Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 638510 - sci-misc/boinc-7.8.1 : crypt.cpp:475:5: error: RSA_get0_key was not declared in this scope
Summary: sci-misc/boinc-7.8.1 : crypt.cpp:475:5: error: RSA_get0_key was not declared ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-22 20:16 UTC by Toralf Förster
Modified: 2020-08-25 10:44 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.64 KB, text/plain)
2017-11-22 20:16 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,131.83 KB, text/plain)
2017-11-22 20:16 UTC, Toralf Förster
Details
environment (environment,151.99 KB, text/plain)
2017-11-22 20:16 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.02 KB, application/x-bzip)
2017-11-22 20:16 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,23.18 KB, application/x-bzip)
2017-11-22 20:17 UTC, Toralf Förster
Details
sci-misc:boinc-7.8.1:20171122-195821.log (sci-misc:boinc-7.8.1:20171122-195821.log,76.26 KB, text/plain)
2017-11-22 20:17 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,46.48 KB, application/x-bzip)
2017-11-22 20:17 UTC, Toralf Förster
Details
Patch to fix Boinc's detection of the current SSL version. (boinc-libressl.patch,447 bytes, patch)
2017-12-05 19:15 UTC, Mark Wagner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-11-22 20:16:45 UTC
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I.. -I../api -I../db -I../lib -I../lib/mac -I../sched -I../tools -I../vda -pthread -Wall -Wextra -Wshadow -Wredundant-decls -Wdisabled-optimization -Wpointer-arith -Wstrict-aliasing -Wcast-align -fPIC -DPIC -pthread -I/usr/include -I/usr/include/openssl -O2 -pipe -march=native -c crypt.cpp  -fPIC -DPIC -o .libs/libboinc_crypt_la-crypt.o
crypt.cpp: In function ‘void openssl_to_keys(RSA*, int, R_RSA_PRIVATE_KEY&, R_RSA_PUBLIC_KEY&)’:
crypt.cpp:475:5: error: ‘RSA_get0_key’ was not declared in this scope
     RSA_get0_key(rp, &n, &e, &d);
     ^~~~~~~~~~~~
crypt.cpp:475:5: note: suggested alternative: ‘RSA_check_key’

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-no-multilib_libressl_20171120-180701

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems) *



emerge -qpv sci-misc/boinc
[ebuild  N    ] sci-misc/boinc-7.8.1  USE="-X -cuda -static-libs" CURL_SSL="libressl -gnutls -openssl"
Comment 1 Toralf Förster gentoo-dev 2017-11-22 20:16:48 UTC
Created attachment 505808 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-11-22 20:16:51 UTC
Created attachment 505810 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-11-22 20:16:54 UTC
Created attachment 505812 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-11-22 20:16:57 UTC
Created attachment 505814 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-11-22 20:17:00 UTC
Created attachment 505816 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-11-22 20:17:03 UTC
Created attachment 505818 [details]
sci-misc:boinc-7.8.1:20171122-195821.log
Comment 7 Toralf Förster gentoo-dev 2017-11-22 20:17:06 UTC
Created attachment 505820 [details]
temp.tbz2
Comment 8 Sven Eden 2017-11-27 16:45:49 UTC
Hmm... I never had this one. I'll see what I can find out, but must ask for some patience. My laptop won't have internet until tomorrow, then I can sync and test.
Comment 9 Mark Wagner 2017-12-05 19:14:04 UTC
OpenSSL changed how elements of RSA keys are accessed between version 1.0 and version 1.1, and Boinc uses the variable OPENSSL_VERSION_NUMBER to detect this.  The problem is that LibreSSL defines itself as "OpenSSL 2.0", despite only being compatible with the OpenSSL 1.0 API.
Comment 10 Mark Wagner 2017-12-05 19:15:06 UTC
Created attachment 508412 [details, diff]
Patch to fix Boinc's detection of the current SSL version.
Comment 11 Sven Eden 2017-12-06 11:41:10 UTC
(In reply to Mark Wagner from comment #10)
> Created attachment 508412 [details, diff] [details, diff]
> Patch to fix Boinc's detection of the current SSL version.

Inspired idea indeed. I'll test that tomorrow, this night I have an appointment.
Comment 12 Sven Eden 2018-03-21 12:15:57 UTC
Sorry for the long delay. Should be fixed by PR https://github.com/gentoo/gentoo/pull/7531
Comment 13 Sven Eden 2018-03-29 05:30:26 UTC
I am still waiting for the PR merge, or Feedback at least, sorry.
Comment 14 Jonas Stein gentoo-dev 2020-08-24 17:58:23 UTC
@asturm were there Closes: lines missing in the merge?
Please have a look at the PR. Can we close this and other tickets?
Comment 15 Andreas Sturmlechner gentoo-dev 2020-08-24 18:08:13 UTC
Hm, you didn't add those Closes: references to this bug. Did they address this one?

Please don't assign me to packages I don't maintain.
Comment 16 Jonas Stein gentoo-dev 2020-08-24 19:51:18 UTC
There were Closes: lines in the comment on
https://github.com/gentoo/gentoo/pull/7531
But I do not know if they were dropped later intentionally or by accident.

@asturm you merged it, so you know best, if other bugs are fixed, or not. 
BTW: This package is not m-n.
Comment 17 Andreas Sturmlechner gentoo-dev 2020-08-24 19:54:49 UTC
Then ffs assign it correctly.

More than two years after proxy-merging some PR I'll have to do the same investigation as anyone else.
Comment 18 Sven Eden 2020-08-25 10:44:17 UTC
The bug has been fixed by https://github.com/gentoo/gentoo/pull/7531 - But I forgot that the "Closes:" statements must be in the commit messages, and not only in the PR description.

Sorry everybody, I failed to check with the bugs!

I am currently waiting for some other PR to merge. Going back into BOINC for some version bumping and review is on my list to do next.