Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638380 - net-misc/dahdi-2.11.1 : /.../dahdi-base.c:5954:7: error: implicit declaration of function signal_pending ; did you mean timer_pending ? [-Werror=implicit-function-declaration]
Summary: net-misc/dahdi-2.11.1 : /.../dahdi-base.c:5954:7: error: implicit declaration...
Status: RESOLVED DUPLICATE of bug 617876
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-21 18:57 UTC by Toralf Förster
Modified: 2018-04-11 17:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.18 KB, text/plain)
2017-11-21 18:57 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,53.11 KB, text/plain)
2017-11-21 18:58 UTC, Toralf Förster
Details
environment (environment,134.27 KB, text/plain)
2017-11-21 18:58 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.54 KB, application/x-bzip)
2017-11-21 18:58 UTC, Toralf Förster
Details
net-misc:dahdi-2.11.1:20171121-184620.log (net-misc:dahdi-2.11.1:20171121-184620.log,9.19 KB, text/plain)
2017-11-21 18:58 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,32.45 KB, application/x-bzip)
2017-11-21 18:58 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-11-21 18:57:55 UTC
   ^~~~~~
/var/tmp/portage/net-misc/dahdi-2.11.1/work/dahdi-linux-2.11.1/drivers/dahdi/dahdi-base.c: In function ‘dahdi_ioctl_iomux’:
/var/tmp/portage/net-misc/dahdi-2.11.1/work/dahdi-linux-2.11.1/drivers/dahdi/dahdi-base.c:5954:7: error: implicit declaration of function ‘signal_pending’; did you mean ‘timer_pending’? [-Werror=implicit-function-declaration]
   if (signal_pending(current)) {
       ^~~~~~~~~~~~~~
       timer_pending

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop-plasma-systemd_libressl_20171120-180801

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv net-misc/dahdi
[ebuild  N    ] net-misc/dahdi-2.11.1  USE="-flash"
Comment 1 Toralf Förster gentoo-dev 2017-11-21 18:57:58 UTC
Created attachment 505508 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-11-21 18:58:01 UTC
Created attachment 505510 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-11-21 18:58:04 UTC
Created attachment 505512 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-11-21 18:58:07 UTC
Created attachment 505514 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-11-21 18:58:10 UTC
Created attachment 505516 [details]
net-misc:dahdi-2.11.1:20171121-184620.log
Comment 6 Toralf Förster gentoo-dev 2017-11-21 18:58:13 UTC
Created attachment 505518 [details]
temp.tbz2
Comment 7 Jaco Kroon 2018-04-11 05:49:24 UTC
Dupe of https://bugs.gentoo.org/617876 ??
Comment 8 Toralf Förster gentoo-dev 2018-04-11 17:14:59 UTC

*** This bug has been marked as a duplicate of bug 617876 ***