Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 638156 - games-emulation/dolphin-5.0 fails to build after gcc-6.4 update
Summary: games-emulation/dolphin-5.0 fails to build after gcc-6.4 update
Status: RESOLVED DUPLICATE of bug 637986
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Devan Franchini (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-19 17:49 UTC by Alex
Modified: 2018-01-11 10:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,309.71 KB, text/x-log)
2017-11-19 17:49 UTC, Alex
Details
Emerge info (emerge.info,4.96 KB, text/plain)
2017-11-19 17:49 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2017-11-19 17:49:12 UTC
Created attachment 504968 [details]
Build log

Hi,

After GCC update to 6.4 games-emulation/dolphin-5.0 fails:
---------------------------------------------------------------------------
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include-fixed/limits.h:168:0,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include-fixed/syslimits.h:7,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include-fixed/limits.h:34,
                 from /var/tmp/portage/games-emulation/dolphin-5.0/work/dolphin-5.0/Source/Core/Common/Common.h:62,
                 from /var/tmp/portage/games-emulation/dolphin-5.0/work/dolphin-5.0/Source/Core/VideoBackends/OGL/RasterFont.cpp:7:
/var/tmp/portage/games-emulation/dolphin-5.0/work/dolphin-5.0/Source/Core/VideoBackends/OGL/RasterFont.cpp:18:18: error: expected unqualified-id before numeric constant
 static const int CHAR_WIDTH = 8;
                  ^
make[2]: *** [Source/Core/VideoBackends/OGL/CMakeFiles/videoogl.dir/build.make:231: Source/Core/VideoBackends/OGL/CMakeFiles/videoogl.dir/RasterFont.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
----------------------------------------------------------------------------

Though I'm not sure that the problem is exactly because of GCC update, but previously I had no problem with building Dolphin.

Build log and emerge info are attached.

Regards,
Alex
Comment 1 Alex 2017-11-19 17:49:47 UTC
Created attachment 504970 [details]
Emerge info
Comment 2 Jan Buecken 2017-12-03 18:29:41 UTC
I assume this is a duplicate of https://bugs.gentoo.org/show_bug.cgi?id=637986

Upstream fix is 
https://github.com/dolphin-emu/dolphin/commit/1963996dd068a081f14fa12f364e9cdf8cd52a41

(as referenced in the other bug)
Comment 3 Sander Sweers 2017-12-08 12:29:01 UTC
Duplicate of bug 637986
Comment 4 David Seifert gentoo-dev 2018-01-11 10:11:01 UTC

*** This bug has been marked as a duplicate of bug 637986 ***