Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63794 - gtk-sharp crasher when built with gcc-3.4.1
Summary: gtk-sharp crasher when built with gcc-3.4.1
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-12 10:19 UTC by Brandon Hale (RETIRED)
Modified: 2004-10-04 17:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brandon Hale (RETIRED) gentoo-dev 2004-09-12 10:19:29 UTC
I just upgraded to gcc 3.4.1 (now ~x86), and pulled an emerge -e world.
Now gtk-sharp apps refuse to work as expected. (blam, muine).

When scrolling in these apps, they crash immediately.
Muine refuses to be traced. Blam outputs a bit of a traceback:


Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
in (unmanaged) (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00004> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00007> Gtk.Application:Run ()
in <0x00007> Gnome.Program:Run ()
in <0x0005a> Imendio.Blam.Application:Main (string[])

/usr/bin/blam: line 6: 25705 Killed                  mono /usr/lib/blam/blam.exe $@

emerge info for fun: emerge info
Portage 2.0.51_pre23 (default-x86-2004.2, gcc-3.4.1, glibc-2.3.4.20040808-r0, 2.6.8-gentoo-r3 i686)
=================================================================
System uname: 2.6.8-gentoo-r3 i686 Intel(R) Pentium(R) M processor 1500MHz
Gentoo Base System version 1.5.3
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux-headers-2.4.22
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium3 -msse2 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -msse2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache cvs sandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/gentoo"
SYNC="rsync://192.168.1.3/gentoo-portage"
USE="X alsa apm avi berkdb bitmap-fonts cdr cdrw crypt cups dvd encode esd flac foomaticdb gdbm gif gnome gpm gtk gtk2 hal imlib jpeg libg++ libwww mad mikmod motif mozilla moznocompose moznoirc moznomail mpeg ncurses nls oggvorbis opengl oss pam pda pdflib perl png python quicktime readline sdl slang spell ssl svga tcpd truetype x86 xml2 xprint xv zlib"
Comment 1 Peter Johanson (RETIRED) gentoo-dev 2004-10-04 17:08:34 UTC
Closing with tseng's consent. He suspects an sse2 optimization bug. Unable to reproduce here.