Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 63761 - torcs-1.2.2 configure dies checking for sin in -lm
Summary: torcs-1.2.2 configure dies checking for sin in -lm
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: PPC Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-12 03:16 UTC by John Steele Scott
Modified: 2006-04-02 14:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge -epv torcs (emerge-epv.txt,11.75 KB, text/plain)
2006-04-02 14:38 UTC, Pacho Ramos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Steele Scott 2004-09-12 03:16:30 UTC
configure: error: Can't find libm. Please check config.log and if you can't solve the problem send the file to eric.espie@free.fr with the subject "torcs compilation problem"

!!! ERROR: games-sports/torcs-1.2.2 failed.
!!! Function egamesconf, Line 56, Exitcode 1
!!! egamesconf failed

fuzz torcs-1.2.2 # tail -n 20 config.log
configure:2233: checking for plib/ssg.h
configure:2243: g++ -E  conftest.C >/dev/null 2>conftest.out
configure:2268: checking for sin in -lm
configure:2290: g++ -o conftest -O2 -mcpu=7450 -maltivec -mabi=altivec -pipe -g3 -ggdb -Wall-Wstrict-prototypes -O3 -mieee-fp   -L/usr/X11R6/lib conftest.C -lm   1>&5
cc1plus: error: invalid option `ieee-fp'
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for C/ObjC but not for C++
configure: failed program was:
#line 2276 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char sin();

int main() {
sin()
; return 0; }

Commenting out line 2054 of configure (ADDCFLAGS="$ADDCFLAGS -mieee-fp") fixes this problem. Note that I'm using gcc-3.4.1-r2 on ppc.

Reproducible: Always
Steps to Reproduce:
Comment 1 Joe Jezak (RETIRED) gentoo-dev 2004-12-12 06:31:07 UTC
This dies because -mieee-fp isn't a valid flag for ppc.  After this fix, the game still isn't playble here, I get segfaults when the race starts.  John did you get the game to actually work?
Comment 2 John Steele Scott 2004-12-13 00:07:47 UTC
I'm pretty sure that I did get this game to run, but I got rid of it because it wasn't much fun playing with the keyboard . . . probably would be fun with a steering wheel though.

Sorry I can't provide any more useful information.
Comment 3 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2004-12-17 14:28:23 UTC
WONTFIX because it doesn't run on ppc after fixing. Maybe a future version.
Comment 4 Pacho Ramos gentoo-dev 2006-04-02 14:38:35 UTC
Created attachment 83761 [details]
emerge -epv torcs

There are some "error" messages because my portage tree is too outdated (because I don't have internet in that computer :(  )

Thanks alot