Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 636842 - dev-libs/boost-1.63.0 conflicts with app-office/libreoffice-bin-5.2.7.2-r1
Summary: dev-libs/boost-1.63.0 conflicts with app-office/libreoffice-bin-5.2.7.2-r1
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-07 22:01 UTC by jorgicio
Modified: 2017-12-05 11:23 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jorgicio 2017-11-07 22:01:51 UTC
Hi!

I noticed what 1.63 version of boost-related packages became stable. However, it conflicts with libreoffice-5.2.7.2-r1 because it needs 1.62.

This happens when I try to do a emerge @world.

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/boost:0

  (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/boost-1.55:0/1.62.0= required by (app-office/libreoffice-bin-5.2.7.2-r1:0/0::gentoo, installed)
                         ^^^^^^^^^^
    dev-libs/boost:0/1.62.0 required by (app-office/libreoffice-bin-5.2.7.2-r1:0/0::gentoo, installed)
                  ^^^^^^^^^
Thanks.

Reproducible: Always
Comment 1 Andreas K. Hüttel gentoo-dev 2017-11-07 22:41:25 UTC
Why does nobody tell me? :(
Comment 2 Jan Beinersdorf 2017-11-08 12:33:59 UTC
Same problem here.
Comment 3 Rodrigo Saboya 2017-11-08 20:57:49 UTC
Any pointers on how to deal with this? Simply updating the dependency on libreoffice-bin is enough to solve the issue?
Comment 4 Andreas K. Hüttel gentoo-dev 2017-11-08 20:59:57 UTC
I'm already building the new libreoffice-bin packages. If nothing goes wrong they should be available by the weekend. Until then the best idea is waiting. (Or if you haven't upgraded boost yet, mask the new boost.)
Comment 5 Andreas K. Hüttel gentoo-dev 2017-11-09 21:56:35 UTC
commit ebc60d7430fee37d95de3eac73c408ee99dce37a (HEAD -> master, origin/master, origin/HEAD)
Author: Andreas K. Hüttel <dilfridge@gentoo.org>
Date:   Thu Nov 9 22:54:52 2017 +0100

    app-office/libreoffice-bin-debug: Version bump. Boost 1.63.
    
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 app-office/libreoffice-bin-debug/Manifest                             | 12 ++++++++++++
 app-office/libreoffice-bin-debug/libreoffice-bin-debug-5.4.2.2.ebuild | 87 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 99 insertions(+)

commit 315b375d909f4a1123d6ccbf7ab0747b6a7f817d
Author: Andreas K. Hüttel <dilfridge@gentoo.org>
Date:   Thu Nov 9 22:53:44 2017 +0100

    app-office/libreoffice-bin: Version bump. Boost 1.63.
    
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 app-office/libreoffice-bin/Manifest                       |  12 +++++++
 app-office/libreoffice-bin/libreoffice-bin-5.4.2.2.ebuild | 250 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 262 insertions(+)
Comment 6 Jan Beinersdorf 2017-11-10 18:03:12 UTC
Seems to work for me. Thanks! :-)
Comment 7 Jan Beinersdorf 2017-11-10 19:57:08 UTC
(In reply to Jan Beinersdorf from comment #6)
> Seems to work for me. Thanks! :-)

...except for one small problem: Trying to spellcheck a document crashes lowriter.

~ # lowriter 
/usr/lib64/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib64/libreoffice/program/../program/libspelllo.so: undefined symbol: _ZNK8Hunspell17get_dict_encodingB5cxx11Ev

Re-emerging hunspell using gcc-5.4 seenms to solve this problem though. (Yes, I'm on of those weird people still using 4.9...) ;-)
Comment 8 Andreas Sturmlechner gentoo-dev 2017-11-10 20:24:57 UTC
(In reply to Jan Beinersdorf from comment #7)
> Re-emerging hunspell using gcc-5.4 seenms to solve this problem though.
> (Yes, I'm on of those weird people still using 4.9...) ;-)
Do not ever mix packages built with <GCC-5 and >=GCC-5. We are unable to support you then.
Comment 9 Alarig Le Lay 2017-11-13 09:09:31 UTC
Hi,

Thanks for the fix :) When do you thinks that the version 5.4.2.2 will be marked as stable?

-- 
alarig
Comment 10 Neil 2017-11-13 10:06:51 UTC
I've found that app-office/libreoffice-bin-5.4.2.2 conflicts with the installed version of dev-libs/boost-1.65.0...

# emerge -av libreoffice-bin
[ebuild  N    ] dev-util/xdelta-3.0.11  USE="-examples -lzma" 
[ebuild  N    ] app-text/libexttextcat-3.4.5  USE="-static-libs" 
[ebuild  N    ] sci-libs/suitesparseconfig-4.2.1-r1  USE="-static-libs" ABI_X86="32 (64) (-x32)" 
[ebuild  N    ] media-fonts/liberation-fonts-2.00.1-r2  USE="X -fontforge" 
[ebuild  N    ] media-fonts/libertine-5.3.0.20120702-r2  USE="X" 
[ebuild  N    ] dev-db/unixODBC-2.3.4-r1  USE="minimal -odbcmanual -static-libs unicode" ABI_X86="32 (64) (-x32)" 
[ebuild  N    ] app-office/libreoffice-l10n-5.4.2.2  USE="-offlinehelp" L10N="-af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -de -dgo -dz -el -en -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-CN -zh-TW -zu" 
[ebuild  N    ] app-crypt/mhash-0.9.9.9-r2  USE="-static-libs" 
[ebuild     UD] dev-util/boost-build-1.63.0 [1.65.0] USE="-examples python {-test}" PYTHON_TARGETS="python2_7" 
[ebuild     UD] dev-libs/boost-1.63.0 [1.65.0] USE="-context -debug -doc icu -mpi nls python -static-libs threads -tools" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" 
[ebuild  N    ] dev-libs/librevenge-0.0.4-r1  USE="-doc {-test}" ABI_X86="32 (64) (-x32)" 
[ebuild  N    ] app-text/libstaroffice-0.0.5  USE="-debug -doc -tools zlib" 
[ebuild  N    ] media-libs/libzmf-0.0.2  USE="-debug -doc {-test} -tools" 
[ebuild  N    ] dev-util/mdds-1.3.1  USE="-valgrind" 
[ebuild  N    ] dev-libs/libixion-0.12.2  USE="-debug python -static-libs threads" PYTHON_SINGLE_TARGET="python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python3_4 -python3_5 -python3_6" 
[ebuild  N    ] dev-libs/liborcus-0.12.1  USE="python spreadsheet-model -static-libs -tools" PYTHON_SINGLE_TARGET="python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python3_4 -python3_5 -python3_6" 
[ebuild  N    ] app-text/libwpd-0.10.2  USE="-doc tools" 
[ebuild  N    ] media-libs/raptor-2.0.15  USE="curl -debug -json -static-libs unicode" 
[ebuild  N    ] dev-cpp/libcmis-0.5.2_pre20160820-r1  USE="-man -static-libs {-test}" 
[ebuild  N    ] media-libs/libcdr-0.1.4  USE="-doc -static-libs {-test}" 
[ebuild  N    ] app-text/libmwaw-0.3.12  USE="-doc -static-libs -tools" 
[ebuild  N    ] app-text/libmspub-0.1.2  USE="-doc -static-libs" 
[ebuild  N    ] app-text/libebook-0.1.2-r1  USE="-doc {-test} -tools" 
[ebuild  N    ] app-text/libwps-0.4.7  USE="-debug -doc -static-libs -tools" 
[ebuild  N    ] media-libs/libpagemaker-0.0.3-r1  USE="-debug -doc -tools" 
[ebuild  N    ] media-libs/libvisio-0.1.6  USE="-doc -static-libs {-test} -tools" 
[ebuild  N    ] app-text/libabw-0.1.1  USE="-doc -static-libs" 
[ebuild  N    ] media-libs/libfreehand-0.1.2  USE="-doc -static-libs {-test}" 
[ebuild  N    ] app-text/mythes-1.2.4  USE="-static-libs" 
[ebuild  N    ] dev-libs/xmlsec-1.2.24-r1  USE="-doc -gcrypt -gnutls -libressl nss openssl -static-libs" 
[ebuild  N    ] net-libs/neon-0.30.2  USE="-doc -expat -gnutls -kerberos -libproxy -libressl nls -pkcs11 ssl -static-libs zlib" ABI_X86="32 (64) (-x32)" 
[ebuild  N    ] app-text/libodfgen-0.1.6  USE="-doc" 
[ebuild  N    ] sci-libs/colamd-2.8.0  USE="-static-libs" 
[ebuild  N    ] sci-mathematics/lpsolve-5.5.2.0  USE="-static-libs" 
[ebuild  N    ] app-text/libwpg-0.3.2  USE="-doc -static-libs" 
[ebuild  N    ] dev-libs/rasqal-0.9.32  USE="crypt -gmp mhash pcre -static-libs {-test} xml" 
[ebuild  N    ] dev-libs/redland-1.0.17-r1  USE="berkdb -iodbc -mysql -odbc -postgres -sqlite -static-libs" 
[ebuild  N    ] app-text/liblangtag-0.6.2  USE="-debug -doc introspection -static-libs {-test}" 
[ebuild  N    ] dev-cpp/clucene-2.3.3.4-r6  USE="-debug -doc -static-libs" 
[ebuild  N    ] media-libs/glm-0.9.8.5  USE="{-test}" CPU_FLAGS_X86="avx -avx2 sse2 sse3" 
[ebuild  N    ] app-text/libetonyek-0.1.7  USE="-doc -static-libs {-test}" 
[ebuild  N    ] app-office/libreoffice-bin-5.4.2.2  USE="-gnome -java -kde" PYTHON_SINGLE_TARGET="-python2_7 python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.63.0 required by (app-office/libreoffice-bin-5.4.2.2:0/0::gentoo, ebuild scheduled for merge)
                  ^^^^^^^^^                                                                                                                             

  (dev-libs/boost-1.65.0:0/1.65.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.65.0= required by (media-gfx/hugin-2017.0:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above


I use ACCEPT_KEYWORDS="~amd64" and masking >dev-libs/boost-1.63.0 solves it but figured I should report this.
Comment 11 Anton Bolshakov 2017-11-14 04:10:54 UTC
please fast forward libreoffice-bin-5.4.2.2 stabilization as it breaks stable user's setup.
Comment 12 Andreas Sturmlechner gentoo-dev 2017-11-14 08:10:46 UTC
It is in progress.
Comment 13 Andreas Sturmlechner gentoo-dev 2017-11-14 17:42:14 UTC
(In reply to Neil from comment #10)
> I've found that app-office/libreoffice-bin-5.4.2.2 conflicts with the
> installed version of dev-libs/boost-1.65.0...
That's not a bug. libreoffice-bin is only built with stable deps.
Comment 14 Andreas Sturmlechner gentoo-dev 2017-12-05 11:23:28 UTC
app-office/libreoffice-bin-5.2.7.2-r1 is no longer in tree.