Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63680 - media-video/mplayer: mencoder coredumps while encoding with a failed assertion
Summary: media-video/mplayer: mencoder coredumps while encoding with a failed assertion
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-11 08:31 UTC by Timmy Douglas
Modified: 2006-06-21 19:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timmy Douglas 2004-09-11 08:31:13 UTC
timmy@main:tmp$ mencoder dvd://1 -slang en -ofps 23.976 -oac copy -vf crop=704:576:0:0,hqdn3d=2:1:2 -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=1600:v4mv:mbd=2:trell:cmp=3:subcmp=3:mbcmp=3:autoaspect:vpass=2 -o movie.avi
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MEncoder 1.0pre5-3.3.4 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1399 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
MMX supported but disabled
MMX2 supported but disabled
SSE supported but disabled
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags: Type: 6 MMX: 0 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions:

Reading /home/timmy/.mplayer/codecs.conf: Can't open '/home/timmy/.mplayer/codecs.conf': No such file or directory
Reading /usr/share/mplayer/codecs.conf: 73 audio & 180 video codecs
AVI file format detected.
VIDEO:  [FrNo]  720x576  24bpp  25.000 fps    0.8 kbps ( 0.1 kbyte/s)
Using pass3 control file: frameno.avi
Reading config file /home/timmy/.mplayer/mencoder: No such file or directory
font: can't open file: /home/timmy/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Reading disc structure, please wait...
There are 7 titles on this DVD.
There are 34 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
success: format: 0  data: 0x0 - 0xAED3000
Selected DVD subtitle channel: 1 language: en
MPEG-PS file format detected.
VIDEO:  MPEG2  720x576  (aspect 3)  25.000 fps  7964.0 kbps (995.5 kbyte/s)
[V] filefmt:2  fourcc:0x10000002  size:720x576  fps:25.00  ftime:=0.0400
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1  (-1=autodetect) osd: 1
Opening video filter: [hqdn3d=2:1:2]
Opening video filter: [crop w=704 h=576 x=0 y=0]
Crop: 704 x 576, 0 ; 0
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.3.1
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
audiocodec: framecopy (format=2000 chans=2 rate=48000 bits=16 bps=56000 sample=1)
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
videocodec: libavcodec (704x576 fourcc=58564944 [DIVX])
High quality encoding selected (non real time)!
Pos:   0.9s     22f ( 0%)   2fps Trem:   0min   0mb  A-V:0.000 [0:448]
Skipping frame!
Pos:   2.2s     55f ( 0%)   3fps Trem:   0min   0mb  A-V:0.000 [1960:448]
Skipping frame!
mencoder: ratecontrol.c:618: ff_rate_estimate_qscale: Assertion `picture_number<rcc->num_entries' failed.
Aborted (core dumped)
timmy@main:tmp$ ls
core  divx2pass.log  frameno.avi  movie.avi  msg.kor  rand.sjis  rip-dvd.sh
timmy@main:tmp$ du -m movie.avi 
286     movie.avi
(gdb) bt
#0  0x403ccf11 in kill () from /lib/libc.so.6
#1  0x4028bb3d in pthread_kill () from /lib/libpthread.so.0
#2  0x4028be9b in raise () from /lib/libpthread.so.0
#3  0x403ccb12 in raise () from /lib/libc.so.6
#4  0x403ce380 in abort () from /lib/libc.so.6
#5  0x403c6010 in __assert_fail () from /lib/libc.so.6
#6  0x082663fd in ff_rate_estimate_qscale ()
#7  0x081919e3 in ff_copy_bits ()
#8  0x0818bfdf in MPV_encode_picture ()
#9  0x08185419 in avcodec_encode_video ()
#10 0x0808c5f7 in vf_open_encoder ()
#11 0x0809fe89 in vf_next_put_image ()
#12 0x0809fe89 in vf_next_put_image ()
#13 0x0809fe89 in vf_next_put_image ()
#14 0x08096950 in decode_video ()
#15 0x080657ec in main ()


Reproducible: Didn't try
Steps to Reproduce:
1.
2.
3.




Portage 2.0.50-r11 (2004.2, gcc-3.3.4, glibc-2.2.5-r2,2.3.4.20040808-r0, 2.6.8-rc2)
=================================================================
System uname: 2.6.8-rc2 i686 AMD Athlon(tm) XP 1600+
Gentoo Base System version 1.5.3
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-mcpu=athlon-xp -O2 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=athlon-xp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache fixpackages sandbox sfperms"
GENTOO_MIRRORS="http://mirrors.tds.net/gentoo http://gentoo.oregonstate.edu
http://www.ibiblio.org/pub/Linux/distributions/gentoo
http://csociety-ftp.ecn.purdue.edu/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X aalib aim alsa apm arts avi berkdb bonobo canna cjk crypt debug dga dvd
emacs encode esd foomaticdb gdbm gif gnome gpm gtk gtk2 gtkhtml guile iconv imap
imlib ipv6 java jpeg kde leim libg++ libwww mad mikmod mmap motif mozilla mpeg
msn ncurses nls nostrip oggvorbis oss pam pdflib perl png python qt quicktime
readline sdl slang spell ssl svga tcltk tcpd tiff truetype unicode x86 xml2 xmms
xv zlib"
Comment 1 Jan Brinkmann (RETIRED) gentoo-dev 2005-05-05 09:56:03 UTC
is this still an issue with newer versions?
Comment 2 Timmy Douglas 2005-05-05 10:41:25 UTC
i don't remember what dvd it was so i can't really check. Seems like it's still there though:

 http://article.gmane.org/gmane.comp.video.mplayer.user/36018
Comment 3 Steve Dibb (RETIRED) gentoo-dev 2006-06-21 16:30:43 UTC
*bump*, is this still an issue?  Can it be duplicated with pre8?
Comment 4 Timmy Douglas 2006-06-21 19:23:50 UTC
I don't know. I'm not going to bother trying so you might as well close it. Looking into the problem back in 2004 might have been a better way to get to the root of the issue though...