Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63574 - perl-5.8.4-r1 fails to emerge
Summary: perl-5.8.4-r1 fails to emerge
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Perl team
Depends on:
Reported: 2004-09-10 11:20 UTC by Michael B
Modified: 2005-07-19 16:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Error log of emerge session (emergeerrors.txt,26.99 KB, text/plain)
2004-09-10 14:22 UTC, Michael B

Note You need to log in before you can comment on or make changes to this bug.
Description Michael B 2004-09-10 11:20:56 UTC
Whenever I try to emerge any package, the system ends up failing with src_compile errors

Reproducible: Always
Steps to Reproduce:
1.Login to desktop, open terminal, su to root...
2.Type "emerge {package name}" 
3.Wait for the errors to show up. :)

Actual Results:  
The system starts getting the files and unpacking them, etc. The program then 
terminates, usually with an src_compile error and the program never works. The 
one program that I have tried several times to download is AMSN...   

Expected Results:  
According to the documentation, the program should download, install and then 
run as normal 

Portage 2.0.50-r11 (default-x86-2004.0, gcc-3.3.4, glibc-, 
System uname: 2.4.26-gentoo-r9 i686 Pentium III (Katmai) 
Gentoo Base System version 1.4.16 
Autoconf: sys-devel/autoconf-2.59-r4 
Automake: sys-devel/automake-1.8.5-r1 
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer" 
FEATURES="autoaddcvs ccache sandbox" 
USE="X apm arts avi berkdb bitmap-fonts crypt cups encode esd foomaticdb gdbm 
gif gnome gpm gtk gtk2 imlib java jpeg kde libg++ libwww mad mikmod motif mpeg 
ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime 
readline sdl slang spell ssl svga tcltk tcpd truetype x86 xml2 xmms xprint xv 
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2004-09-10 11:24:30 UTC
can you possibly give us a list of what's failing? 

And, more importantly can you actually show us the log of the emerge?
Comment 2 Seemant Kulleen (RETIRED) gentoo-dev 2004-09-10 11:48:25 UTC
Please reopen this bug when you can provide some useful information for us (See above comment)
Comment 3 Michael B 2004-09-10 12:28:14 UTC
"And, more importantly can you actually show us the log of the emerge?"

Isnt that what I sent you in the txt file? Or is there some other way that I should log it for you?
Comment 4 Michael B 2004-09-10 14:22:57 UTC
Created attachment 39357 [details]
Error log of emerge session

Originally sent via email - if this is not what you're after, please let me
Comment 5 Michael B 2004-09-10 14:23:35 UTC
File attached. Please see comments.
Comment 6 Mark Dominik Bürkle 2004-12-04 08:57:05 UTC
Though I'm a newbie to Gentoo this doesn't look perl-related to me.

Some parts from the attached log file (attachment#39357 [details]):
You have the full sem*(2) library.
You do not have union semun in <sys/sem.h>.
*** WHOA THERE!!! ***
    The recommended value for $d_semctl_semun on this machine was "define"!
    Keep the recommended value? [y]
You can use union semun for semctl IPC_STAT.
You can also use struct semid_ds* for semctl IPC_STAT.
cd x2p; make depend
make[1]: Entering directory
`sh  cflags "optimize='-O2 -mcpu=i686 -fomit-frame-pointer'" toke.o` -fPIC
          CCCMD =  gcc -DPERL_CORE -c -fno-strict-aliasing
-fomit-frame-pointer  -Wall
gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <URL:> for instructions.
make: *** [toke.o] Error 1

!!! ERROR: dev-lang/perl-5.8.4-r1 failed.
!!! Function src_compile, Line 215, Exitcode 2

Looks to me like some (Your local system) misconfiguration is killing cc.
I guess this is not limited to emerging perl, consider adding something like "gcc: Internal error: Killed (program cc1)" to the subject.

MichaelB: if You want Your problem to be solved, then You have to be more cooperative and being a little bit more polite might help as well.
Comment 7 Michael Cummings (RETIRED) gentoo-dev 2005-07-19 16:30:36 UTC
Going to close this because it was sadly neglected. Please reopen if this occurs
with a current version of perl. Looks an awful lot like a broken gcc flag to me