Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 635380 - media-sound/lame-3.99.5-r1 autoconf fails to compile if GTK+ is not installed / searching for deprecated GTK+1
Summary: media-sound/lame-3.99.5-r1 autoconf fails to compile if GTK+ is not installed...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
Depends on: CVE-2017-15045, CVE-2017-15046
  Show dependency tree
Reported: 2017-10-25 00:36 UTC by Jesús P Rey (Chuso)
Modified: 2019-11-15 20:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

lame-3.99.5-remove_gtk.patch (lame-3.99.5-remove_gtk.patch,498 bytes, patch)
2017-10-25 00:36 UTC, Jesús P Rey (Chuso)
Details | Diff
lame-3.99.5-r2.ebuild (lame-3.99.5-r2.ebuild,2.33 KB, text/plain)
2017-10-25 00:38 UTC, Jesús P Rey (Chuso)

Note You need to log in before you can comment on or make changes to this bug.
Description Jesús P Rey (Chuso) 2017-10-25 00:36:20 UTC
Created attachment 500000 [details, diff]

If GTK+ is not installed, media-sound/lame-3.99.5-r1 fails in the autoconf step because it unconditionally checks for GTK+ version: error: possibly undefined macro: AM_PATH_GTK
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Additionally, the current ebuild already patches some GTK+ stuff (lame-3.98-gtk-path.patch), but AFAIK lame only supports GTK+1, which is abandoned upstream and removed from Portage.

I suggest removing lame-3.98-gtk-path.patch and removing the GTK+ obsolete check from autoconf. That worked to fix the autoconf error in my case.

Related: #168123
Comment 1 Jesús P Rey (Chuso) 2017-10-25 00:38:26 UTC
Created attachment 500002 [details]

ebuild with the patch to remove GTK+
Comment 2 Pacho Ramos gentoo-dev 2019-11-10 15:02:59 UTC
still valid with lame-3.100-r1.ebuild?
Comment 3 Jesús P Rey (Chuso) 2019-11-14 21:04:57 UTC
(In reply to Pacho Ramos from comment #2)
> still valid with lame-3.100-r1.ebuild?

Seems fixed in that version. I just tried to merge it in a system without GTK+ and it's no longer throwing that error.
Comment 4 Pacho Ramos gentoo-dev 2019-11-15 20:12:49 UTC