Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63529 - A Weird Shortcut Menu Problem of KDE 3.3 on PPC64
Summary: A Weird Shortcut Menu Problem of KDE 3.3 on PPC64
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: PPC64 Linux
: High critical (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-09-10 03:13 UTC by Yang Dehua
Modified: 2005-03-14 10:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

the shot (kde-bug.png,25.38 KB, image/png)
2004-09-21 11:59 UTC, Markus Rothe (RETIRED)
patch for kdelibs-3.3.2 on ppc64 (kdelibs-3.3.2-ppc64.patch,892 bytes, patch)
2005-01-26 07:08 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for kdelibs-3.3.2-r2.ebuild (kdelibs-3.3.2-r2.ebuild.patch,386 bytes, patch)
2005-01-26 07:09 UTC, Yuta SATOH (RETIRED)
Details | Diff
New patch from upstream bugs (kdelibs-3.3.2-ppc64-upstream.patch,1.18 KB, patch)
2005-03-13 10:51 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for kdelibs-3.3.2-r5.ebuild (kdelibs-3.3.2-r5.ebuild.patch,309 bytes, patch)
2005-03-13 10:54 UTC, Yuta SATOH (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yang Dehua 2004-09-10 03:13:32 UTC
I emerged KDE 3.3 successfully in my G5 under 2004.2 PPC64 linux. KDE seemed to be working fine but with one weird problem: The key shortcuts donnt work as expected. For example, when I opened kwrite to input uppercase letters by pressing <shift>+<letter>, I got a menu displayed on the upper left of the window, listing all shortcut keys being able to use in editing, though the letter actually appeared in the editing area.The shortcut menu would disappear when any key typed. In fact this is true for almost all kde/qt applications I tried: <ctrl>+<any key>or<shift>+<any key> would bring a menu listing all shortcuts available in the context out, even though that's not needed at all.
Comment 1 Markus Rothe (RETIRED) gentoo-dev 2004-09-21 11:58:12 UTC

I have the same problem and made a screenshot of it, because it is not clearly evident if you didn't saw this before... ;-)

I'll attatch the picture.

Comment 2 Markus Rothe (RETIRED) gentoo-dev 2004-09-21 11:59:22 UTC
Created attachment 40116 [details]
the shot
Comment 3 Markus Rothe (RETIRED) gentoo-dev 2004-09-21 12:00:51 UTC
add: This is a ppc64 bug! I don't get this on my amd machine.

Comment 4 Yang Dehua 2004-09-21 17:23:44 UTC
Yes, exactly the same problem here as shown by the screenshot.
Comment 5 Markus Rothe (RETIRED) gentoo-dev 2004-11-04 04:25:45 UTC
anybody tried 3.3.1?

Comment 6 Markus Rothe (RETIRED) gentoo-dev 2004-11-06 12:33:13 UTC
opened a bug for that at

Comment 7 Markus Rothe (RETIRED) gentoo-dev 2004-11-06 12:33:39 UTC
btw: 3.3.1 didn't solved the problem...
Comment 8 Yuta SATOH (RETIRED) gentoo-dev 2005-01-26 07:08:45 UTC
Created attachment 49561 [details, diff]
patch for kdelibs-3.3.2 on ppc64

file name is kdelibs-3.3.2-ppc64.patch
Comment 9 Yuta SATOH (RETIRED) gentoo-dev 2005-01-26 07:09:30 UTC
Created attachment 49562 [details, diff]
patch for kdelibs-3.3.2-r2.ebuild
Comment 10 Yuta SATOH (RETIRED) gentoo-dev 2005-01-26 07:09:56 UTC
This problem stopped occurring in my environment by applying these patches. 
And, shortcut keys also seems to operate normally. 

However, I'm diffident of change of these codes.
So, I will investigate about this problem for a while.

I'm glad if this patch is a help to someone who discovers a better method.

Thank you.
Comment 11 Simone Gotti (RETIRED) gentoo-dev 2005-01-26 07:16:38 UTC
Are you the author of these patches? Can you please report upstream to the bug number reported in comment #6 ? So they can be reviewed by the developers of the involved library. Thanks.
Comment 12 Yuta SATOH (RETIRED) gentoo-dev 2005-01-26 08:37:05 UTC
I reported to the upstream bug.
Thank you for your advice. 
Comment 13 Yuta SATOH (RETIRED) gentoo-dev 2005-03-13 10:51:13 UTC
Created attachment 53354 [details, diff]
New patch from upstream bugs

This problem was solved in the upstream bugs. (comment #6)
This patch for kdelibs-3.3.2-r5.
Comment 14 Yuta SATOH (RETIRED) gentoo-dev 2005-03-13 10:54:16 UTC
Created attachment 53355 [details, diff]
patch for kdelibs-3.3.2-r5.ebuild
Comment 15 Markus Rothe (RETIRED) gentoo-dev 2005-03-14 10:01:46 UTC
Fixed in CVS. Thx nigoro!!!
Comment 16 Markus Rothe (RETIRED) gentoo-dev 2005-03-14 10:02:08 UTC
marking as FIXED
Comment 17 Markus Rothe (RETIRED) gentoo-dev 2005-03-14 10:02:17 UTC