Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 634916 - www-servers/varnish-5.1.3 will not install: build freezes
Summary: www-servers/varnish-5.1.3 will not install: build freezes
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-21 01:34 UTC by deference
Modified: 2018-07-23 08:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build-varnish.txt,140.39 KB, text/plain)
2017-10-21 01:34 UTC, deference
Details
emerge --info (emergeinfo-varnish.txt,31.33 KB, text/plain)
2017-10-21 01:34 UTC, deference
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deference 2017-10-21 01:34:23 UTC
[ebuild   R   ] www-servers/varnish-5.1.3  USE="jemalloc* jit static-libs" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5) (-python3_6)" 

When trying to install with jemalloc the compilation freezes part way through. 
This happens every time and I've let it sit for hours without anything ever 
happening, in the end I kill the process. The box I try to install it on is not 
connected to the internet, but this does not appear to be a network related 
error. This affects all the versions of varnish I've tested. I relize that I 
don't remember all the version numbers but anything around the time of the last 
6 months that has made it into portage I have probably tested.

If you need anything more just yell.
Comment 1 deference 2017-10-21 01:34:38 UTC
Created attachment 499436 [details]
build.log
Comment 2 deference 2017-10-21 01:34:46 UTC
Created attachment 499438 [details]
emerge --info