Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 634704 - media-sound/lame-3.99.5-r1 incorrectly guessed p0 patching - Failed Running autoconf !
Summary: media-sound/lame-3.99.5-r1 incorrectly guessed p0 patching - Failed Running a...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-19 01:32 UTC by Eugene Cormier
Modified: 2017-10-22 20:03 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (file_634704.txt,3.31 KB, text/plain)
2017-10-19 01:32 UTC, Eugene Cormier
Details
emerge command and output (file_634704.txt,4.23 KB, text/plain)
2017-10-19 01:33 UTC, Eugene Cormier
Details
autoconf.out (file_634704.txt,304 bytes, text/plain)
2017-10-19 01:33 UTC, Eugene Cormier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Cormier 2017-10-19 01:32:45 UTC
Created attachment 499174 [details]
Build log

Lame fails to install here on a fresh install:
* Running aclocal -I . ...                                                                                   [ ok ] 
 * This package has a configure.in file which has long been deprecated.  Please                                      
 * update it to use configure.ac instead as newer versions of autotools will die                                     
 * when it finds this file.  See https://bugs.gentoo.org/426262 for details.
 * Running autoconf -I . --force ...
Comment 1 Eugene Cormier 2017-10-19 01:33:24 UTC
Created attachment 499176 [details]
emerge command and output
Comment 2 Eugene Cormier 2017-10-19 01:33:51 UTC
Created attachment 499178 [details]
autoconf.out
Comment 3 Eugene Cormier 2017-10-19 01:35:24 UTC
more relevant info here:
http://lame.cvs.sourceforge.net/viewvc/lame/lame/acinclude.m4?r1=1.5&r2=1.6
Comment 4 Adam Pardyl 2017-10-19 09:10:35 UTC
I can confirm this bug on a fresh amd64 default/linux/amd64/13.0/desktop/gnome/systemd install (encountered while emerging chromium dependencies)
Comment 5 Peter Große 2017-10-20 12:04:02 UTC
In the commit 

https://gitweb.gentoo.org/repo/gentoo.git/commit/media-sound/lame?id=cac3017eed6bec4140ba2dec99d67365bb1da66f

2 days ago, the lame-3.98-gtk-path.patch was modified and broke the build.
Reverting that change fixed it.
Comment 6 gentoo 2017-10-20 15:14:50 UTC
I can also confirm this on a fresh amd64 default/linux/amd64/13.0/desktop, also while emerging chromium dependencies.
Comment 7 Ryan 2017-10-20 17:41:58 UTC
I also encountered this bug when trying to emerge kde-plasma/plasma-meta on a fresh amd64 install with profile default/linux/amd64/13.0/desktop/plasma
Comment 8 Martin McClure 2017-10-20 18:33:34 UTC
I'm also seeing this installing a new system, installing lame presumably as a dependency of kde-plasma/plasma-meta. Profile default/linux/amd64/13.0/desktop/plasma/systemd.
Comment 9 Ryan 2017-10-20 18:38:06 UTC
If you're looking for a quick fix, revert to the previous commit by doing: 

cd /usr
rm -rf portage
wget https://gitweb.gentoo.org/repo/gentoo.git/snapshot/gentoo-fe177ad7b8aa78ca7c81a1f3b8a64d02163b6466.tar.bz2
tar xvjf gentoo-fe177ad7b8aa78ca7c81a1f3b8a64d02163b6466.tar.bz2
mv gentoo-fe177ad7b8aa78ca7c81a1f3b8a64d02163b6466 portage

and then try to emerge whatever you were trying to emerge. This may not be the right way to do it, but it worked for me.
Comment 10 Aleksandr Wagner (Kivak) 2017-10-20 23:59:45 UTC
I am having this exact same issue. I made a new install today using the default/linux/amd64/13.0/desktop profile. Emerging media-sound/lame-3.99.5-r1 results in the configure.in error.

However, on my system I was able to install media-sound/lame-3.100 without any errors. If you are going to follow this route, do so with caution. The package is not currently stable in Gentoo.
Comment 11 Dmitry Grigoriev 2017-10-21 01:08:16 UTC
I confirm on fresh installation (amd64, default & desktop profiles); unmasking and installing version 3.100 solved the problem.
Comment 12 gentoo 2017-10-21 07:29:26 UTC
(In reply to Dmitry Grigoriev from comment #11)
> I confirm on fresh installation (amd64, default & desktop profiles);
> unmasking and installing version 3.100 solved the problem.

Thanks for the hint on installing 3.100. This solved the issue also for me.
Comment 13 Ben Kohler gentoo-dev 2017-10-22 18:19:49 UTC
I think what's going on here is that the gtk path patch is still "successfully" applying at -p0 when epatch runs it, even though it's now a p1 formatted patch.  So it creates a/gtk.m4 rather than gtk.m4, and apparently triggers some more autoreconf stuff.

epatch.log:

PATCH: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/files/lame-3.96-ccc.patch
CMD: patch -p1 -g0 -E --no-backup-if-mismatch
PWD: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5

PATCH: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/files/lame-3.98-gtk-path.patch
CMD: patch -p0 -g0 -E --no-backup-if-mismatch
PWD: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5

PATCH: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/files/lame-3.99.5-tinfo.patch
CMD: patch -p1 -g0 -E --no-backup-if-mismatch
PWD: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5

PATCH: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/files/lame-3.99.5-msse.patch
CMD: patch -p1 -g0 -E --no-backup-if-mismatch
PWD: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5

PATCH: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5-automake-2.12.patch
CMD: patch -p1 -g0 -E --no-backup-if-mismatch
PWD: /mnt/disk/var-tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5
Comment 14 Ben Kohler gentoo-dev 2017-10-22 18:32:51 UTC
Forcing -p1 on the existing ebuild seems to work.


--- a/media-sound/lame/lame-3.99.5-r1.ebuild
+++ b/media-sound/lame/lame-3.99.5-r1.ebuild
@@ -28,7 +28,7 @@
        cpu_flags_x86_mmx? ( dev-lang/nasm )"

 src_prepare() {
-       epatch \
+       epatch -p1 \
                "${FILESDIR}"/${PN}-3.96-ccc.patch \
                "${FILESDIR}"/${PN}-3.98-gtk-path.patch \
                "${FILESDIR}"/${PN}-3.99.5-tinfo.patch \
Comment 15 Larry the Git Cow gentoo-dev 2017-10-22 20:03:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=72e26e68d470c0123bcfa0ba4a0e5d9bb82370ea

commit 72e26e68d470c0123bcfa0ba4a0e5d9bb82370ea
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2017-10-22 20:03:21 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2017-10-22 20:03:30 +0000

    media-sound/lame: Circumvent broken epatch directory detection, bug 634704
    
    Closes: https://bugs.gentoo.org/634704
    Package-Manager: Portage-2.3.12, Repoman-2.3.3

 media-sound/lame/lame-3.99.5-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)