Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 634140 - sys-block/gparted-0.27.0 BlockSpecial.cc:64:31: error: ‘major’ was not declared in this scope
Summary: sys-block/gparted-0.27.0 BlockSpecial.cc:64:31: error: ‘major’ was not declar...
Status: RESOLVED DUPLICATE of bug 602222
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gilles Dartiguelongue
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2017-10-12 22:23 UTC by ernsteiswuerfel
Modified: 2017-10-13 09:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_634140.txt,6.29 KB, text/plain)
2017-10-12 22:23 UTC, ernsteiswuerfel
Details
build.log (gparted_build.log,17.09 KB, text/x-log)
2017-10-12 22:23 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2017-10-12 22:23:00 UTC
Created attachment 498474 [details]
emerge --info

I did an emerge -e world after upgrading to sys-libs/glibc-2.25-r7. One of the two packages failed to build was sys-block/gparted-0.27.0.

=sys-block/gparted-0.28.1
=sys-block/gparted-0.29.0
build an run fine on my setup.
Comment 1 ernsteiswuerfel 2017-10-12 22:23:36 UTC
Created attachment 498476 [details]
build.log
Comment 2 Tomáš Mózes 2017-10-13 04:31:26 UTC
Yes, 0.29.0 has this fixed and is currently being stabilized.

# diff -u gparted-0.27.0/src/BlockSpecial.cc gparted-0.29.0/src/BlockSpecial.cc 
--- gparted-0.27.0/src/BlockSpecial.cc  2016-10-10 22:05:50.000000000 +0200
+++ gparted-0.29.0/src/BlockSpecial.cc  2017-02-04 18:41:03.000000000 +0100
@@ -14,11 +14,12 @@
  *  along with this program; if not, see <http://www.gnu.org/licenses/>.
  */
 
-#include "../include/BlockSpecial.h"
+#include "BlockSpecial.h"
 
 #include <glibmm/ustring.h>
 #include <sys/types.h>
 #include <sys/stat.h>
+#include <sys/sysmacros.h>
 #include <unistd.h>
 #include <map>

The important part is including <sys/sysmacros.h> that was missing from 0.27.0.
Comment 3 Gilles Dartiguelongue gentoo-dev 2017-10-13 09:34:25 UTC

*** This bug has been marked as a duplicate of bug 602222 ***