Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 632106 - >media-libs/fontconfig-2.11.1-r2 - x11-terms/rxvt-unicode utf-8 characters missing
Summary: >media-libs/fontconfig-2.11.1-r2 - x11-terms/rxvt-unicode utf-8 characters mi...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Fonts Team
Depends on:
Reported: 2017-09-26 21:52 UTC by Brian G. Olson
Modified: 2021-08-17 13:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Tofu characters (fontconfig-rxvt.png,21.10 KB, image/png)
2017-09-26 21:52 UTC, Brian G. Olson

Note You need to log in before you can comment on or make changes to this bug.
Description Brian G. Olson 2017-09-26 21:52:12 UTC
Created attachment 496614 [details]
Tofu characters

I lose some characters when using either media-libs/fontconfig 2.12.3-r1 or 2.12.4 with x11-terms/rxvt-unicode (See attached picture). media-libs/fontconfig-2.11.1-r2 works fine with x11-terms/rxvt-unicode 9.21 and 9.22-r1 (I didn't try 9.22).

The figure is with 'Noto Mono for Powerline', but regular 'Noto Mono', and 'Inconsolata' both show the same behavior.

First column of characters in figure (working) is with:

emerge media-libs/fontconfig-2.11.1-r2

Second column of characters in figure (tofu) is with:

emerge media-libs/fontconfig-2.12.4

The list of characters showing as tofu is not exhaustive, they are simply the characters I use most often so I've noticed them.

Steps to reproduce:

1) Emerge the package >media-libs/fontconfig-2.11.1-r2 (no other packages are emerged/unmerged/re-emerged)
2) Open urxvt, see tofu characters.
3) Emerge the package =media-libs/fontconfig-2.11.1-r2 (no other packages are emerged/unmerged/re-emerged)
4) Open urxvt, see all expected characters.
Comment 1 Tomáš Mózes 2018-01-12 03:37:31 UTC
Can you please try the latest unstable fontconfig and rxvt-unicode? Does it help?
Comment 2 Brian G. Olson 2018-01-12 20:54:48 UTC
I just tried fontconfig-2.12.6 with both rxvt-unicode-9.22 and 9.22-r1 with no luck. All characters show when using fontconfig-2.11-r2 with rxvt-unicode-9.21, 9.22, and 9.22-r1.
Comment 3 Marek Szuba archtester gentoo-dev 2021-08-17 13:35:46 UTC
The problem here lies not with fontconfig or rxvt-unicode but with the fonts you use. At least as far as Inconsolata is concerned, the characters you have tried to use are simmply not there... I presume it used to work with older fontconfig because it somehow handled the font fallback for you.

The "solution" here is to have a fallback font configured for urxvt; The one I have seen mentioned most often in this context is Symbola but in principle any symbol/emoji font should work here. Then add something along the lines of

*font: xft:Inconsolata:size=12, xft:Symbola:size=8

to your URxvt configuration (scaling the symbol font down is necessary because rxvt-unicode does not render fallback characters whose width is larger
than the glyph box of the primary font).