Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 632016 - dev-lang/spidermonkey-24.2.0-r3 does not compile with gcc-7.2
Summary: dev-lang/spidermonkey-24.2.0-r3 does not compile with gcc-7.2
Status: RESOLVED DUPLICATE of bug 601030
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-7
  Show dependency tree
 
Reported: 2017-09-25 21:39 UTC by Alexander Pitzer
Modified: 2017-10-03 18:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,161.81 KB, text/x-log)
2017-09-25 21:40 UTC, Alexander Pitzer
Details
patch (spidermonkey-24.2.0-gcc-7.patch,423 bytes, patch)
2017-09-25 22:01 UTC, Alexander Pitzer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pitzer 2017-09-25 21:39:13 UTC
spidermonkey fails to compile with gcc 7.2 because of the the new compiler rules:

 error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
         if (value[0] == '\0')


Reproducible: Always
Comment 1 Alexander Pitzer 2017-09-25 21:40:24 UTC
Created attachment 496414 [details]
build.log
Comment 2 Alexander Pitzer 2017-09-25 22:01:50 UTC
Created attachment 496418 [details, diff]
patch

this patch should fix the problem
Comment 3 Ian Stakenvicius (RETIRED) gentoo-dev 2017-10-03 18:58:28 UTC
Already addressed in spidermonkey-24.2.0-r4

*** This bug has been marked as a duplicate of bug 601030 ***