Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 631798 - <app-office/lyx-2.3.0 optionally depends on deprecated Qt4 (was: clean up Qt 4 support)
Summary: <app-office/lyx-2.3.0 optionally depends on deprecated Qt4 (was: clean up Qt ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: qt4-removal
  Show dependency tree
 
Reported: 2017-09-23 02:09 UTC by Michael Palimaka (kensington)
Modified: 2018-04-26 15:36 UTC (History)
4 users (show)

See Also:
Package list:
app-office/lyx-2.3.0
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2017-09-23 02:09:57 UTC
app-office/lyx has a Qt 5 USE flag that toggles between Qt 4 and Qt 5 support.

Since Qt 4 is dead, please remove the qt5 USE flag and just enable support unconditionally.
Comment 1 pavel sanda 2017-09-23 16:12:02 UTC
As explained in bug #595470, I am not switching to qt 5, so if this step is necessary it is time for me to depart from proxy-maintaining of LyX package,
at least for any foreseeable future.

Thanks for cooperation for all these long years! :)
Pavel
Comment 2 Michael Palimaka (kensington) gentoo-dev 2017-09-24 02:49:35 UTC
While the cleanup will definitely happen at some point, there's no immediate rush as there's still many many other revdeps that can be considered first.
Comment 3 Andreas Sturmlechner gentoo-dev 2018-02-04 13:10:42 UTC
Pavel, can we clean up <2.2.3-r1 for the time being? This does not yet remove the Qt4 option.
Comment 4 pavel sanda 2018-02-07 20:56:09 UTC
I'd say delete 2.0.8.1-r1, 2.2.2-r1, 2.2.3.
I would let 2.1.5-r1 alive for some time, 2.2.3 was stabilized only recently.
Comment 5 Andreas Sturmlechner gentoo-dev 2018-03-13 23:14:13 UTC
The next version bump should only contain Qt5 support. Optional Qt4-support can be kept in an overlay, except that at some point Qt4 will be removed from tree (and possibly moved to graveyard overlay or wherever Qt team decides to put it)
Comment 6 pavel sanda 2018-03-14 08:20:07 UTC
Ok, this is likely my last contribution...

At rebutia overlay there is ebuild for completely new release serie 2.3.0
https://github.com/gentoo-mirror/rebutia/blob/master/app-office/lyx/lyx-2.3.0.ebuild
with prepared patches for python which should be enough for next two or so years:
https://github.com/gentoo-mirror/rebutia/blob/master/app-office/lyx/files/2.3-python.patch


The ebuild is for both qt4 & qt5, you can strip (tested) qt4 part and commit it to portage after testing it runs for qt5.

Feel free to contact me for any packaging/bug questions, but my position as (proxy) maintainer came to its end as announced.
Comment 7 Larry the Git Cow gentoo-dev 2018-03-30 18:09:46 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=07e82fd1fc07bf055c78b81eaa128f8f837da80d

commit 07e82fd1fc07bf055c78b81eaa128f8f837da80d
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-03-30 18:03:13 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-03-30 18:09:30 +0000

    app-office/lyx: Fix build with Qt 5.11
    
    Bug: https://bugs.gentoo.org/631798
    Package-Manager: Portage-2.3.27, Repoman-2.3.9

 app-office/lyx/files/lyx-2.3.0-qt-5.11.patch | 16 ++++++++++++++++
 app-office/lyx/lyx-2.3.0.ebuild              |  5 ++++-
 2 files changed, 20 insertions(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e3a198c8cee1f6effc78352b2460f7700b74562d

commit e3a198c8cee1f6effc78352b2460f7700b74562d
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-03-30 17:28:31 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-03-30 18:09:30 +0000

    app-office/lyx: 2.3.0 version bump
    
    Thanks-to: pavel sanda <ps@twin.jikos.cz>
    Bug: https://bugs.gentoo.org/631798
    Package-Manager: Portage-2.3.27, Repoman-2.3.9

 app-office/lyx/Manifest                     |   1 +
 app-office/lyx/files/lyx-2.3.0-python.patch |  30 +++++
 app-office/lyx/lyx-2.3.0.ebuild             | 177 ++++++++++++++++++++++++++++
 3 files changed, 208 insertions(+)}
Comment 8 Andreas Sturmlechner gentoo-dev 2018-03-30 18:19:11 UTC
(In reply to pavel sanda from comment #6)
> Ok, this is likely my last contribution...

Thanks for your contributions in all this time!

> Feel free to contact me for any packaging/bug questions, but my position as
> (proxy) maintainer came to its end as announced.

If you could please forward (trivial) qt-5.11 buildfix to upstream, added in commit 07e82fd1fc07bf055c78b81eaa128f8f837da80d.
Comment 9 pavel sanda 2018-04-02 14:14:20 UTC
(In reply to Andreas Sturmlechner from comment #8)
> If you could please forward (trivial) qt-5.11 buildfix to upstream, added in
> commit 07e82fd1fc07bf055c78b81eaa128f8f837da80d.

Ok, this buildfix will be part of 2.3.1.

Also, 2.3.0 does not support automake 1.16 (2.3.1 will).
One can either use the following patch or request 1.15 or ignore the issue until 2.3.1 is out.


https://www.lyx.org/trac/changeset/3abfd72b2720c21eba51bb2338f0b8b835dae720/lyxgit
Comment 10 Larry the Git Cow gentoo-dev 2018-04-02 21:29:40 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ceac2c53741cde2446ce458a60b09082e6756c2a

commit ceac2c53741cde2446ce458a60b09082e6756c2a
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-04-02 21:08:12 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-04-02 21:29:24 +0000

    app-office/lyx: Fix build with automake-1.16
    
    Bug: https://bugs.gentoo.org/648318
    Bug: https://bugs.gentoo.org/631798
    Thanks-to: pavel sanda <ps@twin.jikos.cz>
    Package-Manager: Portage-2.3.28, Repoman-2.3.9

 app-office/lyx/files/lyx-2.3.0-autotools.patch | 27 ++++++++++++++++++++++++++
 app-office/lyx/lyx-2.3.0.ebuild                |  1 +
 2 files changed, 28 insertions(+)}
Comment 11 Andreas Sturmlechner gentoo-dev 2018-04-21 15:20:28 UTC
Arches, please stabilise.
Comment 12 Larry the Git Cow gentoo-dev 2018-04-22 20:34:04 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f953d18252037273a89e33a6c13d8279e6360aea

commit f953d18252037273a89e33a6c13d8279e6360aea
Author:     Aaron Bauman <bman@gentoo.org>
AuthorDate: 2018-04-22 20:33:37 +0000
Commit:     Aaron Bauman <bman@gentoo.org>
CommitDate: 2018-04-22 20:33:51 +0000

    app-office/lyx: amd64 stable wrt bug #631798
    
    Bug: https://bugs.gentoo.org/631798
    Package-Manager: Portage-2.3.31, Repoman-2.3.9

 app-office/lyx/lyx-2.3.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 13 Thomas Deutschmann gentoo-dev Security 2018-04-25 19:30:14 UTC
x86 stable
Comment 14 Matt Turner gentoo-dev 2018-04-26 04:35:26 UTC
ppc/ppc64 stable keywords dropped
Comment 15 Larry the Git Cow gentoo-dev 2018-04-26 15:36:29 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=06a00cb506ea38a6749ee5419519c796ca6b6c84

commit 06a00cb506ea38a6749ee5419519c796ca6b6c84
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-04-26 06:25:46 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-04-26 15:36:13 +0000

    app-office/lyx: Drop old Qt4-based
    
    Bug: https://bugs.gentoo.org/631798
    Package-Manager: Portage-2.3.31, Repoman-2.3.9

 app-office/lyx/Manifest               |   1 -
 app-office/lyx/files/2.1-python.patch |  29 ------
 app-office/lyx/lyx-2.2.3-r4.ebuild    | 186 ----------------------------------
 3 files changed, 216 deletions(-)}