Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 631630 - dev-libs/protobuf-3.3.0 fails build with gcc-6.4
Summary: dev-libs/protobuf-3.3.0 fails build with gcc-6.4
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Arfrever Frehtes Taifersar Arahesis
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2017-09-21 11:41 UTC by Andreas K. Hüttel
Modified: 2018-04-26 16:35 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2017-09-21 11:41:06 UTC
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I/var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src -I.. -DGOOGLE_PROTOBUF_NO_
RTTI -pthread -DHAVE_PTHREAD=1 -DHAVE_ZLIB=1 -Wall -Wno-sign-compare -march=native -O2 -pipe -g -c /var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.
3.0/src/google/protobuf/text_format.cc  -fPIC -DPIC -o google/protobuf/.libs/text_format.o
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/cmath:45:0,
                 from /var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.h:54,
                 from /var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.cc:36:
/var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.h: In static member function ‘static bool google::protobuf
::MathLimits<float>::IsFinite(google::protobuf::MathLimits<float>::Type)’:
/var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.h:233:20: error: expected unqualified-id before ‘(’ token
 #define ISINF std::isinf
                    ^
/var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.h:250:48: note: in expansion of macro ‘ISINF’
   static bool IsFinite(const Type x) { return !ISINF(x) && !ISNAN(x); } \
                                                ^~~~~
/var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.h:282:3: note: in expansion of macro ‘DECL_FP_LIMIT_FUNCS’
   DECL_FP_LIMIT_FUNCS \
   ^~~~~~~~~~~~~~~~~~~
/var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.h:285:1: note: in expansion of macro ‘DECL_FP_LIMITS’
 DECL_FP_LIMITS(float, FLT)
 ^~~~~~~~~~~~~~
/var/tmp/portage/dev-libs/protobuf-3.3.0/work/protobuf-3.3.0/src/google/protobuf/stubs/mathlimits.h:233:20: error: expected primary-expression before ‘__typeof’
 #define ISINF std::isinf
                    ^
...
Comment 1 Andreas K. Hüttel gentoo-dev 2017-10-02 11:07:04 UTC
This works fine with stable protobuf. Thus, not blocking any stabilizations.
Comment 2 Peter Levine 2017-10-03 05:29:42 UTC
Can't reproduce the error but it's likely fixed upstream with https://github.com/google/protobuf/commit/3908b4e40de8a9af1ba06ef01abdf8c5d9162623
Comment 3 Arfrever Frehtes Taifersar Arahesis 2018-04-26 16:35:08 UTC
<dev-libs/protobuf-3.4 have been deleted.