Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 631490 - Dependencies should be updated before the depending ebuilds.
Summary: Dependencies should be updated before the depending ebuilds.
Status: UNCONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-20 08:31 UTC by Simon
Modified: 2022-03-15 22:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge -DNupv world (emerge-DNupv_world.utf8,31.30 KB, text/plain)
2017-09-21 00:14 UTC, Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon 2017-09-20 08:31:07 UTC
Hi using portage 2.3.8 I just made an world update and pcsxr failed because it depended on broken ffmpeg but there was an ffmpeg update in queue too, so if the ffmpeg update would have been put in queue before pcsxr it would have worked..
So why doesn't portage put all dependencies in queue before the depending ebuilds?!
Comment 1 Zac Medico gentoo-dev 2017-09-20 17:05:05 UTC
Normally it should update the dependencies first. If you can reproduce the problem then please attach a log of the emerge --debug --pretend output. Like:

   emerge --puvD @world --pretend --debug > debug.log 2>&1
   xz -9 debug.log
Comment 2 Simon 2017-09-21 00:14:39 UTC
Created attachment 495710 [details]
emerge -DNupv world

Hi I still have the old log from emerge -DNupv without the --debug if that helps, you see there in my attached log that Line 124 (ffmpeg) should be before line 53 (pcsxr).
I also tried reproducing by downgrading ffmpeg but that didn't work, probably it has to do with pcsxr actually being rR and not U!?
Comment 3 Zac Medico gentoo-dev 2017-09-21 01:17:11 UTC
The pcsxr rebuild has anything to do with it. A likely cause is that ffmpeg got pushed later in the merge list due to it being involved in a dependency cycle.