Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 630998 - dev-lang/rakudo-2017.07 perl6-debug-m always exits with error
Summary: dev-lang/rakudo-2017.07 perl6-debug-m always exits with error
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: perl6
  Show dependency tree
 
Reported: 2017-09-14 18:57 UTC by Paul Preney
Modified: 2021-05-16 21:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Preney 2017-09-14 18:57:36 UTC
Running:
  
  perl6-debug-m

outputs:
  
  ===SORRY!===
  Could not find Debugger::UI::CommandLine at line 1 in:
      /home/preney/crossdev/lib
      /home/preney/.perl6
      /usr/share/perl6/site
      /usr/share/perl6/vendor
      /usr/share/perl6
      CompUnit::Repository::AbsolutePath<48984320>
      CompUnit::Repository::NQP<42283688>
      CompUnit::Repository::Perl5<42283728>
  zsh: exit 1     perl6-debug-m

with dev-lang/rakudo (2017.07@2017-09-13) installed.

Is this debugger dependent on specific USE flags, Gentoo configuration, or is this an upstream problem? (I did a default install of perl6, i.e., rakudo USE flags are moar -clang -java -test under Linux).

perl6, perl6-m, perl6-gdb-m, perl6-valgrind-m all appear to run properly.
Comment 1 Patrick Lauer gentoo-dev 2017-10-22 14:06:49 UTC
I think this is a lack of installed libraries/modules - a bit of a weak spot of our current rakudo setup :\

To fix that nicely we'd need to figure out how to package at least the common modules.