Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 629774 - sys-libs/gpm-1.20.7-r2 fails to compile with sys-libs/glibc-2.26 and sys-devel/gcc-7.2.0
Summary: sys-libs/gpm-1.20.7-r2 fails to compile with sys-libs/glibc-2.26 and sys-deve...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Blocks: gcc-7 glibc-2.26
  Show dependency tree
Reported: 2017-09-03 14:46 UTC by Philipp Psurek
Modified: 2019-07-31 22:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

sys-libs~gpm:log+emege--info.tar.lz (sys-libs_gpm.tar.lz,15.48 KB, application/x-lzip)
2017-09-03 14:46 UTC, Philipp Psurek
sigemptyset.patch (sigemptyset.patch,394 bytes, patch)
2017-09-08 00:59 UTC, cyrillic
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Psurek 2017-09-03 14:46:10 UTC
Created attachment 492140 [details]

prog/gpm-root.o: In function `main':
gpm-root.c:(.text.startup+0x215): undefined reference to `__sigemptyset'
collect2: error: ld returned 1 exit status

Steps to reproduce:
 1. update your system to sys-libs/glibc-2.26 and sys-devel/gcc-7.2.0
 2. change your gcc to compile with gcc 7.2.0
(3. emerge -e world)
 4. emerge -v =sys-libs/gpm-1.20.7-r2

tested on amdfam10, k8 and silvermont. emerge --info and logfiles are attached.
Comment 1 cyrillic 2017-09-08 00:21:25 UTC
I get the same error message when using clang/llvm-6 so I think this bug is because of glib-2.26 only.
Comment 2 cyrillic 2017-09-08 00:23:46 UTC
(In reply to cyrillic from comment #1)
> I get the same error message when using clang/llvm-6 so I think this bug is
> because of glib-2.26 only.

I meant glibc-2.26
Comment 3 cyrillic 2017-09-08 00:59:38 UTC
Created attachment 493180 [details, diff]

Try this patch. It seems to work for me.

... as a side note, epatch_user seems to be missing from the sys-libs/gpm-1.20.7-r2.ebuild
Comment 4 Sergei Trofimovich (RETIRED) gentoo-dev 2017-09-19 21:27:27 UTC
The patch looks good! Can you submit it upstream as well?
Comment 5 Larry the Git Cow gentoo-dev 2017-09-19 21:34:48 UTC
The bug has been closed via the following commit(s):

commit 1618968c56caf7f8c08823908d88dc49bb8f7649
Author:     Sergei Trofimovich <>
AuthorDate: 2017-09-19 21:34:32 +0000
Commit:     Sergei Trofimovich <>
CommitDate: 2017-09-19 21:34:42 +0000

    sys-libs/gpm: tweak for glibc-2.26, bug #629774
    Reported-by: Philipp Psurek
    Fix-by: cyrillic
    Package-Manager: Portage-2.3.8, Repoman-2.3.3

 sys-libs/gpm/files/gpm-1.20.7-glibc-2.26.patch | 12 ++++++++++++
 sys-libs/gpm/gpm-1.20.7-r2.ebuild              |  7 ++++++-
 2 files changed, 18 insertions(+), 1 deletion(-)