Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 629690 - x11-libs/libXau-1.0.8 : checking for XAU... configure: error: Package requirements (xproto) were not met:
Summary: x11-libs/libXau-1.0.8 : checking for XAU... configure: error: Package require...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-02 19:20 UTC by Toralf Förster
Modified: 2018-04-27 17:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.33 KB, text/plain)
2017-09-02 19:21 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,8.41 KB, text/plain)
2017-09-02 19:21 UTC, Toralf Förster
Details
environment (environment,124.58 KB, text/plain)
2017-09-02 19:21 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.62 KB, application/x-bzip)
2017-09-02 19:21 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.35 KB, application/x-bzip)
2017-09-02 19:21 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,33.03 KB, application/x-bzip)
2017-09-02 19:21 UTC, Toralf Förster
Details
x11-libs:libXau-1.0.8:20170902-191247.log (x11-libs:libXau-1.0.8:20170902-191247.log,11.82 KB, text/plain)
2017-09-02 19:21 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-09-02 19:20:58 UTC
checking whether ln -s works... yes
checking for pathconf... yes
checking for XAU... configure: error: Package requirements (xproto) were not met:

No package 'xproto' found


=== This is an issue at stable ===


  -------------------------------------------------------------------

  This is an stable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop_stable-abi32+64_20170902-123437

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)




emerge -qpv x11-libs/libXau
[ebuild  N    ] x11-libs/libXau-1.0.8  USE="-static-libs" ABI_X86="32 (64) (-x32)"
Comment 1 Toralf Förster gentoo-dev 2017-09-02 19:21:02 UTC
Created attachment 491916 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-09-02 19:21:05 UTC
Created attachment 491918 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-09-02 19:21:08 UTC
Created attachment 491920 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-09-02 19:21:11 UTC
Created attachment 491922 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-09-02 19:21:15 UTC
Created attachment 491924 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-09-02 19:21:19 UTC
Created attachment 491926 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2017-09-02 19:21:22 UTC
Created attachment 491928 [details]
x11-libs:libXau-1.0.8:20170902-191247.log
Comment 8 Larry the Git Cow gentoo-dev 2018-02-07 22:39:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d5fdb7d569488c4f4a33a6d1cae714d45b5a4f56

commit d5fdb7d569488c4f4a33a6d1cae714d45b5a4f56
Author:     Gilles Dartiguelongue <eva@gentoo.org>
AuthorDate: 2018-02-07 22:34:53 +0000
Commit:     Gilles Dartiguelongue <eva@gentoo.org>
CommitDate: 2018-02-07 22:38:48 +0000

    app-emulation/libguestfs: version bump 1.36.5 → 1.36.13
    
        * Now compatible with >=glibc-2.26, bug #638180.
        * Make sure USE=introspection explicitely passes configure switch as we
          might split glib/gobject from introspection at some point.
        * Switch to perl-functions eclass as advised in bug #629946.
        * Restore USE=ocaml as I could not bug #629490 from provided info.
        * Fix pkg_postinst feature check on USE=gtk.
        * Fix build with FEATURES=test by disabling -Werror always. It makes no
          sense to enable this flag for a release, bug #640494.
        * Add myself to maintainers.
    
        Closes: https://bugs.gentoo.org/629690
        Closes: https://bugs.gentoo.org/629946
        Closes: https://bugs.gentoo.org/638180
        Closes: https://bugs.gentoo.org/640494
    
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 app-emulation/libguestfs/Manifest                  |   1 +
 app-emulation/libguestfs/libguestfs-1.36.13.ebuild | 173 +++++++++++++++++++++
 app-emulation/libguestfs/metadata.xml              |   4 +
 3 files changed, 178 insertions(+)
Comment 9 Gilles Dartiguelongue gentoo-dev 2018-02-07 22:53:26 UTC
Sorry for typo.
Comment 10 Matt Turner gentoo-dev 2018-04-27 17:54:18 UTC
With x11-base/xorg-proto it is not possible for this to occur anymore.