Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 629362 - kde-apps/kdenlive build fails with gcc-7
Summary: kde-apps/kdenlive build fails with gcc-7
Status: RESOLVED DUPLICATE of bug 618070
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-30 09:34 UTC by Arsen Arsenovic
Modified: 2017-09-09 12:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (file_629362.txt,989.97 KB, text/plain)
2017-09-05 15:46 UTC, Arsen Arsenovic
Details
emerge --info and emerge -pqv (file_629362.txt,6.20 KB, text/plain)
2017-09-05 15:48 UTC, Arsen Arsenovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arsen Arsenovic 2017-08-30 09:34:13 UTC
Using GCC-7.1 KDenLive build fails.
emerge --info, build logs and other information are found in this paste: https://paste.pound-python.org/show/gtyGQzL8sKMCCsXvyTS7/

I have found a fix that worked for me on here: http://www.linuxfromscratch.org/blfs/view/cvs/kde/kdenlive.html
Specifically, the following worked:
sed -e '/abs/s/leftDist/(int)&/' \
    -i src/scopes/audioscopes/spectrogram.cpp

Thanks in advance
Comment 1 Mike Gilbert gentoo-dev 2017-08-30 16:08:54 UTC
Please attach the relevant information to this bug report. Pastebin links are not sufficient.
Comment 2 Arsen Arsenovic 2017-09-01 21:24:44 UTC
Dear Mike,
Can you tell me exactly what you need, and I will make sure to get it,

Best regards, 
Arsen
Comment 3 Mike Gilbert gentoo-dev 2017-09-03 02:34:52 UTC
Just take the stuff from the pastebin, and add it to this bug report.
Comment 4 Arsen Arsenovic 2017-09-05 15:46:56 UTC
Created attachment 492442 [details]
Build log

Added build log (adding the rest soon)
Comment 5 Arsen Arsenovic 2017-09-05 15:48:36 UTC
Created attachment 492444 [details]
emerge --info and emerge -pqv

Added the info and emerge -pqv

Here we go, all the info. Sorry if I did something wrong.
Comment 6 Andreas Sturmlechner gentoo-dev 2017-09-09 12:06:11 UTC
kdenlive-16.12.3? Can you please test with a version that was not removed from tree weeks ago?
Comment 7 Andreas Sturmlechner gentoo-dev 2017-09-09 12:09:32 UTC

*** This bug has been marked as a duplicate of bug 618070 ***
Comment 8 Arsen Arsenovic 2017-09-09 12:52:18 UTC
Hmm I wonder how I managed to miss that fix. It works now,

Thank you.