Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 629342 - LTO regression in gcc-6x (and above) causes build failures on gparted and inkscape
Summary: LTO regression in gcc-6x (and above) causes build failures on gparted and ink...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Toolchain Maintainers
URL: https://gcc.gnu.org/bugzilla/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks: lto
  Show dependency tree
 
Reported: 2017-08-30 01:51 UTC by Steve Arnold
Modified: 2019-07-17 22:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Arnold gentoo-dev 2017-08-30 01:51:31 UTC
Unfortunately the upstream bug is closed (again) and marked RESOLVED/FIXED but it seems the patch (backported to at least gcc 6.4.0) has reintroduced it (too much reduction maybe?).

Both apps were building/working with gcc 5.3/4 but the same error now occurs with said patch.  The root cause is essentially one group of upstream devs not using (or misusing) proper visibility rules for public vs private symbols, and another group of upstream devs deciding how the compiler should handle it for different levels of optimization (obviously they haven't converged).  Add to that the un-specificity of the language standard and this is what you get.

I can't comment on the upstream bug or I would reopen it (plus I have travel this week) so I guess I'm documenting it here.  Maybe there's a vapier patch in there somewhere...

I can add my current gparted build failure here, but it's exactly the same as before (and documented on that gcc bug).
Comment 1 Andreas K. Hüttel gentoo-dev 2017-09-01 21:15:10 UTC
@Steve: please add all the info here as needed on the upstream bug (preprocessed sources) and I'll forward it.
Comment 2 Steve Arnold gentoo-dev 2017-09-06 19:46:58 UTC
Pastbin okay for now?

https://paste.debian.net/984852/

plus I have no idea what code to add, since it's a linker failure.  Can you be more specific?
Comment 3 Andreas K. Hüttel gentoo-dev 2017-09-06 20:00:46 UTC
(In reply to Steve Arnold from comment #2)
> Pastbin okay for now?
> 
> https://paste.debian.net/984852/
> 
> plus I have no idea what code to add, since it's a linker failure.  Can you
> be more specific?

I attached your log upstream and asked for advice there. Let's see.
Comment 4 Steve Arnold gentoo-dev 2017-09-28 23:22:42 UTC
One more data point; i got gparted to actually build with the "same" config and versions of the toolchain on a different machine; the hardware is newer and the Gentoo piece is a little bit more up-to-date (and possibly more libs rebuiilt with  newer toolchain bits).  I tried a quick rebuild of the main deps and then gparted but still the same fail (on the original machine).  More analysis required...
Comment 5 Sergei Trofimovich gentoo-dev 2019-02-14 07:35:25 UTC
Does it happen on stable gcc-7.3.0? If it does can you post emerge --info and build.log?
Comment 6 Sergei Trofimovich gentoo-dev 2019-07-17 22:24:36 UTC
Closing as obsolete: not reproducible locally. No `emerge --info` posted to attempt to reproduce closer to the problematic environment.