Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 6289 - vmware-config.pl error with headerfiles
Summary: vmware-config.pl error with headerfiles
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Ryan Phillips (RETIRED)
URL:
Whiteboard:
Keywords:
: 8059 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-08-10 08:57 UTC by Tabe Kooistra
Modified: 2003-02-04 19:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tabe Kooistra 2002-08-10 08:57:39 UTC
Cannot compile vmware modules with vmware-config.pl 
What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] 

The kernel defined by this directory of header files does not have the same 
address space size as your running kernel.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] /usr/include

The directory of kernel headers (version 2.4.18) does not match your running 
kernel (version 2.4.19-gentoo-r7).  Even if the module were to compile 
successfully, it would not load into the running kernel

For any additioal info, mail me if needed.
Comment 1 Troy Dack 2002-08-11 18:03:44 UTC
Don't know if this will fix it but it's worth a try....

In my /etc/conf.d/local.start I link /usr/src/linux to /usr/src/`uname -r`
(might be linux-`uname -r`, I'm doing this from a Win box at the moment) this
ensures that things like vmware, alsa and nvidia drivers are built against the
source for the current running kernel.

So, check and see where your /usr/src/linux points and make sure it is pointing
to the sources for the currently running kernel.

eg:
    /usr/src/linux -> /usr/src/linux-2.4.19-gentoo-r7

-- 
   Troy.
Comment 2 Ryan Phillips (RETIRED) gentoo-dev 2002-08-18 19:37:03 UTC
upstream bug?
Comment 3 Tabe Kooistra 2002-08-19 02:39:11 UTC
uname -r                                                                       
2.4.19-gentoo-r7  

What is the location of the directory of C header files that match your        
running                                                                        
kernel? [/usr/src/linux/include] /usr/src/linux-2.4.19-gentoo-r7/include 

Comment 4 Ryan Phillips (RETIRED) gentoo-dev 2002-08-26 14:45:18 UTC
it doesn't look like your /usr/src/linux symlink is setup correctly.
Comment 5 Ryan Phillips (RETIRED) gentoo-dev 2002-08-28 13:17:25 UTC
Please reopen this bug if need be.
Comment 6 SpanKY gentoo-dev 2002-09-18 14:37:08 UTC
*** Bug 8059 has been marked as a duplicate of this bug. ***