Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 627472 - dev-erlang/fast_xml-1.1.22 : escript: exception error: undefined function rebar:main/1
Summary: dev-erlang/fast_xml-1.1.22 : escript: exception error: undefined function reb...
Status: RESOLVED DUPLICATE of bug 625870
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-10 17:17 UTC by Toralf Förster
Modified: 2019-09-17 14:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.03 KB, text/plain)
2017-08-10 17:17 UTC, Toralf Förster
Details
dev-erlang:fast_xml-1.1.22:20170810-162235.log (dev-erlang:fast_xml-1.1.22:20170810-162235.log,4.16 KB, text/plain)
2017-08-10 17:17 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,340.47 KB, text/plain)
2017-08-10 17:17 UTC, Toralf Förster
Details
environment (environment,19.21 KB, text/plain)
2017-08-10 17:17 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,17.01 KB, application/x-bzip)
2017-08-10 17:17 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.61 KB, application/x-bzip)
2017-08-10 17:17 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,8.20 KB, application/x-bzip)
2017-08-10 17:17 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-08-10 17:17:26 UTC
=ERROR REPORT==== 10-Aug-2017::18:22:40 ===
Loading of /usr/bin/rebar/rebar/ebin/rebar.beam failed: badfile
escript: exception error: undefined function rebar:main/1
  in function  escript:run/2 (escript.erl, line 760)
  in call from escript:start/1 (escript.erl, line 277)
  in call from init:start_em/1 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-no-multilib_20170802-210334

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0
 [2] x86_64-pc-linux-gnu-6.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python3.5 (fallback)
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems)
  [2]   ruby22 (with Rubygems) *



emerge -qpv dev-erlang/fast_xml
[ebuild  N    ] dev-erlang/fast_xml-1.1.22  USE="{-test}"
Comment 1 Toralf Förster gentoo-dev 2017-08-10 17:17:30 UTC
Created attachment 488514 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-08-10 17:17:33 UTC
Created attachment 488516 [details]
dev-erlang:fast_xml-1.1.22:20170810-162235.log
Comment 3 Toralf Förster gentoo-dev 2017-08-10 17:17:36 UTC
Created attachment 488518 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-08-10 17:17:40 UTC
Created attachment 488520 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-08-10 17:17:43 UTC
Created attachment 488522 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-08-10 17:17:46 UTC
Created attachment 488524 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2017-08-10 17:17:49 UTC
Created attachment 488526 [details]
temp.tbz2
Comment 8 R030t1 2017-09-04 05:10:55 UTC
Unable to reproduce.
Comment 9 Hanno Boeck gentoo-dev 2019-09-17 14:37:40 UTC

*** This bug has been marked as a duplicate of bug 625870 ***