Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 627054 - media-libs/esdl-1.3.1 : escript: exception error: undefined function rebar:main/1
Summary: media-libs/esdl-1.3.1 : escript: exception error: undefined function rebar:ma...
Status: RESOLVED DUPLICATE of bug 625870
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-04 17:25 UTC by Toralf Förster
Modified: 2019-09-17 14:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,19.04 KB, text/plain)
2017-08-04 17:25 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,391.24 KB, text/plain)
2017-08-04 17:25 UTC, Toralf Förster
Details
environment (environment,81.71 KB, text/plain)
2017-08-04 17:25 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,57.75 KB, application/x-bzip)
2017-08-04 17:25 UTC, Toralf Förster
Details
media-libs:esdl-1.3.1:20170804-063848.log (media-libs:esdl-1.3.1:20170804-063848.log,2.06 KB, text/plain)
2017-08-04 17:25 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,20.62 KB, application/x-bzip)
2017-08-04 17:25 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-08-04 17:25:30 UTC
=ERROR REPORT==== 4-Aug-2017::08:38:52 ===
Loading of /usr/bin/rebar/rebar/ebin/rebar.beam failed: badfile
escript: exception error: undefined function rebar:main/1
  in function  escript:run/2 (escript.erl, line 760)
  in call from escript:start/1 (escript.erl, line 277)
  in call from init:start_em/1 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop_libressl_20170725-223303

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0
 [2] x86_64-pc-linux-gnu-6.4.0 *
llvm-config:
3.9.1
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   jython2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 7.2.6.10 [icedtea-bin-7]
2)	IcedTea JDK 3.5.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-7  system-vm
  [2]   icedtea-bin-8 

emerge -qpv media-libs/esdl
[ebuild  N    ] media-libs/esdl-1.3.1  USE="truetype -image"
Comment 1 Toralf Förster gentoo-dev 2017-08-04 17:25:34 UTC
Created attachment 487908 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-08-04 17:25:37 UTC
Created attachment 487910 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-08-04 17:25:40 UTC
Created attachment 487912 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-08-04 17:25:43 UTC
Created attachment 487914 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-08-04 17:25:46 UTC
Created attachment 487916 [details]
media-libs:esdl-1.3.1:20170804-063848.log
Comment 6 Toralf Förster gentoo-dev 2017-08-04 17:25:50 UTC
Created attachment 487918 [details]
temp.tbz2
Comment 7 Hanno Boeck gentoo-dev 2019-09-17 14:36:23 UTC

*** This bug has been marked as a duplicate of bug 625870 ***