Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 626966 - media-gfx/openvdb KEYWORDREQ for arm
Summary: media-gfx/openvdb KEYWORDREQ for arm
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Adrian
URL:
Whiteboard:
Keywords: CC-ARCHES, KEYWORDREQ
Depends on:
Blocks: 556758
  Show dependency tree
 
Reported: 2017-08-03 10:45 UTC by Dion Moult
Modified: 2020-10-07 18:13 UTC (History)
5 users (show)

See Also:
Package list:
media-gfx/openvdb ~arm dev-libs/c-blosc ~arm dev-libs/log4cplus ~arm media-libs/glfw ~arm media-libs/openexr ~arm
Runtime testing required: ---
nattka: sanity-check-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dion Moult 2017-08-03 10:45:44 UTC
I see packages available for openvdb on arch Linux, so I'm wondering if someone can help keyword this for arm.
Comment 1 Jonas Stein gentoo-dev 2017-08-06 15:14:10 UTC
In the meantime I suggest you to join #gentoo-arm.
There are other users, who can support a quick solution.
Comment 2 Jonathan Scruggs (RETIRED) gentoo-dev 2017-08-14 17:01:20 UTC
I don't have arm hardware, so I can't test it, and thus can't keyword it.

Copy the ebuild to your own local overlay, add the arm or arm64 keywords, and then try to compile it. You may need to add some of the depends as well. Also, there may be some packages and/or use flags in the arm profile masks, so those may need to be unmasked.

Please report back if it works. I'm currently working on a 4.0.2 update to OpenVDB, so it would be cool if I could add it with the arm keywords.

Cheers.
Comment 3 NATTkA bot gentoo-dev 2020-04-30 08:34:25 UTC
Sanity check failed:

> media-gfx/openvdb-5.2.0-r1
>   depend ~arm stable profile default/linux/arm/17.0 (1 total)
>     >=dev-libs/c-blosc-1.5.0
>     dev-libs/log4cplus
>     media-libs/glfw:=
>     media-libs/openexr:=
>   depend ~arm dev profile default/linux/arm/17.0/armv4 (31 total)
>     >=dev-libs/c-blosc-1.5.0
>     dev-libs/log4cplus
>     media-libs/glfw:=
>     media-libs/openexr:=
>   rdepend ~arm stable profile default/linux/arm/17.0 (1 total)
>     >=dev-libs/c-blosc-1.5.0
>     dev-libs/log4cplus
>     media-libs/glfw:=
>     media-libs/openexr:=
>   rdepend ~arm dev profile default/linux/arm/17.0/armv4 (31 total)
>     >=dev-libs/c-blosc-1.5.0
>     dev-libs/log4cplus
>     media-libs/glfw:=
>     media-libs/openexr:=
Comment 4 NATTkA bot gentoo-dev 2020-06-27 02:21:33 UTC
Unable to check for sanity:

> package masked: media-libs/openexr-2.3.0, by keywords: -arm
Comment 5 Sam James archtester gentoo-dev Security 2020-07-14 23:02:23 UTC
OpenEXR is -arm. We need to make sure that it works on arm and remove that, or we can't do this.
Comment 6 NATTkA bot gentoo-dev 2020-07-21 19:01:35 UTC
Unable to check for sanity:

> package masked: media-libs/openexr-2.5.2, by keywords: -arm
Comment 7 NATTkA bot gentoo-dev 2020-10-07 18:13:10 UTC
Unable to check for sanity:

> package masked: media-libs/openexr-2.5.2-r1, by keywords: -arm