Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 626878 - dev-python/sphinx-gallery-0.1.12 - SandboxViolation: open('/var/tmp/portage/dev-python/sphinx-gallery-0.1.12/work/sphinx-gallery-0.1.12-python2_7/lib/', 'wb')
Summary: dev-python/sphinx-gallery-0.1.12 - SandboxViolation: open('/var/tmp/portage/d...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Python Gentoo Team
Depends on:
Blocks: 636054
  Show dependency tree
Reported: 2017-08-02 14:25 UTC by Juergen Rose
Modified: 2018-04-15 10:04 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,5.62 KB, text/x-log)
2017-08-02 14:25 UTC, Juergen Rose

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2017-08-02 14:25:33 UTC
Created attachment 487652 [details]

'MAKEOPTS=-j1 emerge -v1 sphinx-gallery' fails with:
>>> Compiling source in /var/tmp/portage/dev-python/sphinx-gallery-0.1.12/work/sphinx-gallery-0.1.12 ...
 * python2_7: running distutils-r1_run_phase distutils-r1_python_compile
/usr/bin/python2.7 build
Traceback (most recent call last):
  File "", line 44, in <module>
    'Programming Language :: Python',
  File "/usr/lib64/python2.7/distutils/", line 111, in setup
    _setup_distribution = dist = klass(attrs)
  File "/usr/lib64/python2.7/site-packages/setuptools/", line 320, in __init__
  File "/usr/lib64/python2.7/site-packages/setuptools/", line 377, in fetch_build_eggs
  File "/usr/lib64/python2.7/site-packages/pkg_resources/", line 852, in resolve
    dist = best[req.key] = env.best_match(req, ws, installer)
  File "/usr/lib64/python2.7/site-packages/pkg_resources/", line 1124, in best_match
    return self.obtain(req, installer)
  File "/usr/lib64/python2.7/site-packages/pkg_resources/", line 1136, in obtain
    return installer(requirement)
  File "/usr/lib64/python2.7/site-packages/setuptools/", line 445, in fetch_build_egg
    return cmd.easy_install(req)
  File "/usr/lib64/python2.7/site-packages/setuptools/command/", line 673, in easy_install
    return self.install_item(spec, dist.location, tmpdir, deps)
  File "/usr/lib64/python2.7/site-packages/setuptools/command/", line 699, in install_item
    dists = self.install_eggs(spec, download, tmpdir)
  File "/usr/lib64/python2.7/site-packages/setuptools/command/", line 880, in install_eggs
    return self.build_and_install(setup_script, setup_base)
  File "/usr/lib64/python2.7/site-packages/setuptools/command/", line 1119, in build_and_install
    self.run_setup(setup_script, setup_base, args)
  File "/usr/lib64/python2.7/site-packages/setuptools/command/", line 1107, in run_setup
    raise DistutilsError("Setup script exited with %s" % (v.args[0],))
distutils.errors.DistutilsError: Setup script exited with error: SandboxViolation: open('/var/tmp/portage/dev-python/sphinx-gallery-0.1.12/work/sphinx-gallery-0.1.12-python2_7/lib/', 'wb') {}

The package setup script has attempted to modify files on your system
that are not within the EasyInstall build area, and has been aborted.

root@cheetahnew:/root(68)# emerge --info '=dev-python/sphinx-gallery-0.1.12::gentoo'
Portage 2.3.6 (python 3.4.6-final-0, default/linux/amd64/13.0/desktop, gcc-5.4.0, glibc-2.24-r3, 4.12.3-gentoo x86_64)
                         System Settings
System uname: Linux-4.12.3-gentoo-x86_64-Intel-R-_Core-TM-_i3-2120_CPU_@_3.30GHz-with-gentoo-2.4.1
KiB Mem:     7863312 total,   1846492 free
KiB Swap:   50331640 total,  49848056 free
Timestamp of repository gentoo: Wed, 02 Aug 2017 02:00:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.28 p1.2) 2.28
distcc[4176] (dcc_trace_version) distcc 3.2rc1 x86_64-pc-linux-gnu; built Oct  2 2016 20:26:57 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.2::gentoo
dev-lang/python:          2.7.13-r100::sage-on-gentoo, 3.4.6::gentoo, 3.5.3::gentoo, 3.6.1-r1::gentoo
dev-util/cmake:           3.9.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1::gentoo
sys-apps/openrc:          0.28::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.15.1::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r3::gentoo

    location: /usr/portage_cheetahnew
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

    location: /usr/local/portage
    masters: gentoo
    priority: 0

    location: /var/lib/cpan
    masters: gentoo
    priority: 1

    location: /var/lib/g-octave
    masters: gentoo
    priority: 2

    location: /var/lib/layman/sage-on-gentoo
    masters: gentoo science
    priority: 50

    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

    location: /var/lib/layman/x11
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype- googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA NVIDIA-CUDA Nero-AAC-EULA GIMPS"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 amr ao apache2 apng applet archive armadillo arpack asf aspell assistant atlas audacious audiofile aufs automap automount barcode bash-completion berkdb blas blast bluetooth bluray boost branding btrfs bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cilk clang cli cmake collada consolekit contrib cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia digitalradio djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples excel exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx ftp fuse gcj gd gdal gdbm gedit geoip geolocation geos gfortran gif gimp git glade glamor glib glpk gml gmp gnome gnome-keyring gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gstreamer gtk gtk3 gudev guile hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3tag ide imagemagick imap inotify introspection ipod ipv6 ithreads jadetex java jbig jit john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack latex lcms ldap lensfun libffi libgda libkms libnotify libsamplerate live lm_sensors lua lzma lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mpi-threads mplayer mtp multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg opencl opencv openexr opengl openmp openvg pam pango pcre pda pdf pdl2 perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds ppp preview-latex proj projectm pstricks pulseaudio python q32 qemu qhull qml qt3support qt4 qt5 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool rtlsdr sage samba sasl schroedinger science sdk sdl seccomp secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite ssl startup-notification stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tbb tcl tcpd tex tex4ht theora thesaurus threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb utempter v4l v4l2 vaapi vala valgrind vdpau video vim-syntax virt-network virtualbox visio vorbis vpx vtk wav wayland webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xen xetex xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zsh-completion zvbi" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog sensors thermal" CPU_FLAGS_X86="avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="aivdm ashtech earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 navcom ntrip oceanserver oncore rtcm104v2 rtcm104v3 sirf superstar2 tnt tripmate tsip ublox nmea0183 nmea2000 passthrough" GRUB_PLATFORMS="emu efi-64 pc xen" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="de en fr ru" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd SureElec" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

root@cheetahnew:/root(69)# emerge -pqv '=dev-python/sphinx-gallery-0.1.12::gentoo'
[ebuild     U ] dev-python/sphinx-gallery-0.1.12 [0.1.7-r1] USE="(-test%)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
Comment 1 Robin Kauffman 2017-08-10 20:38:55 UTC
I fixed this (exact) same issue with another package by updating dev-python/pytest-runner.  Would be worth a try.
Comment 2 Juergen Rose 2017-08-11 07:40:25 UTC
(In reply to Robin Kauffman from comment #1)
> I fixed this (exact) same issue with another package by updating
> dev-python/pytest-runner.  Would be worth a try.

'pytest-runner' is not installed on my system.
Comment 3 Juergen Rose 2017-09-01 17:28:04 UTC
Is there not any patch?
Comment 4 Benda Xu gentoo-dev 2017-09-15 10:10:55 UTC
I have met with a similar error.
Comment 5 Benda Xu gentoo-dev 2017-09-15 10:42:23 UTC
It seems to happen quite recently, but we saw similar bugs like,


Does downgrading setuptools solve this issue?
Comment 6 Benda Xu gentoo-dev 2017-09-15 10:46:29 UTC
No, downgrading to setuptools-30.4.0 does not help.

Does deleting setuptools work?
Comment 7 Benda Xu gentoo-dev 2017-09-15 11:36:18 UTC
I think we should remove pytest-runner from

What do you think, Python Team?
Comment 8 Mike Gilbert gentoo-dev 2017-09-15 13:40:43 UTC
(In reply to Benda Xu from comment #7)
> I think we should remove pytest-runner from
> What do you think, Python Team?

Yes, that is probably the best solution. Or you could add it to DEPEND.
Comment 9 Juergen Rose 2017-09-17 09:20:09 UTC
(In reply to Mike Gilbert from comment #8)
> (In reply to Benda Xu from comment #7)
> > I think we should remove pytest-runner from
> > 
> > What do you think, Python Team?
> Yes, that is probably the best solution. Or you could add it to DEPEND.

Adding pytest-runner to DEPEND solved the issue for me.
Comment 10 Marc van der Sluys 2017-10-08 14:43:36 UTC
Same issue here, went away after installing dev-python/pytest-runner - adding it to DEPEND would be a solution.
Comment 11 Juergen Rose 2017-12-03 11:49:50 UTC
I hit this issue again. Adding python_targets_python3_4 USE flag to dev-python/pytest and dev-python/pytest-runner seems to solve the issue for me with my local sphinx-gallery-0.1.12.ebuild.  The sphinx-gallery-0.1.12.ebuild in the standard portage tree is still missing the pytest-runner dependency.
Comment 12 Benjamin Réveillé 2018-02-10 09:06:01 UTC
For those who wondered how to modify the ebuild... This is the patch that worked for me :

--- /usr/portage/dev-python/sphinx-gallery/sphinx-gallery-0.1.12.ebuild 2018-01-09 15:39:49.000000000 +0100
+++ /usr/local/portage/dev-python/sphinx-gallery/sphinx-gallery-0.1.12-r1.ebuild     2018-02-10 10:03:05.862861129 +0100
@@ -20,7 +20,10 @@
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/pytest-runner[${PYTHON_USEDEP}]
 # tests need extra files not distributed
Comment 13 Pacho Ramos gentoo-dev 2018-04-15 10:04:41 UTC
[master fece96f42717] dev-python/sphinx-gallery: pytest-runner needed as DEPEND (#626878)
 1 file changed, 4 insertions(+), 1 deletion(-)