Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 626800 - net-print/cups-filters-1.16.0: emake failed after update to app-text/poppler-0.57.0
Summary: net-print/cups-filters-1.16.0: emake failed after update to app-text/poppler-...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
: 626950 627002 629064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-01 13:20 UTC by Tomas Jelinek
Modified: 2017-08-31 08:57 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=net-print/cups-filters-1.16.0::gentoo' (info,16.75 KB, text/plain)
2017-08-01 13:20 UTC, Tomas Jelinek
Details
build.log (build.log,226.66 KB, text/plain)
2017-08-01 13:25 UTC, Tomas Jelinek
Details
emerge-info.txt (emerge-info.txt,15.72 KB, text/plain)
2017-08-23 16:51 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,301.60 KB, text/plain)
2017-08-23 16:52 UTC, Toralf Förster
Details
environment (environment,118.18 KB, text/plain)
2017-08-23 16:52 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,16.79 KB, application/x-bzip)
2017-08-23 16:52 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,41.51 KB, application/x-bzip)
2017-08-23 16:52 UTC, Toralf Förster
Details
net-print:cups-filters-1.16.3:20170822-194436.log (net-print:cups-filters-1.16.3:20170822-194436.log,88.91 KB, text/plain)
2017-08-23 16:52 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,36.31 KB, application/x-bzip)
2017-08-23 16:52 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Jelinek 2017-08-01 13:20:31 UTC
Created attachment 487538 [details]
emerge --info '=net-print/cups-filters-1.16.0::gentoo'

Rebuild fails after being triggered by app-text/poppler-0.57.0 update.
Comment 1 Tomas Jelinek 2017-08-01 13:25:24 UTC
Created attachment 487540 [details]
build.log
Comment 2 Juergen Rose 2017-08-01 14:31:46 UTC
I have the same issue.
Comment 3 Jonas Stein gentoo-dev 2017-08-01 18:58:25 UTC
net-print/cups-filters-1.13.5 fail to build with app-text/poppler-0.57.0 too.
Comment 4 Ivan Iraci 2017-08-02 10:24:34 UTC
(In reply to Juergen Rose from comment #2)

> I have the same issue.

Me too.
Comment 5 Ivan Iraci 2017-08-02 13:35:40 UTC
This bug's summary is wrong: I have this problem with gcc 4.9.

It is better to revert it to the previous version ("net-print/cups-filters-1.16.0: emake failed after update to app-text/poppler-0.57.0"), with no mention to gcc version.
Comment 6 Luke A. Guest 2017-08-02 18:04:21 UTC
Confirmed, just upgraded and got this error.
Comment 7 Jonas Stein gentoo-dev 2017-08-02 19:26:09 UTC
A short summary

GCC      Poppler cups    result
--------------------------------
4.9      0.57    1.16.0  fail
5.x      0.57    1.16.0  fail
5.4.0-r3 0.57    1.13.5  fail
5.4.0-r3 0.56    1.13.5  success

Everybody is invited to look for more details. I guess poppler introduced something new which is not compatible with cups. We should look at the cups and poppler bug tracker and perhaps ask them too.
https://bugs.linuxfoundation.org/buglist.cgi?quicksearch=poppler
Comment 8 Manne 2017-08-03 06:23:38 UTC
GCC      Poppler cups    result
--------------------------------
6.3      0.57    1.16.0  success
Comment 9 Erol Mutlu 2017-08-03 08:48:44 UTC
(In reply to Manne from comment #8)
> GCC      Poppler cups    result
> --------------------------------
> 6.3      0.57    1.16.0  success

Confirmed
Comment 10 Brian Evans Gentoo Infrastructure gentoo-dev 2017-08-03 12:51:24 UTC
*** Bug 626950 has been marked as a duplicate of this bug. ***
Comment 11 Ben Kohler gentoo-dev 2017-08-03 20:23:04 UTC
*** Bug 627002 has been marked as a duplicate of this bug. ***
Comment 12 Maciej Mrozowski gentoo-dev 2017-08-04 01:09:58 UTC
Easy to fix, affected programs need to append -std=c++11, because poppler recently (since https://cgit.freedesktop.org/poppler/poppler/commit/poppler/PDFDoc.h?id=66e718e753a527289ce86cd206fcffd23fc28d81) started using C++11 syntax in on its XPDF.

Initially I was thinking of patching poppler.pc, and it would fix, but compiler would complain elsewhere:

x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/tmp/portage/app-text/texlive-core-2016-r5/work/texlive-20160523-source/texk/web2c (...) 20160523-source/texk/web2c/'`dvigen.c
cc1: warning: command line option '-std=c++11' is valid for C++/ObjC++ but not for C
Comment 13 Iade Gesso 2017-08-04 12:56:30 UTC
(In reply to Maciej Mrozowski from comment #12)
> Easy to fix, affected programs need to append -std=c++11, because poppler
> recently (since
> https://cgit.freedesktop.org/poppler/poppler/commit/poppler/PDFDoc.
> h?id=66e718e753a527289ce86cd206fcffd23fc28d81) started using C++11 syntax in
> on its XPDF.
> 
> Initially I was thinking of patching poppler.pc, and it would fix, but
> compiler would complain elsewhere:
> 
> x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.
> -I/tmp/portage/app-text/texlive-core-2016-r5/work/texlive-20160523-source/
> texk/web2c (...) 20160523-source/texk/web2c/'`dvigen.c
> cc1: warning: command line option '-std=c++11' is valid for C++/ObjC++ but
> not for C

Hey this works like a charm!

Thx

Iade
Comment 14 josef.95 2017-08-04 13:35:58 UTC
Yes, a gcc-5 workaround
CXXFLAGS="${CXXFLAGS} -std=c++11" emerge -av1 cups-filters
should work.

But I think better is, use current gcc-6.4.0 and make is stable :)
Comment 15 Marian Kyral 2017-08-06 06:30:55 UTC
(In reply to josef.95 from comment #14)
> Yes, a gcc-5 workaround
> CXXFLAGS="${CXXFLAGS} -std=c++11" emerge -av1 cups-filters
> should work.

Yes, it works. Thanks.

> 
> But I think better is, use current gcc-6.4.0 and make is stable :)

I've checked bugzilla. No issues against 6.4 and no stabilization request. So I can expect no big issues during upgrade to 6.4?
Comment 17 Juergen Rose 2017-08-08 05:43:47 UTC
(In reply to Austin English from comment #16)
> https://gitweb.gentoo.org/repo/gentoo.git/commit/
> ?id=688cb6112495f5f2a282ff2b846c2fcff2c03eaf

Thanks Austin,
it works here.
Comment 18 Toralf Förster gentoo-dev 2017-08-23 16:51:54 UTC
got at the unstable amd64 chroot image 17.0-desktop-gnome-systemd_20170815-183537 this : net-print/cups-filters-1.16.3 :  *   emake failed
Comment 19 Toralf Förster gentoo-dev 2017-08-23 16:51:58 UTC
Created attachment 490294 [details]
emerge-info.txt
Comment 20 Toralf Förster gentoo-dev 2017-08-23 16:52:01 UTC
Created attachment 490296 [details]
emerge-history.txt
Comment 21 Toralf Förster gentoo-dev 2017-08-23 16:52:05 UTC
Created attachment 490298 [details]
environment
Comment 22 Toralf Förster gentoo-dev 2017-08-23 16:52:09 UTC
Created attachment 490300 [details]
etc.portage.tbz2
Comment 23 Toralf Förster gentoo-dev 2017-08-23 16:52:13 UTC
Created attachment 490302 [details]
logs.tbz2
Comment 24 Toralf Förster gentoo-dev 2017-08-23 16:52:17 UTC
Created attachment 490304 [details]
net-print:cups-filters-1.16.3:20170822-194436.log
Comment 25 Toralf Förster gentoo-dev 2017-08-23 16:52:20 UTC
Created attachment 490306 [details]
temp.tbz2
Comment 26 Michael Palimaka (kensington) gentoo-dev 2017-08-27 14:10:03 UTC
(In reply to Toralf Förster from comment #24)
> Created attachment 490304 [details]
> net-print:cups-filters-1.16.3:20170822-194436.log

This one is a test failure, unrelated to the original bug. Reclosing.
Comment 27 Michael Palimaka (kensington) gentoo-dev 2017-08-27 14:11:36 UTC
*** Bug 629064 has been marked as a duplicate of this bug. ***