Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 626374 - media-sound/volti-0.2.3-r1 needs dbus-python-0.80.0 or higher
Summary: media-sound/volti-0.2.3-r1 needs dbus-python-0.80.0 or higher
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-27 16:39 UTC by Jesús Guerrero
Modified: 2017-08-27 10:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge_info.out,6.61 KB, text/plain)
2017-08-24 11:32 UTC, HÁRSFALVI Levente
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesús Guerrero 2017-07-27 16:39:24 UTC
So, running volti outputs:

$ volti
This program needs dbus-python 0.80.0 or higher

$ eix dbus-python
[I] dev-python/dbus-python
     Available versions:  1.2.0-r1 1.2.4 {doc examples test PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"}
     Installed versions:  1.2.4(18:24:48 27/07/17)(-doc -examples -test PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6")
     Homepage:            https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/
     Description:         Python bindings for the D-Bus messagebus

$ eix volti
[I] media-sound/volti
     Available versions:  0.2.3-r1 {X libnotify PYTHON_TARGETS="python2_7"}
     Installed versions:  0.2.3-r1(18:25:21 27/07/17)(X libnotify PYTHON_TARGETS="python2_7")
     Homepage:            https://github.com/gen2brain/volti
     Description:         GTK+ application for controlling audio volume from system tray/notification area

I used to run volti without problems some weeks ago. But, sincerely, and to tell the truth, I don't know when it screwed up exactly.

I re-emerged both packages, in the hope that some python stuff was broken or something, but that didn't fix anything. 

I can  post emerge --info but I don't think it's necessary this time. It's probably the little critter looking for the module in the wrong path or, maybe, we need to adjust something for the newer dbus-python versions.
Comment 1 HÁRSFALVI Levente 2017-08-24 11:32:19 UTC
Created attachment 490384 [details]
emerge --info
Comment 2 HÁRSFALVI Levente 2017-08-24 11:33:09 UTC
Ran into the same problem some minutes ago.

levente@zaonce ~ $ volti
This program needs dbus-python 0.80.0 or higher
Exiting

levente@zaonce ~ $ equery l -p dbus-python
 * Searching for dbus-python ...
[-P-] [  ] dev-python/dbus-python-1.2.0-r1:0
[IP-] [  ] dev-python/dbus-python-1.2.4:0

levente@zaonce ~ $ equery l -p volti
 * Searching for volti ...
[IP-] [  ] media-sound/volti-0.2.3-r1:0
Comment 3 HÁRSFALVI Levente 2017-08-24 13:06:19 UTC
The root of the problem is that dbus-python >1.2.0-rx no longer installs version files that volti is trying to find and use.

levente@zaonce ~ $ strace volti 
execve("/usr/bin/volti", ["volti"], [/* 78 vars */]) = 0
...
...
stat("/usr/lib64/python2.7/site-packages/dbus/_version", 0x7ffcff853200) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.7/site-packages/dbus/_version.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.7/site-packages/dbus/_versionmodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.7/site-packages/dbus/_version.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.7/site-packages/dbus/_version.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
write(2, "This program needs dbus-python 0"..., 56This program needs dbus-python 0.80.0 or higher
Exiting
) = 56

levente@zaonce ~ $ find /usr/lib64/python2.7/site-packages/dbus/ -name _version*
(none found)

After downgrading to dev-python/dbus-python-1.2.0-r1 ,

levente@zaonce ~ $ find /usr/lib64/python2.7/site-packages/dbus/ -name _version* 
/usr/lib64/python2.7/site-packages/dbus/_version.pyo
/usr/lib64/python2.7/site-packages/dbus/_version.pyc
/usr/lib64/python2.7/site-packages/dbus/_version.py

...and the mixer starts up without problems.
Comment 4 HÁRSFALVI Levente 2017-08-24 13:17:29 UTC
To make things clear, although volti does start up after downgrading dbus-python, volti-mixer (for me) still does not, probably due to an other (different) issue.
Comment 5 hfern 2017-08-27 07:14:08 UTC
Same here: after world update volti complains that it needs dbus-python 0.80.0 or higher.
Comment 6 Jesús Guerrero 2017-08-27 10:19:30 UTC
So, unless someone who knows how to handle this properly in python, depending on module versions, I suggest forcing volti dependency on >=dev-python/dbus-python-1.2.4 and patching it this way using epatch or whatever from the ebuild. Quick and easy.

--- volti.orig  2017-08-27 12:16:20.111010863 +0200
+++ volti       2017-08-27 12:15:29.122009652 +0200
@@ -22,7 +22,7 @@

 try:
     import dbus
-    import dbus._version
+#    import dbus._version
     from dbus.mainloop.glib import DBusGMainLoop
     assert dbus.version >= (0, 80, 0)
 except ImportError, AssertionError: