Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625696 - dev-util/codeblocks-16.01 segmentation fault with gcc-6
Summary: dev-util/codeblocks-16.01 segmentation fault with gcc-6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2017-07-19 19:42 UTC by Keith Harrison
Modified: 2017-07-30 16:04 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info codeblocks (emerge,5.22 KB, text/plain)
2017-07-21 23:50 UTC, Dutch Ingraham
Details
codeblocks debg report (codeblocks.xml,21.70 KB, text/xml)
2017-07-21 23:55 UTC, Dutch Ingraham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Harrison 2017-07-19 19:42:23 UTC
Builds fine with gcc 6, but crashes immediately on startup.

After rebuilding world recently, this happens consistently on multiple computers.

Reading symbols from codeblocks...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/codeblocks 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Starting Code::Blocks Release 16.01  rev 10692 Jul 19 2017, 00:29:39 - wx2.8.12 (Linux, unicode) - 64 bit
[New Thread 0x7fffe6811700 (LWP 15589)]
[New Thread 0x7fffe6010700 (LWP 15590)]
[New Thread 0x7fffe580f700 (LWP 15591)]
[New Thread 0x7fffe500e700 (LWP 15592)]
Initialize EditColourSet .....
[New Thread 0x7fffd7fff700 (LWP 15601)]
[New Thread 0x7fffd77fe700 (LWP 15602)]
[New Thread 0x7fffd6ffd700 (LWP 15603)]
Initialize EditColourSet: done.

Thread 1 "codeblocks" received signal SIGSEGV, Segmentation fault.
0x00007ffff5d0a143 in wxStringBase::operator=(wxStringBase const&) () from /usr/lib64/libwx_baseu-2.8.so.0
(gdb) info frame
Stack level 0, frame at 0x7fffffffceb0:
 rip = 0x7ffff5d0a143 in wxStringBase::operator=(wxStringBase const&); saved rip = 0x7ffff7a6e791
 called by frame at 0x7fffffffced0
 Arglist at 0x7fffffffcea0, args: 
 Locals at 0x7fffffffcea0, Previous frame's sp is 0x7fffffffceb0
 Saved registers:
  rip at 0x7fffffffcea8
(gdb) bt
#0  0x00007ffff5d0a143 in wxStringBase::operator=(wxStringBase const&) () from /usr/lib64/libwx_baseu-2.8.so.0
#1  0x00007ffff7a6e791 in wxPGProperty::Init(wxString const&, wxString const&) () from /usr/lib64/libcodeblocks.so.0
#2  0x00007ffff7a7cf45 in wxPGProperty::wxPGProperty(wxString const&, wxString const&) () from /usr/lib64/libcodeblocks.so.0
#3  0x00007ffff7a98155 in wxStringProperty::wxStringProperty(wxString const&, wxString const&, wxString const&) () from /usr/lib64/libcodeblocks.so.0
#4  0x0000000000507d83 in ?? ()
#5  0x000000000046ac25 in ?? ()
#6  0x00007ffff76f5fea in DebuggerManager::CreateWindows() () from /usr/lib64/libcodeblocks.so.0
#7  0x00007ffff76f607d in DebuggerManager::SetInterfaceFactory(cbDebugInterfaceFactory*) () from /usr/lib64/libcodeblocks.so.0
#8  0x00000000004ac64d in ?? ()
#9  0x00000000004bf309 in ?? ()
#10 0x00000000004c2fbb in ?? ()
#11 0x00000000004564c0 in ?? ()
#12 0x000000000045ab5e in ?? ()
#13 0x00007ffff5ceb1dc in wxEntry(int&, wchar_t**) () from /usr/lib64/libwx_baseu-2.8.so.0
#14 0x0000000000449462 in main ()
(gdb) q
A debugging session is active.



Quick workaround (but this may break other things):

package.env:
x11-libs/wxGTK gcc5.conf
dev-util/codeblocks gcc5.conf

gcc5.conf:
CC="gcc-5.4.0"
CXX="g++-5.4.0"


Possible related bug report and patch here:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=197888
Comment 1 Peter Levine 2017-07-21 21:41:10 UTC
Looks like https://bugzilla.redhat.com/show_bug.cgi?id=1342076
Comment 2 Peter Levine 2017-07-21 22:07:04 UTC
I can confirm the bug and https://src.fedoraproject.org/cgit/rpms/codeblocks.git/tree/codeblocks-16.01-gcc6.patch appears to fix it for me.
Comment 3 Dutch Ingraham 2017-07-21 23:50:05 UTC
Created attachment 486410 [details]
emerge --info codeblocks
Comment 4 Dutch Ingraham 2017-07-21 23:55:16 UTC
Created attachment 486412 [details]
codeblocks debg report
Comment 5 Dutch Ingraham 2017-07-21 23:56:37 UTC
I'll also confirm, along with the two attachments.
Comment 6 Peter Levine 2017-07-22 21:04:38 UTC
PR: https://github.com/gentoo/gentoo/pull/5175
Comment 7 David Seifert gentoo-dev 2017-07-30 16:04:50 UTC
commit e25f6fa23f1f30b6b05489f07328a8cd5d7a2c68
Author: Peter Levine <plevine457@gmail.com>
Date:   Sat Jul 22 16:59:39 2017 -0400

    dev-util/codeblocks: Fix segfault with GCC-6
    
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=625696