Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625512 - sci-mathematics/polymake fails install without '.' in @INC (do "bundled/atint/configure.pl" failed, '.' is no longer in @INC))
Summary: sci-mathematics/polymake fails install without '.' in @INC (do "bundled/atint...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Mathematics related packages
URL:
Whiteboard: ~arch only; needs version bump
Keywords: PullRequest
: 634204 810321 (view as bug list)
Depends on: 648804
Blocks: perl-5.26-no-dot-inc
  Show dependency tree
 
Reported: 2017-07-18 13:28 UTC by Kent Fredric (IRC: kent\n) (RETIRED)
Modified: 2021-10-23 00:17 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.21 KB, text/plain)
2018-02-26 18:27 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,80.07 KB, text/plain)
2018-02-26 18:27 UTC, Toralf Förster
Details
environment (environment,86.78 KB, text/plain)
2018-02-26 18:27 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.20 KB, application/x-bzip)
2018-02-26 18:27 UTC, Toralf Förster
Details
sci-mathematics:polymake-3.0_p2:20180226-182039.log (sci-mathematics:polymake-3.0_p2:20180226-182039.log,3.01 KB, text/plain)
2018-02-26 18:27 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,21.70 KB, application/x-bzip)
2018-02-26 18:27 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2017-07-18 13:28:36 UTC
See tracker bug and https://wiki.gentoo.org/wiki/Project:Perl/Dot-In-INC-Removal for details.

Though it looks like a patch that simply injects "./" in front of the relevant "do" calls will do the trick.


>>> Configuring source in /var/tmp/portage/sci-mathematics/polymake-3.0_p2/work/polymake-3.0 ...
do "bundled/atint/configure.pl" failed, '.' is no longer in @INC; did you mean do "./bundled/atint/configure.pl"? at (eval 2) line 2.
do "bundled/cdd/configure.pl" failed, '.' is no longer in @INC; did you mean do "./bundled/cdd/configure.pl"? at (eval 3) line 2.
do "bundled/javaview/configure.pl" failed, '.' is no longer in @INC; did you mean do "./bundled/javaview/configure.pl"? at (eval 4) line 2.
do "bundled/jreality/configure.pl" failed, '.' is no longer in @INC; did you mean do "./bundled/jreality/configure.pl"? at (eval 5) line 2.
do "bundled/libnormaliz/configure.pl" failed, '.' is no longer in @INC; did you mean do "./bundled/libnormaliz/configure.pl"? at (eval 6) line 2.
do "bundled/nauty/configure.pl" failed, '.' is no longer in @INC; did you mean do "./bundled/nauty/configure.pl"? at (eval 7) line 2.
do "bundled/soplex/configure.pl" failed, '.' is no longer in @INC; did you mean do "./bundled/soplex/configure.pl"? at (eval 8) line 2.
Unrecognized option --with-cdd=/usr;
Try ./configure --help for detailed information
 * ERROR: sci-mathematics/polymake-3.0_p2::gentoo failed (configure phase):


There may be more of this sort of problem deeper in though.
Comment 1 Greg Turner 2017-10-21 17:32:14 UTC
Revbump to 3.1 is probably needed (otherwise it fails building lexer).
Comment 2 Dennis Schridde 2017-12-17 10:10:08 UTC
Possible duplicate: bug #634204
Comment 3 Toralf Förster gentoo-dev 2017-12-17 10:11:03 UTC
*** Bug 634204 has been marked as a duplicate of this bug. ***
Comment 4 Dennis Schridde 2018-02-21 16:14:22 UTC
I ran into this again.  Is a fix within sight?
Comment 5 Dennis Schridde 2018-02-26 07:42:22 UTC
Should be fixed by the version bump in bug #648804, but I would like someone else to test the result of that build thoroughly.

See-Also: https://bugs.gentoo.org/648804
Comment 6 Toralf Förster gentoo-dev 2018-02-26 18:27:06 UTC
got at the unstable amd64 chroot image 17.0-desktop-gnome-systemd_20180224-115203 this : Unrecognized option --with-cdd=/usr;
Comment 7 Toralf Förster gentoo-dev 2018-02-26 18:27:09 UTC
Created attachment 521168 [details]
emerge-info.txt
Comment 8 Toralf Förster gentoo-dev 2018-02-26 18:27:12 UTC
Created attachment 521170 [details]
emerge-history.txt
Comment 9 Toralf Förster gentoo-dev 2018-02-26 18:27:16 UTC
Created attachment 521172 [details]
environment
Comment 10 Toralf Förster gentoo-dev 2018-02-26 18:27:19 UTC
Created attachment 521174 [details]
etc.portage.tbz2
Comment 11 Toralf Förster gentoo-dev 2018-02-26 18:27:23 UTC
Created attachment 521176 [details]
sci-mathematics:polymake-3.0_p2:20180226-182039.log
Comment 12 Toralf Förster gentoo-dev 2018-02-26 18:27:26 UTC
Created attachment 521178 [details]
temp.tbz2
Comment 13 Sam James archtester gentoo-dev Security 2021-08-17 02:52:20 UTC
*** Bug 634204 has been marked as a duplicate of this bug. ***
Comment 14 Michael Orlitzky gentoo-dev 2021-10-21 23:33:04 UTC
*** Bug 810321 has been marked as a duplicate of this bug. ***
Comment 15 Larry the Git Cow gentoo-dev 2021-10-23 00:17:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=db8613a7ef8e28bae0e4d6002e03676110919783

commit db8613a7ef8e28bae0e4d6002e03676110919783
Author:     Michael Orlitzky <mjo@gentoo.org>
AuthorDate: 2021-10-21 23:34:01 +0000
Commit:     Michael Orlitzky <mjo@gentoo.org>
CommitDate: 2021-10-23 00:11:23 +0000

    sci-mathematics/polymake: new upstream version 4.5.
    
    Lots of ebuild improvements (EAPI=8,...) in this one. Several bugs
    have been fixed, and some new ones likely introduced; best not to
    dwell. Now that we have something passable in the tree, it will be a
    lot easier to make incremental improvements.
    
    Closes: https://bugs.gentoo.org/618332
    Closes: https://bugs.gentoo.org/625512
    Closes: https://bugs.gentoo.org/648804
    Closes: https://github.com/gentoo/gentoo/pull/17925
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Michael Orlitzky <mjo@gentoo.org>

 sci-mathematics/polymake/Manifest               |   2 +-
 sci-mathematics/polymake/metadata.xml           |  52 ++++++++---
 sci-mathematics/polymake/polymake-3.0_p2.ebuild |  90 ------------------
 sci-mathematics/polymake/polymake-4.5.ebuild    | 117 ++++++++++++++++++++++++
 4 files changed, 158 insertions(+), 103 deletions(-)