Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625120 - sci-mathematics/coq-8.6 : Error: The files /usr/lib64/ocaml/pervasives.cmi
Summary: sci-mathematics/coq-8.6 : Error: The files /usr/lib64/ocaml/pervasives.cmi
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Mathematics related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-14 17:53 UTC by Toralf Förster
Modified: 2019-12-13 14:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.00 KB, text/plain)
2017-07-14 17:53 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,113.34 KB, text/plain)
2017-07-14 17:53 UTC, Toralf Förster
Details
environment (environment,76.69 KB, text/plain)
2017-07-14 17:53 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,30.19 KB, application/x-bzip)
2017-07-14 17:53 UTC, Toralf Förster
Details
sci-mathematics:coq-8.6:20170714-044827.log (sci-mathematics:coq-8.6:20170714-044827.log,395.22 KB, text/plain)
2017-07-14 17:53 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,33.11 KB, application/x-bzip)
2017-07-14 17:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-07-14 17:53:16 UTC
"/usr/bin/ocamlfind" ocamlc -rectypes  -c -I "+camlp4" -pp '"/usr/bin/camlp4orf" -I "+camlp4" -impl' -impl grammar/compat5.mlp
File "grammar/compat5.mlp", line 1:
Error: The files /usr/lib64/ocaml/pervasives.cmi
       and /usr/lib64/ocaml/camlp4/Camlp4.cmi make inconsistent assumptions
       over interface Pervasives
make[1]: *** [Makefile.build:257: grammar/compat5.cmo] Error 2

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-systemd_20170711-225716

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.5 (fallback)
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems)
  [2]   ruby22 (with Rubygems) *
Comment 1 Toralf Förster gentoo-dev 2017-07-14 17:53:19 UTC
Created attachment 484488 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-07-14 17:53:22 UTC
Created attachment 484490 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-07-14 17:53:25 UTC
Created attachment 484492 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-07-14 17:53:29 UTC
Created attachment 484494 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-07-14 17:53:32 UTC
Created attachment 484496 [details]
sci-mathematics:coq-8.6:20170714-044827.log
Comment 6 Toralf Förster gentoo-dev 2017-07-14 17:53:35 UTC
Created attachment 484498 [details]
temp.tbz2