Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 62454 - bmp-extra-plugins ebuild
Summary: bmp-extra-plugins ebuild
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: EBUILD
: 117086 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-08-31 17:23 UTC by will
Modified: 2005-12-29 13:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The ebuild (bmp-extra-plugins-0.2.1.ebuild,549 bytes, text/plain)
2004-08-31 17:27 UTC, will
Details
A working ebuild (bmp-extra-plugins-0.2.1.ebuild,743 bytes, text/plain)
2004-09-10 10:31 UTC, will
Details
An ebuild for previous suggestion. (bmp-extra-plugins-0.2.1.ebuild,1.83 KB, text/plain)
2004-10-08 14:53 UTC, will
Details
bmp-extra-plugins-0.2.2.ebuild (bmp-extra-plugins-0.2.2.ebuild,763 bytes, text/plain)
2004-12-21 15:59 UTC, will
Details

Note You need to log in before you can comment on or make changes to this bug.
Description will 2004-08-31 17:23:54 UTC
Here is an ebuild for bmp-extra-plugins. It compiles and installs fine, but causes bmp to crash.
Comment 1 will 2004-08-31 17:27:24 UTC
Created attachment 38636 [details]
The ebuild
Comment 2 will 2004-09-10 10:31:48 UTC
Created attachment 39332 [details]
A working ebuild

This ebuild does not install the libblursk plugin which is why bmp crashes.
Comment 3 Andrew Kopplin 2004-09-20 13:41:13 UTC
Hi. Just FYI, I got these errors using this ebuild:

oggre.c:33:27: beep/beepctrl.h: No such file or directory
oggre.c:34:29: beep/dirbrowser.h: No such file or directory
oggre.c:35:29: beep/configfile.h: No such file or directory
oggre.c:36:23: beep/util.h: No such file or directory

All those files exist in /usr/include/bmp, so I got around it with: 
ln -s /usr/include/bmp /usr/include/beep
Comment 4 Christian Axelsson 2004-10-03 04:37:23 UTC
This one should have a few USE-flags. There should be options to build the different plugins: scrobbler, blursk (some different options, minilcd, ogg, crossfade (some different options here), xf86audio, musepack, mplayer and arts (did I miss anyone, check the output of ./configure for the list)
Comment 5 will 2004-10-08 14:53:45 UTC
Created attachment 41394 [details]
An ebuild for previous suggestion.

This ebuild tries to take advantage of the suggestion previously posted. It
uses use flags for everything. Only oss support is turned on or off though. Any
suggestions?
Comment 6 Tony Vroon gentoo-dev 2004-11-21 12:23:52 UTC
I have seen this package but ignored it for now, there is no convenient way of separating the packages out (or disabling parts of it, as you've seen now).
There is interest in the crossfade plugin. Note that plugins that segfault BMP are defective, and shouldn't be included.
Comment 7 will 2004-12-21 15:59:04 UTC
Created attachment 46588 [details]
bmp-extra-plugins-0.2.2.ebuild

This is an ebuild for the newest version of the plugin set. Unfortuently
mplayer causes problems with my bmp so I disabled it. There is use flag support
for oss in crossfade and nls. It is a sweet pluginset. If someone could come up
with a patch for mplayer that would be sweet.
Comment 8 Tony Vroon gentoo-dev 2004-12-23 00:55:31 UTC
Did you also disable crossfade and musepack? Those plugins are already in portage, and one ebuild should not overwrite files that belong to another.
If blursk means blur scope, BMP seems to have that natively.
Did you test on BMP 0.9.7? It has better plugin support (more stable, gnome-vfs disabled).

I'll look at this again tonight. (I'd still like them to be separated out, but from my last try I can tell you it won't be easy).
Comment 9 will 2004-12-23 12:45:48 UTC
blursk is not blur scope. It is a completely different visulization. No I didn't disable those two. They should be disabled though. 
Comment 10 Tony Vroon gentoo-dev 2005-03-02 12:44:23 UTC
This set of plugins can not be separated out properly and would overwrite files from plugins that are already in the portage tree under their own name.
I can not create a workable ebuild out of this bug, sorry. Closing this bug, thanks for trying.
Comment 11 Russell Cloran 2005-03-12 07:36:24 UTC
I've found it is possible to separate out at least the lirc component. I'm sure it is possible with the other components, but I have not tried.

See bug 84983 and the attached ebuild for how I did this.
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2005-12-29 07:16:49 UTC
*** Bug 117086 has been marked as a duplicate of this bug. ***
Comment 13 Tony Vroon gentoo-dev 2005-12-29 13:42:53 UTC
As the duplicate shows that people are still using BMP; I would highly recommend that you look at audacious, as beep-media-player is unmaintained. Most of the functionality that BMP needed plugins for is already present in audacious when first installed.
If there is any functionality that you need that is not yet in audacious, please either try porting it yourself, or submit a bug to audacious.
No new plugins for beep-media-player will be merged.