Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 62366 - pkg-config does not automatically include /usr/local/lib in its search path.
Summary: pkg-config does not automatically include /usr/local/lib in its search path.
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-31 02:46 UTC by Don Curtis
Modified: 2004-09-01 03:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Don Curtis 2004-08-31 02:46:52 UTC
I believe that the pkg-config e-build needs to be updated such that it remedies the problem of no including /usr/local/lib.

This is not an issue for most ebuilds because they are standized for --prefix=/usr however when i compile software on my own (external of portage) i find it easy to sort it by using --prefix=/usr/local.  However, when these packages install their pc (pkg-config) files they place them in /usr/local/lib/pkgconfig.  I believe this should be automatically included in the pkg-config ebuild.  My solution is as follows:

Include a file to be installed to /etc/env.d that includes the line: PKG_CONFIG_PATH='/usr/local/lib/pkgconfig'

It seems like this feature would help many people and is not that big of a deal to include it.

Reproducible: Always
Steps to Reproduce:
1. Install a library with --prefix=/usr/local
2. Run pkg-config --list-all


Actual Results:  
pkg-config does not list the library.

Expected Results:  
shown the new library in the list of all libraries it knows about.
Comment 1 Don Curtis 2004-08-31 22:46:07 UTC
Why did this get switched to GNOME? Its a Portage / Ebuild issue.  And as far as i know pkgconfig is independant totally of gnome.  Simply a development tool.
Comment 2 foser (RETIRED) gentoo-dev 2004-09-01 03:43:13 UTC
it's not a portage/ebuild issue & pkgconfig is maintained by the gnome team fyi

I think it's wiser to keep the paths to defaults, to avoid problems with extra non-default libs. Some ppl have completely seperate installs in /usr/local or maybe in /opt . I think it's up to those -advanced- users to alter this behaviour to their need, this not a problem on any default gentoo install. So, for those reasons closing this wontfix.