Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 623566 - <sys-devel/binutils-2.31.1 - linker fails with duplicate symbols
Summary: <sys-devel/binutils-2.31.1 - linker fails with duplicate symbols
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL: https://sourceware.org/bugzilla/show_...
Whiteboard:
Keywords: REGRESSION
: 627692 634124 636664 636698 638948 639270 641960 642296 642350 642922 645408 645682 646290 646308 646358 646754 (view as bug list)
Depends on: binutils-2.31.1-stable
Blocks:
  Show dependency tree
 
Reported: 2017-07-02 17:42 UTC by Leonid Kopylov
Modified: 2019-04-29 00:00 UTC (History)
22 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.tar (build.log.tar,16.04 KB, application/x-tar)
2017-07-02 17:45 UTC, Leonid Kopylov
Details
build.log.bz2 (build.log.bz2,16.85 KB, application/bzip2)
2017-10-30 16:28 UTC, Leonid Kopylov
Details
kphotoalbum build with new binutils (kphotoalbum.tar.gz,66.94 KB, application/gzip)
2017-11-07 17:56 UTC, Frank Krömmelbein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kopylov 2017-07-02 17:42:45 UTC
# emerge --info '=media-gfx/kphotoalbum-5.2::gentoo'
Portage 2.3.6 (python 3.4.6-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-6.3.0, glibc-2.24-r3, 4.11.8-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.11.8-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700_CPU_@_3.40GHz-with-gentoo-2.4.1
KiB Mem:     4050040 total,   2677968 free
KiB Swap:    4194300 total,   3606588 free
Timestamp of repository gentoo: Sun, 02 Jul 2017 13:30:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.28 p1.2) 2.28
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo, 3.6.1-r1::gentoo
dev-util/ccache:          3.3.4::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1::gentoo
sys-apps/openrc:          0.27.2::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.15.1::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA google-chrome PUEL RAR Nero-EULA-US OPERA-2014 skype-4.0.0.7-copyright TeamViewer"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.isoc.org.il/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib accessibility acl acpi afp airplay alsa amd64 anacron antiboss apcupsd archive aspell audit avahi berkdb bidi bittorrent bluetooth bluray box branding bzip2 cairo cdda cddb cdio cdparanoia cdr clamav clamd clamdtop cli client cmus colord conntrack contrib cracklib creds cron crypt cryptsetup cups curl cxx dbus designer device-mapper discid dolphin dos drawing dri dropbox dts dvb dvd dvdr eds egl emboss emerald encode evo examples exif expat experimental face fam fat finger firefox flac fontconfig fortran ftp fuse gconf gd gdbm gegl geoip gif glamor gles gme gnome gnome-keyring gnome-online-accounts go google googledrive gpg gpm grub gssapi gstreamer gtk gtk3 gui gvfs hddtemp help histman html http httpd hunspell iconv icq icu idn image-converter imap introspection ios iostats ipod ipv6 irc iscsi itunes java jpeg jpeg2k kde kerberos lastfm lcms ldap legacy-systray libass libcaca libkms libnotify libsecret lj logrotate lua mad math mbox mdadm mdnsresponder-compat minizip mng moc modules mount mp3 mp4 mpd mpeg mpx mrim msn mtp multilib multimedia mysql nano-syntax nas natspec nautilus ncurses net netlink network-cron networkmanager nfs nftables nls notmuch nptl nscd nsplugin ntfs ntlm offensive ogg openexr opengl openmp openntpd oscar pam pango pcap pcre pdf pdfimport perl phonon pidgin pipe playlist plugman png podcast policykit pop postfix postgres ppds prediction procmail pulseaudio python qml qrcode qt3support qt4 qt5 quickstarter radio rar raw rdp readline recorder reiserfs remote rss samba sasl schroedinger scrobbler sdl seccomp session share skins skydrive slp smi smime smp smtp soundcloud spamassassin speex spell sql sqlite ssl startup-notification stats svg symlink sync-plugin-portage systemd systeminfo systray taglib tcpd telepathy tfshark theora threads thunderbird tiff tk tools tracker truetype tty-helpers udev udisks unicode upnp upnp-av upower usb v4l vala vim vim-pager vim-plugin vim-syntax vkontakte vlc vlm vnc vorbis wayland web webkit widgets winbind wininst wxwidgets x264 xa xattr xcb xfs xkb xml xmms2 xmpp xv xvid xvmc yahoo zenmap zeroconf zip zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-US he ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-beanshell wiki-publisher scripting-javascript" LINGUAS="en he ru en_US he_IL ru_RU" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22 ruby23 ruby24" USERLAND="GNU" VIDEO_CARDS="vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

# emerge -pqv '=media-gfx/kphotoalbum-5.2::gentoo'
[ebuild  N    ] media-gfx/kphotoalbum-5.2  USE="face handbook kipi map raw -debug"
Comment 1 Leonid Kopylov 2017-07-02 17:45:10 UTC
Created attachment 480016 [details]
build.log.tar
Comment 2 Andreas Sturmlechner gentoo-dev 2017-07-02 17:47:23 UTC
Version of Qt?
Comment 3 Leonid Kopylov 2017-07-02 17:49:30 UTC
(In reply to Andreas Sturmlechner from comment #2)
> Version of Qt?

qt5
Comment 4 Andreas Sturmlechner gentoo-dev 2017-07-02 17:51:38 UTC
What version of Qt5...
Comment 5 Leonid Kopylov 2017-07-02 17:56:06 UTC
(In reply to Andreas Sturmlechner from comment #4)
> What version of Qt5...

how do i find it?
Comment 6 Andreas Sturmlechner gentoo-dev 2017-07-02 18:07:26 UTC
nvm, it's at the end of your build.log anyway:


/usr/lib64/libQt5WebKitWidgets.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5WebKitWidgets.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5WebKitWidgets.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Widgets.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Widgets.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Widgets.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
...
/usr/lib64/libQt5OpenGL.so.5:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5OpenGL.so.5:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5OpenGL.so.5:(*IND*+0x0): multiple definition of `__bss_start'
collect2: error: ld returned 1 exit status
Comment 7 Michael Palimaka (kensington) gentoo-dev 2017-07-03 12:42:41 UTC
This is apparently a binutils-2.28 regression, CCing toolchain@
Comment 8 Leonid Kopylov 2017-08-12 11:27:12 UTC
*** Bug 627692 has been marked as a duplicate of this bug. ***
Comment 9 Andreas K. Hüttel gentoo-dev 2017-10-03 20:17:30 UTC
Could you please test with newer binutils? The upstream report indicates that the problem may be fixed.
Comment 10 Bernard Cafarelli gentoo-dev 2017-10-25 15:30:53 UTC
*** Bug 634124 has been marked as a duplicate of this bug. ***
Comment 11 Leonid Kopylov 2017-10-30 16:23:27 UTC
(In reply to Andreas K. Hüttel from comment #9)
> Could you please test with newer binutils? The upstream report indicates
> that the problem may be fixed.

i reinstalled the whole system, media-gfx/kphotoalbum-5.2 still failed to emerge
Comment 12 Leonid Kopylov 2017-10-30 16:28:16 UTC
Created attachment 500980 [details]
build.log.bz2
Comment 13 Michael Palimaka (kensington) gentoo-dev 2017-11-06 23:57:04 UTC
Still getting reports that this is happening with bfd.
Comment 14 Michael Palimaka (kensington) gentoo-dev 2017-11-06 23:57:15 UTC
*** Bug 636664 has been marked as a duplicate of this bug. ***
Comment 15 Michael Palimaka (kensington) gentoo-dev 2017-11-06 23:57:49 UTC
*** Bug 636698 has been marked as a duplicate of this bug. ***
Comment 16 Frank Krömmelbein 2017-11-07 17:55:18 UTC
I tried it with the newest version of the binutils, but it still fails for me.

[ebuild   R   ~] sys-devel/binutils-2.29.1-r1:2.29.1::gentoo  USE="cxx nls -multitarget -static-libs {-test} -vanilla" 0 KiB


eselect binutils list 
 [1] x86_64-pc-linux-gnu-2.28.1
 [2] x86_64-pc-linux-gnu-2.29.1 *


. /etc/profile


libQt5Gui.so.5.7.1 /usr/lib64/libQt5Core.so.5.7.1 
/usr/lib64/libQt5Gui.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Gui.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Gui.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/kphotoalbum.dir/build.make:5739: kphotoalbum] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-gfx/kphotoalbum-5.2/work/kphotoalbum-5.2_build'
make[1]: *** [CMakeFiles/Makefile2:68: CMakeFiles/kphotoalbum.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/media-gfx/kphotoalbum-5.2/work/kphotoalbum-5.2_build'
make: *** [Makefile:141: all] Error 2


I did NOT update sys-libs/binutils-libs:

[ebuild   R    ] sys-libs/binutils-libs-2.28.1:0/2.28.1::gentoo  USE="nls -64-bit-bfd -multitarget -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
Would it be necessary to update the libs as well?
Comment 17 Frank Krömmelbein 2017-11-07 17:56:30 UTC
Created attachment 502946 [details]
kphotoalbum build with new binutils
Comment 18 Martin Heusel 2017-11-26 10:27:06 UTC
same error here with opencv-2.4.13-r3 and binutils-2.29.1-r1:

[ 31%] Linking CXX shared library ../../lib/libopencv_highgui.so
cd /var/tmp/portage/media-libs/opencv-2.4.13-r3/work/opencv-2.4.13_build/modules/highgui && /usr/bin/cmake -E cmake_link_script CMakeFiles/opencv_highgui.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++ -fPIC -march=native -O2 -pipe   -fsigned-char -W -Wall -Werror=return-type -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -Wno-narrowing -Wno-delete-non-virtual-dtor -Wno-array-bounds -Wno-aggressive-loop-optimizations -fdiagnostics-show-option -Wno-long-long -pthread -ffunction-sections -fopenmp -Wno-deprecated-declarations -Wno-clobbered -Wl,-O1 -Wl,--as-needed -shared -Wl,-soname,libopencv_highgui.so.2.4 -o ../../lib/libopencv_highgui.so.2.4.13 CMakeFiles/opencv_highgui.dir/src/cap.cpp.o CMakeFiles/opencv_highgui.dir/src/cap_images.cpp.o CMakeFiles/opencv_highgui.dir/src/loadsave.cpp.o CMakeFiles/opencv_highgui.dir/src/utils.cpp.o CMakeFiles/opencv_highgui.dir/src/window.cpp.o CMakeFiles/opencv_highgui.dir/src/window_QT.cpp.o CMakeFiles/opencv_highgui.dir/qrc_window_QT.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_base.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_bmp.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_exr.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_imageio.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_jpeg.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_jpeg2000.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_png.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_pxm.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_sunras.cpp.o CMakeFiles/opencv_highgui.dir/src/grfmt_tiff.cpp.o CMakeFiles/opencv_highgui.dir/src/bitstrm.cpp.o CMakeFiles/opencv_highgui.dir/opencv_highgui_autogen/moc_compilation.cpp.o ../../lib/libopencv_imgproc.so.2.4.13 -ldl -lm -lpthread -lrt -lGLU -lGL -ltbb -lz -ljpeg -lpng -lz -ltiff /usr/lib64/libQt5Test.so.5.7.1 /usr/lib64/libQt5Concurrent.so.5.7.1 /usr/lib64/libQt5OpenGL.so.5.7.1 ../../lib/libopencv_core.so.2.4.13 -ldl -lm -lpthread -lrt -ltbb -ljpeg -lpng -ltiff /usr/lib64/libQt5Widgets.so.5.7.1 /usr/lib64/libQt5Gui.so.5.7.1 /usr/lib64/libQt5Core.so.5.7.1 
/usr/lib64/libQt5Gui.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Gui.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Gui.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_edata'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
/usr/lib64/libQt5Core.so.5.7.1:(*IND*+0x0): multiple definition of `_end'
collect2: error: ld returned 1 exit status
Comment 19 toon 2017-11-26 21:26:43 UTC
I have the same problem building opencv as Martin Heusel.
Comment 20 Andreas Sturmlechner gentoo-dev 2017-11-27 09:50:16 UTC
*** Bug 638948 has been marked as a duplicate of this bug. ***
Comment 21 Alex 2017-11-30 09:15:49 UTC
The same with opencv-2.4.13-r3, switching binutils & rebuild of qt didn't help. Has anyone found a solution?
Comment 22 Andreas Sturmlechner gentoo-dev 2017-11-30 09:50:16 UTC
*** Bug 639270 has been marked as a duplicate of this bug. ***
Comment 24 Andreas K. Hüttel gentoo-dev 2017-12-02 16:39:27 UTC
(In reply to Nico Baggus from comment #23)
> This may be a hint....
> 
> https://github.com/meta-qt5/meta-qt5/commit/
> 3ae86cb32edd1449f702e0a094929ae9b21ce191

Err, this indicates that a fix might be possible on the qt side.
Comment 25 Davide Pesavento gentoo-dev 2017-12-03 05:51:35 UTC
(In reply to Andreas K. Hüttel from comment #24)
> (In reply to Nico Baggus from comment #23)
> > This may be a hint....
> > 
> > https://github.com/meta-qt5/meta-qt5/commit/
> > 3ae86cb32edd1449f702e0a094929ae9b21ce191
> 
> Err, this indicates that a fix might be possible on the qt side.
Not really. This is a gold bug, therefore gold must be fixed.
The workaround on the qt side (force linking with bfd ld instead of gold) isn't really a solution, since the problem can appear in any other package built with gold.

Fedora added[1] a workaround to ignore duplicate symbols in bfd ld, but then removed it without explanation after updating to 2.29.

[1] https://src.fedoraproject.org/cgit/rpms/binutils.git/commit/?id=803efc2501ee7ecaf68c99bb436ea924274a6ccc
Comment 26 Larry the Git Cow gentoo-dev 2017-12-09 22:54:37 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=08de8e36f50def97e798d6e548aa7e9c8565ec35

commit 08de8e36f50def97e798d6e548aa7e9c8565ec35
Author:     Michael Palimaka <kensington@gentoo.org>
AuthorDate: 2017-12-09 22:53:45 +0000
Commit:     Michael Palimaka <kensington@gentoo.org>
CommitDate: 2017-12-09 22:54:25 +0000

    media-gfx/kphotoalbum: force gold linker to work around binutils bug
    
    Bug: https://bugs.gentoo.org/623566
    Package-Manager: Portage-2.3.14, Repoman-2.3.6

 media-gfx/kphotoalbum/Manifest               | 2 +-
 media-gfx/kphotoalbum/kphotoalbum-5.2.ebuild | 4 +++-
 2 files changed, 4 insertions(+), 2 deletions(-)}
Comment 27 Michael Palimaka (kensington) gentoo-dev 2017-12-10 11:34:59 UTC
I've pushed an additional workaround to help avoid the exposure of this breakage:
https://gitweb.gentoo.org/proj/qt.git/commit/?id=fe45faae1a15c644db0420f33a67df5197c52fcc

This will help where a user does not change their linker backwards and forwards and will only take effect after a qt update/rebuild.
Comment 28 Davide Pesavento gentoo-dev 2017-12-10 18:07:59 UTC
(In reply to Michael Palimaka (kensington) from comment #27)
> I've pushed an additional workaround to help avoid the exposure of this
> breakage:
> https://gitweb.gentoo.org/proj/qt.git/commit/
> ?id=fe45faae1a15c644db0420f33a67df5197c52fcc
> 
> This will help where a user does not change their linker backwards and
> forwards and will only take effect after a qt update/rebuild.

Good idea, thanks!
Comment 29 Michael Palimaka (kensington) gentoo-dev 2017-12-22 09:20:22 UTC
*** Bug 641960 has been marked as a duplicate of this bug. ***
Comment 30 Michael Palimaka (kensington) gentoo-dev 2017-12-22 11:57:52 UTC
I've pushed the qt5-build.eclass improvement to ::gentoo now: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=64b2ad10079f4c4931520ef102b35f672ee74d99
Comment 31 Rafał Mużyło 2017-12-23 13:02:14 UTC
(In reply to Davide Pesavento from comment #25)
> Fedora added[1] a workaround to ignore duplicate symbols in bfd ld, but then
> removed it without explanation after updating to 2.29.
> 
> [1]
> https://src.fedoraproject.org/cgit/rpms/binutils.git/commit/
> ?id=803efc2501ee7ecaf68c99bb436ea924274a6ccc

Well, it's just a guess, but seeing that in spec file one of the entries before removing that patch was 'Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild'...well, that's likely the reason for removing the patch.
Comment 32 Hanno Zysik (geki) 2017-12-23 23:15:05 UTC
Just had a look at fedora's binutils.spec[0] for 2.29.1. Patch08 (Patch09 and Patch11 - though unrelated but still interesting to have) seems to be queued for 2.30 release.

Should we wait for 2.30 or should Gentoo's binutils 2.29.1 be patched?

[0] http://pkgs.fedoraproject.org/cgit/rpms/binutils.git/tree/binutils.spec?id=b8265c46f7ddae23a792ee8306fbaaeacba83bf8#n118
Comment 33 Michael Palimaka (kensington) gentoo-dev 2017-12-27 08:41:13 UTC
*** Bug 642350 has been marked as a duplicate of this bug. ***
Comment 34 Michael Palimaka (kensington) gentoo-dev 2017-12-27 08:41:38 UTC
*** Bug 642296 has been marked as a duplicate of this bug. ***
Comment 35 Michael Palimaka (kensington) gentoo-dev 2017-12-31 23:46:25 UTC
*** Bug 642922 has been marked as a duplicate of this bug. ***
Comment 36 Rick Farina (Zero_Chaos) gentoo-dev 2018-01-03 20:22:20 UTC
on an updated system I was instructed by asturm on irc to rebuild qtcore and my issue has since vanished.  likely this will help others to at least get out of this situation.
Comment 37 Pacho Ramos gentoo-dev 2018-01-04 10:16:23 UTC
(In reply to Hanno Meyer-Thurow (geki) from comment #32)
> Just had a look at fedora's binutils.spec[0] for 2.29.1. Patch08 (Patch09
> and Patch11 - though unrelated but still interesting to have) seems to be
> queued for 2.30 release.
> 
> Should we wait for 2.30 or should Gentoo's binutils 2.29.1 be patched?
> 
> [0]
> http://pkgs.fedoraproject.org/cgit/rpms/binutils.git/tree/binutils.
> spec?id=b8265c46f7ddae23a792ee8306fbaaeacba83bf8#n118

Could Fedora patch be applied meantime? It is not too obvious to know that you need to rebuild qtcore to make qtgui build before coming here to know it :/

Thanks
Comment 38 Joseph George 2018-01-06 23:00:30 UTC
i have had the same issue too http://forums.gentoo.org/viewtopic-t-1074980-start-0-postdays-0-postorder-asc-highlight-.html

qtgui wouldn't build and only compiled successfully after rebuilding qtcore.
qtdeclarative wouldn't build and only compiled successfully after rebuilding qtnetwork.

all packages on stable x86. i haven't had any qt updates recently, but recompiling world after profile update to 17.0
Comment 39 Ben Kohler gentoo-dev 2018-01-22 19:56:02 UTC
*** Bug 645408 has been marked as a duplicate of this bug. ***
Comment 40 Michael Palimaka (kensington) gentoo-dev 2018-01-25 13:00:06 UTC
*** Bug 645682 has been marked as a duplicate of this bug. ***
Comment 41 Michael Palimaka (kensington) gentoo-dev 2018-01-30 10:09:41 UTC
mjo identified this binutils patch which may help:
https://sourceware.org/ml/binutils/2017-11/msg00543.html
Comment 42 Grant Goodyear 2018-01-30 18:29:24 UTC
Just had a failure building qtdeclarative-5.9.3:

x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -Wl,--enable-new-dtags -shared -o libparticlesplugin.so .obj/plugin.o  -L/var/tmp/portage/dev-qt/qtdeclarative-5.9.3/work/qtdeclarative-opensource-src-5.9.3/lib -lQt5QuickParticles -lQt5Quick -lQt5Qml -lQt5Gui -lQt5Network -lQt5Core -lGL -lpthread  
/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Gui.so:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Gui.so:(*IND*+0x0): multiple definition of `_edata'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Gui.so:(*IND*+0x0): multiple definition of `_end'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Network.so:(*IND*+0x0): multiple definition of `_edata'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Network.so:(*IND*+0x0): multiple definition of `__bss_start'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Network.so:(*IND*+0x0): multiple definition of `_end'
collect2: error: ld returned 1 exit status

I'm guessing this is more-of-the-same. I'm rebuilding qtcore, qtgui, and qtnetwork to see if that allows me to build qtdeclarative.
Comment 43 Grant Goodyear 2018-01-30 18:44:30 UTC
(In reply to Grant Goodyear from comment #42)
> Just had a failure building qtdeclarative-5.9.3:
> 
> x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -Wl,--enable-new-dtags
> -shared -o libparticlesplugin.so .obj/plugin.o 
> -L/var/tmp/portage/dev-qt/qtdeclarative-5.9.3/work/qtdeclarative-opensource-
> src-5.9.3/lib -lQt5QuickParticles -lQt5Quick -lQt5Qml -lQt5Gui -lQt5Network
> -lQt5Core -lGL -lpthread  
> /usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Gui.so:
> (*IND*+0x0): multiple definition of `__bss_start'
> /usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Gui.so:
> (*IND*+0x0): multiple definition of `_edata'
> /usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Gui.so:
> (*IND*+0x0): multiple definition of `_end'
> /usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Network.so:
> (*IND*+0x0): multiple definition of `_edata'
> /usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Network.so:
> (*IND*+0x0): multiple definition of `__bss_start'
> /usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/../../../../lib64/libQt5Network.so:
> (*IND*+0x0): multiple definition of `_end'
> collect2: error: ld returned 1 exit status
> 
> I'm guessing this is more-of-the-same. I'm rebuilding qtcore, qtgui, and
> qtnetwork to see if that allows me to build qtdeclarative.

Yep, that worked.
Comment 44 Michael Palimaka (kensington) gentoo-dev 2018-02-01 12:27:07 UTC
*** Bug 646290 has been marked as a duplicate of this bug. ***
Comment 45 Andreas Sturmlechner gentoo-dev 2018-02-01 15:19:57 UTC
*** Bug 646308 has been marked as a duplicate of this bug. ***
Comment 46 Andreas Sturmlechner gentoo-dev 2018-02-01 21:01:33 UTC
*** Bug 646358 has been marked as a duplicate of this bug. ***
Comment 47 Michael Palimaka (kensington) gentoo-dev 2018-02-06 12:18:59 UTC
*** Bug 646754 has been marked as a duplicate of this bug. ***
Comment 48 Andreas K. Hüttel gentoo-dev 2018-11-30 23:06:25 UTC
This might be fixed in future binutils-2.31.1-r2, fingers crossed. Not sure.


https://github.com/gentoo/binutils-gdb/commit/612de6a0d2b164816ee0d8ee8e8a2c7d3b2f477c
Comment 49 Larry the Git Cow gentoo-dev 2018-12-03 23:43:40 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0309767fb5b4f958d271526d3730a7da407b2a93

commit 0309767fb5b4f958d271526d3730a7da407b2a93
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-12-03 23:43:15 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-12-03 23:43:32 +0000

    sys-devel/binutils: 2.31.1 revbump, pl 4 (no keywords, please test!)
    
    Bug: https://bugs.gentoo.org/672398
    Bug: https://bugs.gentoo.org/672126
    Bug: https://bugs.gentoo.org/623566
    Package-Manager: Portage-2.3.52, Repoman-2.3.12
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 sys-devel/binutils/Manifest                  |   1 +
 sys-devel/binutils/binutils-2.31.1-r2.ebuild | 427 +++++++++++++++++++++++++++
 2 files changed, 428 insertions(+)
Comment 50 Larry the Git Cow gentoo-dev 2018-12-08 18:03:24 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=39bff4d8ecf2590b647d7aef196b7f22d57b85c6

commit 39bff4d8ecf2590b647d7aef196b7f22d57b85c6
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-12-08 17:54:03 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-12-08 18:03:10 +0000

    sys-devel/binutils: rekeyword
    
    Closes: https://bugs.gentoo.org/672398
    Bug: https://bugs.gentoo.org/623566
    Closes: https://bugs.gentoo.org/672126
    Package-Manager: Portage-2.3.52, Repoman-2.3.12
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 sys-devel/binutils/binutils-2.31.1-r2.ebuild | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
Comment 51 Larry the Git Cow gentoo-dev 2019-04-29 00:00:09 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=894e4f2719e94cdfbb639dbaffbcec1433d206bb

commit 894e4f2719e94cdfbb639dbaffbcec1433d206bb
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2019-04-28 23:58:37 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2019-04-28 23:58:37 +0000

    package.mask: Mask <sys-devel/binutils-2.31.1-r4 and friends
    
    Closes: https://bugs.gentoo.org/623566
    Bug: https://bugs.gentoo.org/676460
    Bug: https://bugs.gentoo.org/682702
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 profiles/package.mask | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)