Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 62324 - Kernel Panic after install and grub setup.
Summary: Kernel Panic after install and grub setup.
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: Normal major (vote)
Assignee: Robert Moss (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-30 19:02 UTC by Jamie Pate
Modified: 2005-03-25 11:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jamie Pate 2004-08-30 19:02:22 UTC
I thin I followed the directions to a T, and I have repeated the steps 4 times.  Yet I get the same results.  I'm sorry if there is something I have overlooked but I am new to linux, so sorry ahead of time.

System Hardware:
ASUS P4G8X-Deluxe
P4-2400/533
1.0GB DDR400
Lite-On DVD+-R+-RW (Secondary Master)
SATA Raptor 74GB 10000rpm (secondary SATA)
SATA Raptor 36GB 10000rpm (primary SATA [BOOT][Gentoo/grub])
WD2000JB 200GB 7200rpm (Primary Master IDE)
FDD

SATA Raptor 36GB Partitioning:
/dev/sda1     jfs     512MB
/dev/sda2     swap    2GB
/dev/sda3     jfs     rest

Problem:
After completing the install manually configuring the kernel (turning more on than off). After configuring Grub and debugging my grub issues I have a working grub configuration:

"root (hd0,0)"
"kernel /kernel-2.4.26-gentoo-r9 root=/dev/hde"

Now the error comes up saying:

"Kernel panic: VFS: unable to mount root fs on 21:00"

I do notice that in the LiveCD enviroment i would refer to the harddrive i was installing Gentoo into would be refered to as /dev/sda but in grub i have to specify it as /dev/hde...?  and is there any reason I can't use jfs for my file systems for both boot and root?
Comment 1 Benjamin Judas (RETIRED) gentoo-dev 2004-08-30 20:40:20 UTC
It's probably something related to your kernel-configuration. Since it worked with the CD, it also has to work from your running system. Check your kernel-configuration again and make sure you didn't forget anything. Grub itselft should be able to handle jfs. In any case, this "bug" (it's not really a bug, since it worked off the livecd and should work with a properly configured kernel) is not a Live-CD bug, so I am reassigning it to bug wranglers.
Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-31 06:00:47 UTC
#1. What kernel did you use?  If you used gentoo-dev-sources, then make sure you've disabled any SATA stuff under IDE/ATA and instead enabled the SATA under SCSI, as it is a newer and more complete interface.

#2. Why are you using JFS for your /boot?  I don't see any reason why it shouldn't work, but I believe that ext2 is preferred simply for compatability reasons.

#3. Why are you using /dev/hde for grub?  The error you're getting is making me think that it *should* be /dev/sda3.  If it *was* supposed to be /dev/hde, it would be /dev/hde3 anyway.

Assigning to maintainer for grub to see if he can think of something that I missed.
Comment 3 Brad Cowan (RETIRED) gentoo-dev 2004-08-31 06:25:55 UTC
Every point Chris made is valid, also one I seen...a 2 gig swap partition is pretty excessive when you have a gig of ram. I have over a gig of ram and if I ever get into swap its rarely over 50 megs. I would advise 256 or 512 meg swap some people would suggest allot less :P
Comment 4 Robert Moss (RETIRED) gentoo-dev 2004-08-31 09:27:10 UTC
Considering there's 310GB of total disk space there, a 2GB swap partition isn't exactly excessive, so it's probably fine.

However, the issue here is a configuration one. The kernel panic error occurs because your root filesystem is not getting mounted. The use of JFS has been shown to be fine here, because grub has clearly read the configuration file off it.

So, try changing the kernel line of your /boot/grub/grub.conf to:

kernel /kernel-2.4.26-gentoo-r9 root=/dev/sda3

The "root=" argument is what the *kernel* sees, not what anything else sees. So if a 2.4.26 kernel sees your root partition as /dev/sda3, then /dev/sda3 is what goes into grub.conf.

Changing status to RESOLVED INVALID - if the above suggestion doesn't work, please reopen. If it does work, please (!) report back here to let us know that this isn't something that needs fixing.
Comment 5 Benjamin Judas (RETIRED) gentoo-dev 2004-08-31 11:59:11 UTC
User send the following e-mail to me:

"Sorry I figured out half my issue late last night.  my grub statement
set root for /dev/hde yet it should be /dev/hde3...  One dumb mistake
behind me and a little wiser with linux now...  I have it trying to
boot at least now...  Other issues now but I'm going to try and fiddle
more before I bother the professionals again..."

So this is definitely done.
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2005-03-25 11:25:05 UTC
Moving these so we can remove the "Install CD" component from "Gentoo Linux".

I apologize to everyone for this spam, but according to the bugzilla developers,
this is the only reasonable way to do this.