Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 622420 - dev-python/matplotlib-2.1.2-r1 and dev-python/matplotlib-2.2.0: keywordreq
Summary: dev-python/matplotlib-2.1.2-r1 and dev-python/matplotlib-2.2.0: keywordreq
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 646610 (view as bug list)
Depends on: 650254
Blocks: 636054
  Show dependency tree
 
Reported: 2017-06-21 19:40 UTC by Michał Górny
Modified: 2018-04-22 07:35 UTC (History)
2 users (show)

See Also:
Package list:
dev-python/matplotlib-2.1.2-r1 dev-python/matplotlib-2.2.0 dev-python/subprocess32-3.2.7 dev-python/colorspacious-1.1.0 dev-python/sphinx-gallery-0.1.12 dev-python/kiwisolver-1.0.1 dev-python/cairocffi-0.8.0 dev-python/xcffib-0.5.1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-06-21 19:40:43 UTC
The 2.0.2 bump lost the following keywords:

  ~arm ~ppc

Might be worth the effort to rekeyword it.
Comment 1 Benda Xu gentoo-dev 2017-07-05 07:41:30 UTC
I don't have access to a ppc box. Are you going to ask the arch team to test it out?

Otherwise we can wait for specific keyword requests from a user.
Comment 2 Andreas Sturmlechner gentoo-dev 2018-01-05 18:38:46 UTC
Arches, please keyword so we can continue with removal of old matplotlib and subsequently qt4-removal.
Comment 3 Matt Turner gentoo-dev 2018-03-12 00:47:46 UTC
added ~ppc64
Comment 4 Stabilization helper bot gentoo-dev 2018-03-12 01:03:16 UTC
An automated check of this bug failed - repoman reported dependency errors (51 lines truncated): 

> dependency.bad dev-python/matplotlib/matplotlib-2.2.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/kiwisolver-1.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/sphinx-gallery-0.1.12[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.2.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/kiwisolver-1.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.badindev dev-python/matplotlib/matplotlib-2.2.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0/armv4) ['>=dev-python/kiwisolver-1.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/sphinx-gallery-0.1.12[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 5 Matt Turner gentoo-dev 2018-03-12 02:08:09 UTC
Readding ppc64@ after dropping keyword due to missing deps.
Comment 6 Stabilization helper bot gentoo-dev 2018-03-12 03:01:19 UTC
An automated check of this bug failed - repoman reported dependency errors (63 lines truncated): 

> dependency.bad dev-python/matplotlib/matplotlib-2.2.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/kiwisolver-1.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/sphinx-gallery-0.1.12[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.2.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/kiwisolver-1.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.2.0.ebuild: DEPEND: ~ppc64(default/linux/powerpc/ppc64/17.0/64bit-userland) ['>=dev-python/kiwisolver-1.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/sphinx-gallery-0.1.12[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 7 Matt Turner gentoo-dev 2018-03-12 06:45:27 UTC
Well, that didn't work. Help?
Comment 8 Andreas Sturmlechner gentoo-dev 2018-03-15 19:49:09 UTC
Okay, let's clean up here.

(In reply to Matt Turner from comment #7)
> Well, that didn't work. Help?
matplotlib >2.1.0-r1 RDEPENDs on dev-python/sphinx-gallery so that broke when you raised the version in package list. And >=2.2.0 needs dev-python/kiwisolver-1.0.1 in addition. But also bug 636054 would be broken now that 2.1.0-r1 is no longer getting keyworded here.

The best solution if we don't want to go back to 2.1.0-r1 is to clean up bug interdeps and integrate sphinx-gallery keywording here.

- Adding dev-python/matplotlib-2.1.2-r1 to satisfy bug 636054
- Adding dev-python/sphinx-gallery-0.1.12 to obsolete bug 646610
- Adding dev-python/kiwisolver-1.0.1 to fix deps
- Adding ppc, seems it was forgotten
Comment 9 Andreas Sturmlechner gentoo-dev 2018-03-15 19:50:49 UTC
*** Bug 646610 has been marked as a duplicate of this bug. ***
Comment 10 Stabilization helper bot gentoo-dev 2018-03-15 20:02:39 UTC
An automated check of this bug failed - repoman reported dependency errors (170 lines truncated): 

> dependency.bad dev-python/matplotlib/matplotlib-2.1.2-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.2-r1.ebuild: RDEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.2-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.2-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.2-r1.ebuild: RDEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.2-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 11 Sergei Trofimovich gentoo-dev 2018-03-18 10:42:45 UTC
~ppc64 keyworded
Comment 12 Andrey Grozin gentoo-dev 2018-03-18 21:20:18 UTC
2.2.2 has appeared. It is a bug-fix release for the LTS 2.2. We should also add keywords to 2.2.2.
Comment 13 Sergei Trofimovich gentoo-dev 2018-03-19 07:31:43 UTC
~ppc keyworded
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-04-22 07:35:13 UTC
~arm added