Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 622024 - dev-lang/rust-1.16.0 undefined reference to '__muloti4' with GCC 7.1.0-r1 LTO
Summary: dev-lang/rust-1.16.0 undefined reference to '__muloti4' with GCC 7.1.0-r1 LTO
Status: RESOLVED DUPLICATE of bug 682866
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Georgy Yakovlev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: lto
  Show dependency tree
 
Reported: 2017-06-17 11:52 UTC by Steffen Hau
Modified: 2020-03-18 20:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (dev-lang_rust-1.16.0-build.log.xz,89.85 KB, application/x-xz)
2017-06-17 11:52 UTC, Steffen Hau
Details
build.log for rust 1.19.0 with gcc 6.4.0 (build.log,31.22 KB, text/xz-stream)
2017-11-19 19:42 UTC, Jeffrey Lin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Hau 2017-06-17 11:52:56 UTC
Created attachment 476740 [details]
build.log

error: linking with `x86_64-pc-linux-gnu-gcc` failed: exit code: 1
  |
  = note: "x86_64-pc-linux-gnu-gcc" "-Wl,--as-needed" "-Wl,-z,noexecstack" "-m64" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/bin/rustc.0.o" "-o" "x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/bin/rustc" "-Wl,--gc-sections" "-pie" "-Wl,-O1" "-nodefaultlibs" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/llvm/lib" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-Wl,-Bstatic" "-Wl,-Bdynamic" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_driver-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_lint-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_privacy-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_save_analysis-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_typeck-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_borrowck-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_mir-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_passes-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_resolve-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_plugin-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_metadata-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "syntax_ext-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "proc_macro-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_trans-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_const_eval-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_platform_intrinsics-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_incremental-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_const_math-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_back-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "syntax-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_data_structures-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_errors-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "syntax_pos-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "term-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "log-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "serialize-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "rustc_llvm-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "graphviz-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "getopts-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "fmt_macros-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "arena-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "flate-63283ac5" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "std-63283ac5" "/home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib/libcompiler_builtins-63283ac5.rlib" "-l" "rt" "-l" "dl" "-l" "pthread" "-l" "m" "-l" "stdc++" "-l" "dl" "-l" "pthread" "-l" "gcc_s" "-l" "pthread" "-l" "c" "-l" "m" "-l" "rt" "-l" "util"
  = note: /home/gentoo/tmp/portage/dev-lang/rust-1.16.0/work/rustc-1.16.0-src/x86_64-unknown-linux-gnu/stage1/lib64/rust-1.16.0/rustlib/x86_64-unknown-linux-gnu/lib/librustc_const_math-63283ac5.so: error: undefined reference to '__muloti4'
          collect2: error: ld returned 1 exit status
          

error: aborting due to previous error


Adding -fno-lto fixes the build failure.
Comment 1 Jeffrey Lin 2017-11-19 19:42:41 UTC
Created attachment 504998 [details]
build.log for rust 1.19.0 with gcc 6.4.0

Still an issue on rust 1.19.0.
Comment 2 Dirkjan Ochtman gentoo-dev 2018-05-14 13:03:21 UTC
Can anyone still reproduce this with Rust 1.25.0 or later?
Comment 3 Steffen Hau 2018-05-14 20:20:16 UTC
Yes, rust-1.26.0 fails with LTO enabled:

error: linking with `x86_64-pc-linux-gnu-gcc` failed: exit code: 1
  |
  = note: "x86_64-pc-linux-gnu-gcc" "-Wl,--as-needed" "-Wl,-z,noexecstack" "-m64" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-sysroot/lib/rustlib/x86_64-unknown-linux-gnu/lib" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/rustc-de3f03829f2fc917.rustc0-5eee6fc2d7e46788fe3205594ae0bc24.rs.rcgu.o" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/rustc-de3f03829f2fc917.rustc1-5eee6fc2d7e46788fe3205594ae0bc24.rs.rcgu.o" "-o" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/rustc-de3f03829f2fc917" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/rustc-de3f03829f2fc917.crate.allocator.rcgu.o" "-Wl,--gc-sections" "-pie" "-Wl,-z,relro,-z,now" "-Wl,-O1" "-nodefaultlibs" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/release/deps" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/build/backtrace-sys-5891bf0101f32727/out/.libs" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/build/miniz-sys-2911c7b5ca977aa1/out" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-sysroot/lib/rustlib/x86_64-unknown-linux-gnu/lib" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_driver-50c02524c7376ab6" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_trans_utils-30f26ccb972ec479" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_traits-1d3ce2aa55afe4d8" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_save_analysis-77d8b0a4f003605a" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_resolve-316d47483ef58e03" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_incremental-e34b2efc5fe9582c" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_privacy-50e821865ae29774" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_typeck-1b0b88ea89c953ed" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_platform_intrinsics-520a31e9b4b1ad1f" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_plugin-ed137e46708653d8" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_metadata-756c87cb5aa8cdab" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "syntax_ext-cba611ea3b482019" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_lint-8133ffe21a08c649" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_passes-1fc09a8ce2362aed" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_borrowck-4277c4b02def0f39" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_mir-5248aa2a08b8a5bb" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_allocator-bf3520f7fee6bbde" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc-4e5e10fde8f20759" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-sysroot/lib/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "test-a19ec22539e671bc" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-sysroot/lib/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "term-56989bc792f2a3b1" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "proc_macro-6d8f8aed086be9f0" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_const_math-bda1fe2e3d9116aa" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_back-0c01adfc30e4fffa" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "syntax-fbc249743facc3aa" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_errors-c9391cb42eb4751e" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "syntax_pos-2bc35320c19135ba" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_data_structures-140b05c26923af37" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "serialize-6b77f29b6ee45775" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "rustc_cratesio_shim-323fc1c8b9db9f7d" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "fmt_macros-4fb191c19db78008" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "graphviz-9b9916e05a598b7c" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps" "-l" "arena-ad409c7ea45bee67" "-L" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-sysroot/lib/rustlib/x86_64-unknown-linux-gnu/lib" "-l" "std-d5ed4fef985b1338" "-Wl,-Bstatic" "/home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-sysroot/lib/rustlib/x86_64-unknown-linux-gnu/lib/libcompiler_builtins-40225d50b2d84d63.rlib" "-Wl,-Bdynamic" "-l" "util" "-l" "util" "-l" "dl" "-l" "rt" "-l" "pthread" "-l" "gcc_s" "-l" "c" "-l" "m" "-l" "rt" "-l" "pthread" "-l" "util" "-l" "util"
  = note: /home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/librustc-4e5e10fde8f20759.so: error: undefined reference to '__rbt_backtrace_pcinfo'
          /home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/librustc-4e5e10fde8f20759.so: error: undefined reference to '__rbt_backtrace_syminfo'
          /home/gentoo/tmp/portage/dev-lang/rust-1.26.0/work/rustc-1.26.0-src/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/librustc-4e5e10fde8f20759.so: error: undefined reference to '__rbt_backtrace_create_state'
          collect2: error: ld returned 1 exit status


Just the referenced function has changed. Btw.: I'm also not able to compile any dev-util/cargo version with LTO enabled. It reports a lot of undefined reference to libgit related functions.
Comment 4 Jonas Stein gentoo-dev 2020-03-18 20:57:35 UTC
this version is no longer in the tree. But the problem is still present. 
Closing as duplicate with link to the newer ticket exceptionally.

*** This bug has been marked as a duplicate of bug 682866 ***