Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 62085 - Porting: orbit-2.10.4
Summary: Porting: orbit-2.10.4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: PPC All
: High normal (vote)
Assignee: osx porters
Depends on: 61689 64779 70448
Blocks: 63363
  Show dependency tree
Reported: 2004-08-29 04:11 UTC by dario
Modified: 2007-06-12 17:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

patch for orbit-2.10.4 on macos (orbit-macos.patch,1.01 KB, patch)
2004-08-29 04:18 UTC, dario
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description dario 2004-08-29 04:11:13 UTC
Looking at fink project I wrote this simple patch to make orbit 2.10.4 compiling on macos. Never tried it running.

Reproducible: Always
Steps to Reproduce:
Comment 1 dario 2004-08-29 04:18:30 UTC
Created attachment 38423 [details, diff]
patch for orbit-2.10.4 on macos
Comment 2 foser (RETIRED) gentoo-dev 2004-08-29 05:13:07 UTC
try it running.. dunno why you file a patch from some other project which you haven't tested ?
Comment 3 dario 2004-08-29 09:26:31 UTC
I don't know how to test it, I have emerged it to compile mozilla, but after emerging this version I saw that the old version is required :(

To emerge the old version I need the old glib, that won't compile :((
Comment 4 Roman Dilken 2004-11-09 04:30:24 UTC
I'm trying to port orbit 2.12.0.
Here is the error I get:

checking for poptStrippedArgv in -lpopt... no
configure: error: You must have popt version 1.5 or greater installed.

But: popt is installed correctly and ranlib /usr/lib/libpopt.a doesn't help either.

Here my emerge info:

!!! Relying on the shell to locate gcc, this may break
!!! DISTCC, installing gcc-config and setting your current gcc
!!! profile will fix this
Portage 2.0.51-r3 (default-macos/ppc/10.3, gcc-3.3, libsystem-7.1-r0, 7.5.0 Power Macintosh)
System uname: 7.5.0 Power Macintosh powerpc
distcc 2.0.1-zeroconf powerpc-apple-darwin7.0 (protocol 1) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.57,sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.6.3,sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="ppc-macos ~ppc-macos"
CFLAGS="-O3 -pipe  -mcpu=G5 -mtune=G5 -mpowerpc64 -funroll-loops"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -pipe  -mcpu=G5 -mtune=G5 -mpowerpc64 -funroll-loops"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks keepwork"
USE="ppc X berkdb debug gif hbci jpeg justify makecheck multilib nls nptl ofx ppc-macos quotes recode ssl threads tiff unicode usb"

Comment 5 Kito (RETIRED) gentoo-dev 2004-11-09 07:56:23 UTC
it looks like your version libpopt is static, probably need to build a dynamic version as well. Heres what i have:

% ls /usr/lib/libpop*
/usr/lib/libpopt.0.0.0.dylib /usr/lib/libpopt.dylib
/usr/lib/libpopt.0.dylib     /usr/lib/
Comment 6 Roman Dilken 2004-11-09 08:14:42 UTC
No, I have the same files for libpopt.
Look what I've found in config.log:

configure:21845: checking for poptStrippedArgv in -lpopt
configure:21875: gcc -o conftest -O3 -pipe  -mcpu=G5 -mtune=G5 -mpowerpc64 -funr
oll-loops -g -g -g   conftest.c -lpopt   >&5
ld: Undefined symbols:

It seems that gettext breaks orbit but gettext can't be compiled due to bug 70448.
Comment 7 Roman Dilken 2004-11-15 03:45:24 UTC
Here is what I got after upgrading gettext. Now I have the problem with multiple definitions of local_charset...

gcc -O3 -pipe -mcpu=G5 -mtune=G5 -mpowerpc64 -funroll-loops -g -g -g -o test-linc test-linc.o -pthreads  ../src/.libs/liblinc.a -L/usr/lib /usr/lib/libgobject-2.0.dylib /usr/lib/libgthread-2.0.dylib /usr/lib/libglib-2.0.dylib /usr/lib/libintl.dylib -lc /usr/lib/libiconv.dylib
gcc: unrecognized option `-pthreads'
ld: warning multiple definitions of symbol _locale_charset
/usr/lib/libintl.dylib(localcharset.o) definition of _locale_charset
/usr/lib/libiconv.dylib(localcharset.o) definition of _locale_charset
ld: Undefined symbols:
make[3]: *** [test-linc] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Comment 8 Roman Dilken 2004-11-15 04:18:24 UTC
I had the problem before, too but I thought it would be solved by the latest gettext. But that's not the real problem, it seems...
Comment 9 Kito (RETIRED) gentoo-dev 2004-11-15 07:38:13 UTC
the multiple symbols are just a warning. Its looking for a bind symbol. Try using
Comment 10 Roman Dilken 2004-11-15 07:42:50 UTC
It seems to work, thank you.
Is it generally a good idea to put these CFLAGS into make.conf?
Comment 11 Kito (RETIRED) gentoo-dev 2004-11-15 08:23:13 UTC
no, its just for things that use the bind functions.
Comment 12 Hasan Khalil (RETIRED) gentoo-dev 2005-01-20 21:45:33 UTC
Can we get a status update on this? Where are we with respect to orbit?
Comment 13 Lina Pezzella (RETIRED) gentoo-dev 2005-01-22 13:34:49 UTC
libIDL is a dependency of orbit. Keyworded today. The last dependency is indent. Apple provides a BSD version of indent. See Bug #61689
Comment 14 Markus Ullmann (RETIRED) gentoo-dev 2007-06-12 17:46:27 UTC
see you in prefix :)