Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 620726 - net-irc/quassel[qt4,webkit] depends on dev-qt/qtwebkit:4
Summary: net-irc/quassel[qt4,webkit] depends on dev-qt/qtwebkit:4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qtwebkit4-removal
  Show dependency tree
 
Reported: 2017-06-04 07:14 UTC by Michael Palimaka (kensington)
Modified: 2017-06-05 09:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2017-06-04 07:14:30 UTC
net-irc/quassel[qt4,webkit] depends on dev-qt/qtwebkit:4 which is ancient and will never see any security updates.

Since there's a perfectly good Qt 5 available, I'd suggest just removing the qt4 USE flag completely.
Comment 1 Johannes Huber gentoo-dev 2017-06-05 09:10:20 UTC
(In reply to Michael Palimaka (kensington) from comment #0)
> ...
> Since there's a perfectly good Qt 5 available, I'd suggest just removing the
> qt4 USE flag completely.

Still font issues in Qt5/Plasma env as Qt 4 won't go away in the near future, I decided to keep qt4 build option.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8110a18906f52f1c600a1f1976ad7e17b878279e