Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 620698 - dev-embedded/pikdev depends on dev-qt/qtwebkit:4
Summary: dev-embedded/pikdev depends on dev-qt/qtwebkit:4
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Rafael Martins
URL:
Whiteboard: Pending removal: 2017-08-14
Keywords: PMASKED
Depends on:
Blocks: qtwebkit4-removal
  Show dependency tree
 
Reported: 2017-06-04 06:43 UTC by Michael Palimaka (kensington)
Modified: 2017-08-14 07:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2017-06-04 06:43:44 UTC
dev-embedded/pikdev depends on dev-qt/qtwebkit:4 which is ancient and will never see any security updates.

Since upstream appears to be dead and no Qt 5 port is available, it might be time to remove this package if webkit support cannot be disabled.
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-08-14 07:28:54 UTC
commit 8d646d9d4fbf6954590ccc89a77b3ad783716ae7
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: Mon Aug 14 09:27:38 2017
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: Mon Aug 14 09:28:20 2017

    dev-embedded/pikdev: Remove last-rited pkg, #620698

 dev-embedded/pikdev/Manifest            |  1 -
 dev-embedded/pikdev/metadata.xml        | 13 ----------
 dev-embedded/pikdev/pikdev-1.4.0.ebuild | 46 ---------------------------------
 profiles/package.mask                   |  5 ----
 4 files changed, 65 deletions(-)