Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 620474 - sci-electronics/qucs depends on deprecated Qt4/Qt3Support (was: 0.0.19 version bump)
Summary: sci-electronics/qucs depends on deprecated Qt4/Qt3Support (was: 0.0.19 versio...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Michał Górny
URL: https://github.com/Qucs/qucs/blob/quc...
Whiteboard: Masked for removal on 2018-05-03
Keywords: PMASKED
Depends on:
Blocks: 624740 qt4-removal 648668
  Show dependency tree
 
Reported: 2017-06-03 06:52 UTC by Karsten Merkle
Modified: 2018-05-03 11:45 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
qucs-0.0.19.ebuild (qucs-0.0.19.ebuild,922 bytes, text/plain)
2017-06-03 06:52 UTC, Karsten Merkle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karsten Merkle 2017-06-03 06:52:37 UTC
Created attachment 475072 [details]
qucs-0.0.19.ebuild

I did a rough ebuild for qucs-0.0.19 no use flags & test-cases.
Compiles and works for me
Comment 1 Jonas Stein gentoo-dev 2017-06-03 08:20:44 UTC
Thank you. 
Please fix also the header and test it with repoman. 

These lines should be cleaned a bit:

cd qucs-core || die
sed -i 's:hicumL2V2p31n.core.h::g' src/components/verilog/Makefile.in || die
cd ..
Comment 2 Andreas Sturmlechner gentoo-dev 2017-11-30 00:33:22 UTC
I was just going to file last-rites when I found this bug. It seems that even 0.0.19 still depends on Qt3Support, which is not a good sign. Karsten, if you are still interested in this package, could you maybe check if at least git master is buildable without qt3support now?
Comment 3 eroen 2018-01-03 20:00:20 UTC
Getting this bumped would really be great, the 0.0.18 version in gentoo suffers from at least one severe usability bug.[0]

0: https://github.com/Qucs/qucs/issues/401
Comment 4 Andreas Sturmlechner gentoo-dev 2018-01-03 20:06:12 UTC
some qt3support-removal work: https://github.com/Qucs/qucs/issues/753
qucs-s fork: https://ra3xdh.github.io/
Comment 5 Andreas Sturmlechner gentoo-dev 2018-03-18 18:23:48 UTC
At this point we should not bother with any bump that is not yet ported to Qt5.

last chance Qt5-WIP-maintainer-fork: https://github.com/guitorri/qucs/tree/wip/eduard/removing-qt3/qucs
Comment 6 Andreas Sturmlechner gentoo-dev 2018-03-18 20:53:31 UTC
Or actually: https://github.com/guitorri/qucs/tree/QG-port-08

But upstream can't tell an estimate until next release...
Comment 7 Larry the Git Cow gentoo-dev 2018-05-03 11:45:42 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=79498debc64c5fe9c456d6a1f11f7b865a3abccc

commit 79498debc64c5fe9c456d6a1f11f7b865a3abccc
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-05-03 11:41:24 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-05-03 11:45:06 +0000

    sci-electronics/qucs: Remove last-rited package
    
    Closes: https://bugs.gentoo.org/620474
    Closes: https://bugs.gentoo.org/624740
    Closes: https://bugs.gentoo.org/648668

 profiles/package.mask                             |   5 -
 sci-electronics/qucs/Manifest                     |   1 -
 sci-electronics/qucs/files/qucs-0.0.18-gcc6.patch | 189 ----------------------
 sci-electronics/qucs/metadata.xml                 |  15 --
 sci-electronics/qucs/qucs-0.0.18.ebuild           |  68 --------
 5 files changed, 278 deletions(-)