Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 620056 - app-text/mupdf-1.11-r1: gl error 65544, Wayland issues
Summary: app-text/mupdf-1.11-r1: gl error 65544, Wayland issues
Status: RESOLVED DUPLICATE of bug 616968
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Weber (RETIRED)
Depends on:
Reported: 2017-05-29 01:27 UTC by fuse809
Modified: 2017-06-22 23:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

strace.log (strace.log,26.26 KB, text/x-log)
2017-05-29 01:29 UTC, fuse809
LD_DEBUG=libs mupdf <FILE> output (mupdf-debug.log,13.85 KB, text/x-log)
2017-05-29 01:30 UTC, fuse809

Note You need to log in before you can comment on or make changes to this bug.
Description fuse809 2017-05-29 01:27:41 UTC
Even though there are no Wayland dependencies for app-text/mupdf-1.11-r1 oddly even I try to launch it is tries to launch but fails giving the error:

gl error 65544: Wayland: Failed to connect to display
cannot initialize glfw

media-libs/glfw-3.2.1 is installed, however. emerge -pqv app-text/mupdf returns:

[ebuild   R   ] app-text/mupdf-1.11-r1  USE="X curl opengl openssl -javascript -libressl -static -static-libs -vanilla"

If it relevant this is occurring under the i3 window manager (I do not know its behaviour under other window managers/desktop environments). I ran:

equery g mupdf | grep -i wayland

to check for any Wayland dependencies and no Wayland dependency came up. My architecture is AMD64 if relevant. LD_DEBUG=libs mupdf returns: (I have not been able to attach logs to bugs, sorry). I will add the output of emerge --info app-text/mupdf to the first comment. strace -o strace.log mupdf <FILE> returns:
Comment 1 fuse809 2017-05-29 01:28:05 UTC
Portage 2.3.6 (python 3.4.6-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-6.3.0, glibc-2.24-r1, 4.11.3-ck-r1 x86_64)
                         System Settings
System uname: Linux-4.11.3-ck-r1-x86_64-Intel-R-_Core-TM-_i7-4700MQ_CPU_@_2.40GHz-with-gentoo-2.3
KiB Mem:    16344052 total,   4631976 free
KiB Swap:          0 total,         0 free
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo
dev-util/cmake:           3.8.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.2::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo

    location: /usr/portage
    sync-type: git
    priority: -1000

    location: /usr/local/fusion809-overlay
    masters: gentoo

    location: /usr/local/flatpak-overlay
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/gamerlay
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/games-overlay
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/gnome
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/grub2-themes
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/kde
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/mozilla
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/steam-overlay
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/tlp-portage
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bumblebee bzip2 cairo cdda cdr cli cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kms kwallet lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl nvidia ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis wayland widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid xwayland zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="en en_AU en_GB en_US en-AU en-GB en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_AU en_GB en-AU en-GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

app-text/mupdf-1.11-r1::gentoo was built with the following:
USE="X curl opengl openssl -javascript -libressl -static -static-libs -vanilla" ABI_X86="(64)"
Comment 2 fuse809 2017-05-29 01:29:00 UTC
Created attachment 474596 [details]
Comment 3 fuse809 2017-05-29 01:29:18 UTC
I'll be I can attach logs now. I'll attach all the ones I pastebinned.
Comment 4 fuse809 2017-05-29 01:30:09 UTC
Created attachment 474598 [details]
LD_DEBUG=libs mupdf <FILE> output

LD_DEBUG=libs mupdf <FILE> output
Comment 5 fuse809 2017-05-29 04:02:16 UTC
I tried following to get some more info about the bug but in GDB (started by gdb --args mupdf <FILE> `perl -e 'print "A"x100'`) running run returned:

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/".
gl error 65544: Wayland: Failed to connect to display
cannot initialize glfw
[Inferior 1 (process 10147) exited with code 01]

running bt returned:

No stack.

I did build muPDF with FEATURES="nostrip" and with the -ggdb compiler option before running GDB on it.
Comment 6 curious 2017-06-08 20:19:12 UTC
same things happens to me : 

error: XDG_RUNTIME_DIR not set in the environment.
gl error 65544: Wayland: Failed to connect to display
cannot initialize glfw
Comment 7 Michael Weber (RETIRED) gentoo-dev 2017-06-22 23:06:14 UTC
this can be traced to a mupdf build having media-libs/glfw[wayland] installed.
Comment 8 Michael Weber (RETIRED) gentoo-dev 2017-06-22 23:10:46 UTC
glfw[wayland] disables X11 support, see bug 616968

*** This bug has been marked as a duplicate of bug 616968 ***