Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 619646 - dev-ruby/redcloth-4.3.2 : LoadError: cannot load such file -- rake/extensiontask
Summary: dev-ruby/redcloth-4.3.2 : LoadError: cannot load such file -- rake/extensiontask
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-25 06:52 UTC by Toralf Förster
Modified: 2017-05-26 07:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,5.69 KB, text/plain)
2017-05-25 06:52 UTC, Toralf Förster
Details
dev-ruby:redcloth-4.3.2:20170525-004249.log (dev-ruby:redcloth-4.3.2:20170525-004249.log,2.94 KB, text/plain)
2017-05-25 06:52 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,299.32 KB, text/plain)
2017-05-25 06:52 UTC, Toralf Förster
Details
environment (environment,160.86 KB, text/plain)
2017-05-25 06:52 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,25.91 KB, application/x-bzip)
2017-05-25 06:52 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-05-25 06:52:25 UTC
 * Running compile phase for ruby21 ...
rake aborted!
LoadError: cannot load such file -- rake/extensiontask
/var/tmp/portage/dev-ruby/redcloth-4.3.2/work/ruby21/redcloth-4.3.2/tasks/compile.rake:19:in `<top (required)>'
/var/tmp/portage/dev-ruby/redcloth-4.3.2/work/ruby21/redcloth-4.3.2/Rakefile:7:in `load'
/var/tmp/portage/dev-ruby/redcloth-4.3.2/work/ruby21/redcloth-4.3.2/Rakefile:7:in `block in <top (required)>'

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: desktop-gcc5_20170519-190644

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
  [3]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
  [2]   ruby22 (with Rubygems)
java-config:
The following VMs are available for generation-2:
Available Java Virtual Machines:
  (none found)
Comment 1 Toralf Förster gentoo-dev 2017-05-25 06:52:28 UTC
Created attachment 474190 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-05-25 06:52:31 UTC
Created attachment 474192 [details]
dev-ruby:redcloth-4.3.2:20170525-004249.log
Comment 3 Toralf Förster gentoo-dev 2017-05-25 06:52:35 UTC
Created attachment 474194 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-05-25 06:52:38 UTC
Created attachment 474196 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-05-25 06:52:41 UTC
Created attachment 474198 [details]
etc.portage.tbz2
Comment 6 Hans de Graaff gentoo-dev 2017-05-26 07:23:47 UTC
(In reply to Toralf Förster from comment #0)
>  * Running compile phase for ruby21 ...
> rake aborted!
> LoadError: cannot load such file -- rake/extensiontask

This is provided by dev-ruby/rake-compiler which is a build-time dependency.