Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 618308 - media-video/vlc-2.2.6 version bump
Summary: media-video/vlc-2.2.6 version bump
Status: RESOLVED DUPLICATE of bug 619494
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://www.videolan.org/developers/v...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-12 17:24 UTC by Frank Krömmelbein
Modified: 2017-06-06 14:30 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Krömmelbein 2017-05-12 17:24:14 UTC
From URL, this looks like security related fixes:

Fix ADPCM heap corruption (FG-VD-16-067)
Fix DVD/LPCM heap corruption (FG-VD-16-090)
Comment 1 Jonas Stein gentoo-dev 2017-05-12 19:39:02 UTC
https://trac.videolan.org/vlc/ticket/17448
Comment 2 James Le Cuirot gentoo-dev 2017-05-15 21:52:52 UTC
I successfully built it by just renaming and commenting out ${PN}-2.2.4-qt57.patch. Unfortunately it didn't fix my weird VDPAU issue.
Comment 3 Frank Krömmelbein 2017-05-24 15:24:12 UTC
New upstream release 2.2.6 is now available with more security fixes.
Comment 4 Michael Palimaka (kensington) gentoo-dev 2017-06-06 13:45:19 UTC
Fixed in git.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b2bcbfd9976f1f236c65affb1c954f43604284a3
Comment 5 Thomas Deutschmann gentoo-dev Security 2017-06-06 14:30:42 UTC
Thanks for the report and the bump. We will proceed in bug 619494.

*** This bug has been marked as a duplicate of bug 619494 ***