Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 618206 - media-libs/mesa-17.1: i915g is broken
Summary: media-libs/mesa-17.1: i915g is broken
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 627278
  Show dependency tree
 
Reported: 2017-05-11 15:50 UTC by Francesco Turco
Modified: 2018-01-05 18:13 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.log,7.63 KB, text/x-log)
2017-05-11 15:50 UTC, Francesco Turco
Details
qupzilla backtrace (basic) (qupzilla-basic.log,8.63 KB, text/x-log)
2017-05-11 15:54 UTC, Francesco Turco
Details
qupzilla backtrace (full) (qupzilla-full.log,163.80 KB, text/x-log)
2017-05-11 15:54 UTC, Francesco Turco
Details
mpv backtrace (basic) (mpv-basic.log,898 bytes, text/x-log)
2017-05-11 15:55 UTC, Francesco Turco
Details
mpv backtrace (full) (mpv-full.log,13.42 KB, text/x-log)
2017-05-11 15:55 UTC, Francesco Turco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco Turco 2017-05-11 15:50:42 UTC
Created attachment 472324 [details]
emerge --info

Since I upgraded media-libs/mesa from version 17.0.4 to version 17.1.0_rc4 I cannot start QupZilla anymore because it produces a segmentation fault. Mpv crashes too when playing any video. media-libs/mesa-9999 causes segmentation fault too. media-libs/mesa-17.0.5 works fine.

I have an Intel GPU (Q35 chipset).

# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02)

See also: https://bugs.freedesktop.org/show_bug.cgi?id=100984
Comment 1 Francesco Turco 2017-05-11 15:54:20 UTC
Created attachment 472326 [details]
qupzilla backtrace (basic)
Comment 2 Francesco Turco 2017-05-11 15:54:49 UTC
Created attachment 472328 [details]
qupzilla backtrace (full)
Comment 3 Francesco Turco 2017-05-11 15:55:16 UTC
Created attachment 472330 [details]
mpv backtrace (basic)
Comment 4 Francesco Turco 2017-05-11 15:55:41 UTC
Created attachment 472332 [details]
mpv backtrace (full)
Comment 5 Alexander Tsoy 2017-05-14 23:08:07 UTC
Yes, i915g driver is broken in mesa 17.1. Temporary workaround is to switch to the classic i915 driver.
Comment 6 Davide Pesavento gentoo-dev 2017-05-14 23:32:51 UTC
not sure why we're CC'ed here...
Comment 7 Francesco Turco 2017-05-20 12:13:02 UTC
After running "eselect mesa set i915 2" (gallium) both qupzilla and mpv crash.
After running "eselect mesa set i915 1" (classic) both qupzilla and mpv run successfully.
Comment 8 David Flogeras 2017-11-13 15:37:32 UTC
Has anyone confirmed any newer ~arch versions of mesa fix this behaviour?

I'm under the impression that the gallium driver is newer/the future, but I also found this from debian:

http://metadata.ftp-master.debian.org/changelogs/main/m/mesa/unstable_changelog

The interesting part being:

***
Stop building i915g at all, it's apparently never going to be a suitable replacement for i915c.
***
Comment 9 lekto 2017-12-10 17:52:02 UTC
I don't know if it's really related, but I got segfault while watching movie in mpv.
I pause mpv, turn off fullscreen and alt+tab to another window, but when I want go back to mpv, sometimes window is gone and I got this:
mpv/vo[17458]: segfault at 85 ip 00007f47e29c7033 sp 00007f47e3ffd4a0 error 4 in i965_dri.so[7f47e261c000+726000]

Also swiching youtube movie fullscreen on and off sometimes make segfault, I need hold F button and after few seconds got segfault:
Chrome_~dThread[9277]: segfault at 0 ip 00007f4ee6f70623 sp 00007f4ee1482ad0 error 6 in libxul.so[7f4ee6b6a000+4a02000] 

[ebuild   R    ] www-client/firefox-57.0.1::gentoo  USE="dbus eme-free hwaccel screenshot system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite -bindist -custom-cflags -custom-optimization -debug -gmp-autoupdate -hardened -jack (-neon) -nsplugin -pgo -pulseaudio (-selinux) -startup-notification {-test} -wifi" L10N="en-GB -ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW" 0 KiB
[ebuild   R    ] media-libs/mesa-17.3.0_rc5::gentoo  USE="classic dri3 egl gallium gbm gles2 llvm nptl opencl vaapi vdpau wayland -bindist -d3d9 -debug -gles1 -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -valgrind -vulkan -xa -xvmc" VIDEO_CARDS="i965 intel (-freedreno) -i915 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware" 0 KiB
[ebuild   R    ] media-video/mpv-0.27.0::gentoo  USE="X alsa cli egl iconv libass lua opengl uchardet vaapi vdpau wayland xv zlib (-aqua) -archive -bluray -cdda (-coreaudio) -cplugins -cuda -doc -drm -dvb -dvd -encode -gbm -jack -javascript -jpeg -lcms (-libav) -libcaca -libmpv -luajit -openal -oss -pulseaudio (-raspberry-pi) -rubberband -samba -sdl (-selinux) {-test} -tools -v4l -zsh-completion" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 0 KiB
Comment 10 Kajzer 2017-12-11 22:30:24 UTC
I had that problem with 17.1.10, because of that I had to unmask 17.2.6 and the problem is fixed there.
Comment 11 Kajzer 2017-12-20 01:39:12 UTC
With kernel 4.14.7 I'm getting segfaults, tried different versions of Mesa and it was the same thing, surprisingly even with Mesa set to classic, have no clue what's changed in the kernel to cause this, had to revert back to 4.12.12
Comment 12 David Flogeras 2017-12-31 14:57:46 UTC
For what it's worth, after upgrading to the now stable mesa-17.2.7 on this x86 machine, switching back to gallium now works again for me.
Comment 13 Kajzer 2017-12-31 15:24:34 UTC
My previous comment with kernel 4.14.x... turned out I get segfaults if uxa is set, with sna enabled there are no problems, maybe uxa is getting dropped or it already is, I'm not sure.
Comment 14 Christian Buchinger 2018-01-04 07:03:09 UTC
FTR upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=101055

Testing with GMA3150 (Atom N550) I wasn't able to run Plasma (kwin segfaults) on gallium with any version >17.0.6
Comment 15 Kajzer 2018-01-04 23:02:13 UTC
(In reply to cb1 from comment #14)
> FTR upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=101055
> 
> Testing with GMA3150 (Atom N550) I wasn't able to run Plasma (kwin
> segfaults) on gallium with any version >17.0.6

I had the same problem and it took me a while to figure it out.
Problem is that in mesa versions >17.0.6 opengl 2.1 is disabled and only 1.4 is available. But, you can enable 2.1 again with driconf, make sure that ARB_fragment_shader and ARB_occlusion_query keys are enabled, one of those wasn't in my case, then reboot. Gallium will work again without segfaults, in fact opengl 2.1 will always be enabled, even when you choose classic.
Comment 16 Christian Buchinger 2018-01-05 15:47:14 UTC
(In reply to Kajzer from comment #15)
> I had the same problem and it took me a while to figure it out.
> Problem is that in mesa versions >17.0.6 opengl 2.1 is disabled and only 1.4
> is available. But, you can enable 2.1 again with driconf, make sure that
> ARB_fragment_shader and ARB_occlusion_query keys are enabled, one of those
> wasn't in my case, then reboot. Gallium will work again without segfaults,
> in fact opengl 2.1 will always be enabled, even when you choose classic.

During my tests in December I already tried that following a note in the Arch wiki which added these two options to /etc/drirc [1]. I tried again with driconf and a users ~/.drirc which didn't change anything at first sight. Now I found the following:

* Running gentoo-sources-4.9.72 and mesa-17.2.7
* Gallium enabled for i915
* glxinfo says it's in fact running on OpenGL 2.1
* kwin_x11 crashed because of a window decoration (Freeze for plasma); Set to Breeze, kwin comes up now
* Other random parts of plasma and/or things with qt5 are now segfaulting, eg. kdeconnect and the desktop design part of plasma system setting
* plasmashell doesn't run anymore (but I guess it's caused by another fancy design setting on my profile, with an empty dummy profile it started fine)

I'm still tinkering with it (within my capabilities) but it feels like some gfx functions are entirely missing or faulty.


[1] https://wiki.archlinux.org/index.php/intel_graphics#OpenGL_2.1_with_i915_driver
Comment 17 Kajzer 2018-01-05 16:29:46 UTC
I'm using 945G gpu btw.

$ inxi -G                                                                                                                                                                                                              
Graphics:  Card: Intel 82945G/GZ Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 ) driver: intel Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel 945G version: 2.1 Mesa 17.3.1

maybe I would have the same problems if I was using plasma, I'm on AwesomeWM, the only problem I had with this was playing videos, they would segfault, but the problem was both in the kernel and mesa, as for kernel I couldn't use uxa anymore, and segfaults was because of opengl 2.1 and gallium, now that I've enabled opengl 2.1 with driconf that problem was gone too.
Right now I'm on Mesa 17.3.1 and kernel 4.14.11
in /etc/X11/xorg.conf.d/20-intel.conf I have :
Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"      
	Option      "AccelMethod"  "sna"
EndSection

Can't notice any problems, finally I might add.
We don't have the same chip but it's the same gen, hope you find the right combo.