Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 617774 - app-eselect/eselect-vi-1.1.9: vis doesn't show up in 'eselect vi list'
Summary: app-eselect/eselect-vi-1.1.9: vis doesn't show up in 'eselect vi list'
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 2 votes (vote)
Assignee: Vim Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-07 22:15 UTC by Thomas Capricelli
Modified: 2020-03-01 13:53 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to add vis to eselect-vi (file_617774.txt,458 bytes, patch)
2020-03-01 13:53 UTC, sirvertalot
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Capricelli 2017-05-07 22:15:52 UTC
Once app-editors/vis-0.3 is installed, I can't see it with eselect : 

% eselect vi list
Available vi implementations:
  [1]   vim *
  [2]   nvim
  [3]   busybox
Comment 1 Ulrich Müller gentoo-dev 2017-05-13 18:48:22 UTC
Not a problem of eselect proper, but of the vi module. Reassigning to its maintainer (namely, vim project).
Comment 2 sirvertalot 2020-02-29 01:36:46 UTC
Despite not showing up in $ eselect vi list, you can still set the symlink:

$ eselect vi list
Available vi implementations:
  [1]   vim
  [2]   busybox

$ eselect vi show
Current vi implementation:
  vis
Comment 3 sirvertalot 2020-03-01 13:53:03 UTC
Created attachment 616722 [details, diff]
patch to add vis to eselect-vi

This works, although you need to unmask ~amd64 because only eselect-vi-1.1.9-r1 is EAPI>5.