Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 615964 - media-video/gxine-0.5.908-r1 : checking which logo format to use... configure: error: no available demuxer for the logo image - rebuild/reinstall xine-lib?
Summary: media-video/gxine-0.5.908-r1 : checking which logo format to use... configure...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-18 16:06 UTC by Toralf Förster
Modified: 2018-03-07 02:18 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,5.42 KB, text/plain)
2017-04-18 16:06 UTC, Toralf Förster
Details
config.log.tbz2 (config.log.tbz2,12.73 KB, application/x-bzip)
2017-04-18 16:06 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,404.77 KB, text/plain)
2017-04-18 16:06 UTC, Toralf Förster
Details
environment (environment,127.31 KB, text/plain)
2017-04-18 16:06 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,56.57 KB, application/x-bzip)
2017-04-18 16:06 UTC, Toralf Förster
Details
media-video:gxine-0.5.908-r1:20170418-100852.log (media-video:gxine-0.5.908-r1:20170418-100852.log,11.25 KB, text/plain)
2017-04-18 16:06 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,34.05 KB, application/x-bzip)
2017-04-18 16:06 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-04-18 16:06:36 UTC
checking for library containing log10... none required
checking for libxine >= 1.1.8... yes
checking which logo format to use... configure: error: no available demuxer for the logo image - rebuild/reinstall xine-lib?

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-video/gxine-0.5.908-r1/work/gxine-0.5.908/config.log

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named 13.0-systemd-abi32+64_20170409-195332) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.5 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
  [2]   ruby22 (with Rubygems)
java-config:
The following VMs are available for generation-2:
Comment 1 Toralf Förster gentoo-dev 2017-04-18 16:06:39 UTC
Created attachment 470332 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-04-18 16:06:42 UTC
Created attachment 470334 [details]
config.log.tbz2
Comment 3 Toralf Förster gentoo-dev 2017-04-18 16:06:45 UTC
Created attachment 470336 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-04-18 16:06:48 UTC
Created attachment 470338 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-04-18 16:06:51 UTC
Created attachment 470340 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-04-18 16:06:54 UTC
Created attachment 470342 [details]
media-video:gxine-0.5.908-r1:20170418-100852.log
Comment 7 Toralf Förster gentoo-dev 2017-04-18 16:06:57 UTC
Created attachment 470344 [details]
temp.tbz2
Comment 8 Thomas Capricelli 2017-11-23 02:42:38 UTC
I can confirm this bug. Could it be related to USE flags ? Here are mine :


[I] media-libs/xine-lib
     Available versions:  (1) 1.2.6-r2 (~)1.2.8 **1.2.9999
       {+X a52 aac aalib +alsa altivec bluray +css directfb dts dvb dxr3 fbcon flac fusionsound gtk imagemagick ipv6 jack jpeg libav libcaca mad +mmap mng modplug musepack nls opengl oss pulseaudio samba sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack +xcb xinerama +xv xvmc}
     Installed versions:  1.2.8(1)(03:36:59 23/11/2017)(X a52 aac alsa css dts flac ipv6 jack jpeg mad mmap mng nls opengl sdl speex theora truetype v4l vcd vdpau vorbis vpx wavpack xcb xinerama xv -aalib -altivec -bluray -directfb -dvb -dxr3 -fbcon -fusionsound -gtk -imagemagick -libav -libcaca -modplug -musepack -oss -pulseaudio -samba -vaapi -vdr -vidix -vis -xvmc)
     Homepage:            http://xine.sourceforge.net/
     Description:         Core libraries for Xine movie player
Comment 9 Pacho Ramos gentoo-dev 2018-03-01 11:05:29 UTC
does 0.5.909 work for you?
Comment 10 Michael Yagliyan 2018-03-02 02:18:47 UTC
Not sure why this was resolved/fixed.  There is no information provided on what the fix is, and I tried gxine-0.5.909 -- it fails to build in the same way.  This ticket should be re-opened.
Comment 11 Pacho Ramos gentoo-dev 2018-03-05 14:59:58 UTC
It is the gtk USE flag: it's needed to enable it in xine-lib to build gxine
Comment 12 Michael Yagliyan 2018-03-07 02:18:02 UTC
Confirmed.  I enabled the gtk useflag for xine-lib, and then successfully emerged gxine-0.5.907-r1.

So the gxine ebuild should be updated to require that xine-lib have that useflag enabled.