Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 615778 - media-libs/alsa-lib Application crashes: problem with alsamixer and bluetooth output
Summary: media-libs/alsa-lib Application crashes: problem with alsamixer and bluetooth...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: ARM64 Linux
: Normal normal (vote)
Assignee: Gentoo ALSA team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-16 19:52 UTC by Marek Duranik
Modified: 2019-06-30 11:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_615778.txt,5.34 KB, text/plain)
2017-04-17 10:08 UTC, Marek Duranik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Duranik 2017-04-16 19:52:08 UTC
Hello,

I tried switch audio output to bluetooth device with command "alsamixer -D bluealsa", but still I got same error message. I tried compile all reachable version 1.0.29 1.1.2 1.1.3. Error message is same on all version. Compilation all versions finish without problem. 

pi64 ~ # alsamixer -D bluealsa 
 ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.1.3/work/alsa-lib-1.1.3/src/dlmisc.c:142:(snd_dlsym_verify) unable to verify version for symbol _snd_ctl_bluealsa_open 
 ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.1.3/work/alsa-lib-1.1.3/src/dlmisc.c:263:(snd1_dlobj_cache_get) symbol _snd_ctl_bluealsa_open is not defined inside /usr/lib64/alsa-lib/libasound_module_ctl_bluealsa.so 
 cannot open mixer: No such device or address

Bluetooth device configuration probably work fine:

pi64 ~ # bluetoothctl 
 [NEW] Controller B8:27:EB:2D:BA:05 BlueZ 5.43 [default] 
 [NEW] Device 58:51:00:50:A0:B2 AJ-69 
 [AJ-69]# devices 
 Device 58:51:00:50:A0:B2 AJ-69 
 [AJ-69]# info 58:51:00:50:A0:B2 
 Device 58:51:00:50:A0:B2 
         Name: AJ-69 
         Alias: AJ-69 
         Class: 0x240404 
         Icon: audio-card 
         Paired: yes 
         Trusted: yes 
         Blocked: no 
         Connected: yes 
         LegacyPairing: no 
         UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb) 
         UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb) 
         UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb) 
         UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb) 
         UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
Comment 1 Marek Duranik 2017-04-17 10:08:00 UTC
Created attachment 470222 [details]
emerge --info
Comment 2 Marek Duranik 2017-04-19 15:38:03 UTC
I compiled alasa-lib version 1.1.2 without distcc and error message is now different:

madurani@pi64 ~ $ alsamixer -D bluealsa
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.1.2/work/alsa-lib-1.1.2/src/dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib64/alsa-lib/libasound_module_ctl_bluealsa.so
cannot open mixer: No such device or address
Comment 3 Pacho Ramos gentoo-dev 2019-06-30 11:05:54 UTC
please retry on an updated system